remove aur/knockd, now in abs/community/knockd

This commit is contained in:
Jason Plum 2015-09-13 08:04:29 -04:00
parent c898f59cbe
commit 3094b556f5
5 changed files with 0 additions and 99 deletions

View file

@ -1,38 +0,0 @@
# $Id: PKGBUILD 20410 2008-12-03 09:44:51Z tom $
# Maintainer: Mike Sampson <mike at sambodata dot com>
# Contriburor: Steven <steven at stebalien dot com>
# Contributor: Aaron Griffin <aaron@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=knockd
pkgver=0.7
pkgrel=1
pkgdesc="A simple port-knocking daemon"
arch=('i686' 'x86_64')
url="http://www.zeroflux.org/projects/knock"
license=(GPL)
depends=('libpcap>=1.0.0')
backup=('etc/knockd.conf')
source=(http://www.zeroflux.org/proj/knock/files/knock-$pkgver.tar.gz
knockd knockd.logrotate knockd.service limits.h.patch)
md5sums=('cb6373fd4ccb42eeca3ff406b7fdb8a7'
'72302d899887996694586c3d479de245'
'56a4113ec89ba2e96f79ab23c914d52a'
'da806fb9fbdf638df4e0011070ff9ef1'
'e56dc7359f36c3b07da6710c404d671e')
build() {
cd "$srcdir/knock-$pkgver"
patch -Np0 -i "$srcdir/limits.h.patch"
./configure --prefix=/usr --sbin=/usr/bin --sysconfdir=/etc
make
}
package() {
cd "$srcdir/knock-$pkgver"
make DESTDIR="$pkgdir" MANDIR=/usr/share/man install
#install -D -m755 "$srcdir/knockd" "$pkgdir/etc/rc.d/knockd"
install -D -m755 "$srcdir/knockd.service" "$pkgdir/usr/lib/systemd/system/knockd.service"
install -D -m644 "$srcdir/knockd.logrotate" "$pkgdir/etc/logrotate.d/knockd"
}

View file

@ -1,37 +0,0 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
PID=`pidof -o %PPID /usr/sbin/knockd`
case "$1" in
start)
stat_busy "Starting Port-Knocking Daemon"
if [ -z "$PID" ]; then
/usr/sbin/knockd -d
fi
if [ ! -z "$PID" -o $? -gt 0 ]; then
stat_fail
else
add_daemon knockd
stat_done
fi
;;
stop)
stat_busy "Stopping Port-Knocking Daemon"
[ ! -z "$PID" ] && kill $PID &> /dev/null
if [ $? -gt 0 ]; then
stat_fail
else
rm_daemon knockd
stat_done
fi
;;
restart)
$0 stop
sleep 1
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac

View file

@ -1,5 +0,0 @@
/var/log/knockd.log {
missingok
notifempty
delaycompress
}

View file

@ -1,9 +0,0 @@
[Unit]
Description=Port-Knocking Daemon
After=network.target
[Service]
ExecStart=/usr/sbin/knockd
[Install]
WantedBy=multi-user.target

View file

@ -1,10 +0,0 @@
--- src/knockd.c.orig 2008-12-03 07:21:14.643255773 +0000
+++ src/knockd.c 2008-12-03 07:24:59.606701396 +0000
@@ -46,6 +46,7 @@
#include <syslog.h>
#include <pcap.h>
#include <errno.h>
+#include <limits.h>
#include "list.h"
static char version[] = "0.5";