community/supercollider to 3.9.1-2

This commit is contained in:
Kevin Mihelich 2018-03-09 00:33:23 +00:00
parent d0e3aa83e0
commit 30a80d6a0f
2 changed files with 16 additions and 33 deletions

View file

@ -8,8 +8,8 @@
_name=SuperCollider
pkgname=supercollider
pkgver=3.9.0
pkgrel=1
pkgver=3.9.1
pkgrel=2
pkgdesc="An environment and programming language for real time audio synthesis and algorithmic composition"
arch=('x86_64')
url="https://supercollider.github.io"
@ -20,31 +20,34 @@ optdepends=('emacs: emacs interface'
'gedit: gedit interface')
source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pkgver}/${_name}-${pkgver}-Source-linux.tar.bz2")
install="${pkgname}.install"
sha512sums=('52274ce0c5e604e44f844e77bb7245d6829c49a002ac0c383c3d150f48c60bd79b8f0481cd629e13544d6a01f2c5fd05d92d24d2c24602df2bf798cff94c0b0f')
sha512sums=('cd18f250f53c576a6636b98f2c53d0a2d58e885b37b2612d227a7e8043e14b2840e34a32bcfa69a04da56cc9ef96a1e5aa1cd8de15e54db65ace665a1dd0770b')
prepare() {
cd "${_name}-Source"
mv -v "${_name}-Source" "${pkgname}-${pkgver}"
cd "${pkgname}-${pkgver}"
# requires out-of-tree build
[ -d bld ] || mkdir bld && cd bld
mkdir -v bld
}
build() {
cd "${_name}-Source/bld"
cd "${pkgname}-${pkgver}/bld"
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DLIBSCSYNTH=ON \
-DFORTIFY=ON \
-DSC_VIM=OFF \
-DSSE=OFF -DSSE2=OFF -DSUPERNOVA=OFF -DNOVA_SIMD=ON -DNATIVE=OFF \
-DCMAKE_C_FLAGS="${CFLAGS}"
# cmake broken for system libraries:
# https://github.com/supercollider/supercollider/issues/3513
# -DSYSTEM_BOOST=ON \
# -DSYSTEM_YAMLCPP=ON \
make
}
package() {
cd "${_name}-Source/bld"
cd "${pkgname}-${pkgver}/bld"
make DESTDIR="${pkgdir}" install
cd ..
install -Dm644 AUTHORS ${pkgdir}/usr/share/doc/${pkgname}/AUTHORS
install -Dm644 CHANGELOG.md ${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG.md
install -Dm644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README.md
install -Dm644 README_LINUX.md ${pkgdir}/usr/share/doc/${pkgname}/README_LINUX.md
install -t "${pkgdir}/usr/share/doc/${pkgname}/" \
-vDm644 ../{AUTHORS,{CHANGELOG,README,README_LINUX}.md}
}

View file

@ -1,20 +0,0 @@
--- server/plugins/DiskIO_UGens.cpp 2016-08-22 10:12:21.000000000 +0200
+++ server/plugins/DiskIO_UGens.cpp.fix 2017-12-06 23:45:39.043242894 +0100
@@ -27,6 +27,7 @@
#include <sndfile.h>
#include <atomic>
+#include <functional>
#include <new>
#include <SC_Lock.h>
--- lang/LangPrimSource/PyrSerialPrim.cpp 2016-08-22 10:12:21.000000000 +0200
+++ lang/LangPrimSource/PyrSerialPrim.cpp.fix 2017-12-07 00:06:12.756776492 +0100
@@ -27,6 +27,7 @@
#include <errno.h>
#include <fcntl.h>
+#include <functional>
#include <stdint.h>
#include <stdio.h>
#include <stdlib.h>