extra/rust to 1.64.0-1

This commit is contained in:
Kevin Mihelich 2022-09-24 17:53:44 +00:00
parent 851236c583
commit 30dffdf13f
4 changed files with 37 additions and 15 deletions

View file

@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
index b1fae356d893..a9783708d7a7 100644
index 6291b204e485..d0a193a323a6 100644
--- a/src/bootstrap/dist.rs
+++ b/src/bootstrap/dist.rs
@@ -950,7 +950,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
@@ -977,7 +977,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
let dirent = dirent.expect("read dir entry");
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {

View file

@ -24,10 +24,10 @@ targets, as things break when this is done:
4 files changed, 12 insertions(+), 3 deletions(-)
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
index 14ad1a42a7d8..efd47c47293b 100644
index 6a8298605a23..89272b760791 100644
--- a/compiler/rustc_session/src/config.rs
+++ b/compiler/rustc_session/src/config.rs
@@ -1867,7 +1867,7 @@ pub fn parse_target_triple(
@@ -1820,7 +1820,7 @@ pub fn parse_target_triple(
early_error(error_format, &format!("target file {path:?} does not exist"))
})
}
@ -37,7 +37,7 @@ index 14ad1a42a7d8..efd47c47293b 100644
}
}
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
index 0998c618f31a..91c79c7e4ff0 100644
index 765803d16928..75e6df9a8f3a 100644
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
@@ -9,7 +9,7 @@ pub fn target() -> Target {
@ -50,10 +50,10 @@ index 0998c618f31a..91c79c7e4ff0 100644
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
f64:32:64-f80:32-n8:16:32-S128"
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
index da0589cdd209..dc9865bdf64a 100644
index f7abeafd38f1..815586e7105d 100644
--- a/compiler/rustc_target/src/spec/mod.rs
+++ b/compiler/rustc_target/src/spec/mod.rs
@@ -2506,6 +2506,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
@@ -2549,6 +2549,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
Ok(TargetTriple::TargetJson { path_for_rustdoc: canonicalized_path, triple, contents })
}
@ -70,7 +70,7 @@ index da0589cdd209..dc9865bdf64a 100644
///
/// If this target is a path, the file name (without extension) is returned.
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
index e525cfdde14f..2dfe25f4f238 100644
index 956be0353fa3..3f133efef343 100644
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
@@ -15,7 +15,7 @@ pub fn target() -> Target {

View file

@ -9,10 +9,10 @@ We don't ship rust-lld.
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
index de7b7374af31..9ea181ab8d8f 100644
index 9216d3e7b65f..75d038a42a69 100644
--- a/compiler/rustc_target/src/spec/wasm_base.rs
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
@@ -99,8 +99,7 @@ pub fn options() -> TargetOptions {
@@ -89,8 +89,7 @@ macro_rules! args {
// arguments just yet
limit_rdylib_exports: false,

View file

@ -17,7 +17,7 @@ highmem=1
pkgbase=rust
pkgname=(rust rust-src)
epoch=1
pkgver=1.63.0
pkgver=1.64.0
pkgrel=1
pkgdesc="Systems programming language focused on safety, speed and concurrency"
url=https://www.rust-lang.org/
@ -36,12 +36,12 @@ source=(
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
remove-include-linux-fs.h.patch
)
sha256sums=('1f9580295642ef5da7e475a8da2397d65153d3f2cb92849dbd08ed0effca99d0'
sha256sums=('b3cd9f481e1a2901bf6f3808d30c69cc4ea80d93c4cc4e2ed52258b180381205'
'SKIP'
'c901a9bb036c29ca092f7dbc8b447efdd9aa1044a902a88f9d024cb22681dc19'
'7080a88e44234aa363ba6321f319c8d9621382dd9581748a43847dae005e55bd'
'5137df0a3399e279db4c5b83ae8e99d2c1977f62aec2f90521edb02f51597064'
'26bf232d144b81a303ed91f6a331ddf004c5d9fefd41a11e36b61812a34459aa'
'84ae2843d5ed83e9400e96d5f2d8cf3d1b89809bea76897c2762743460e06a87'
'1986e62bd2826eacaadd681e294943d890d75f24fd1f54fbd4015c3c622ac097'
'8fa64a2bdfb798184bde1c80d4775889a91d8b2ed076a6ea29ea99df9a2098cc'
'34ed866e313e4580130a50118a4410d36fa0159123982521b6ef049439fc32ad')
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
474E22316ABF4785A88C6E8EA2C794A986419D8A) # Tom Stellard <tstellar@redhat.com>
@ -108,15 +108,37 @@ deny-warnings = false
compression-formats = ["gz"]
[target.x86_64-unknown-linux-gnu]
cc = "/usr/bin/gcc"
cxx = "/usr/bin/g++"
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"
llvm-config = "/usr/bin/llvm-config"
[target.i686-unknown-linux-gnu]
cc = "/usr/bin/gcc"
cxx = "/usr/bin/g++"
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"
[target.aarch64-unknown-linux-gnu]
cc = "/usr/bin/gcc"
cxx = "/usr/bin/g++"
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"
llvm-config = "/usr/bin/llvm-config"
[target.armv7-unknown-linux-gnueabihf]
cc = "/usr/bin/gcc"
cxx = "/usr/bin/g++"
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"
llvm-config = "/usr/bin/llvm-config"
[target.arm-unknown-linux-gnueabihf]
cc = "/usr/bin/gcc"
cxx = "/usr/bin/g++"
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"
llvm-config = "/usr/bin/llvm-config"
END