community/libcec to 4.0.0-1

This commit is contained in:
Kevin Mihelich 2016-11-26 20:55:10 +00:00
parent 8066d80e70
commit 310c356b2d
2 changed files with 9 additions and 43 deletions

View file

@ -1,32 +0,0 @@
From 4144242b59b65d36cf004778c172e351403b1a6a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 3 Mar 2016 17:58:16 -0700
Subject: [PATCH] remove default to zero
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
src/libcec/cmake/CheckPlatformSupport.cmake | 8 --------
1 file changed, 8 deletions(-)
diff --git a/src/libcec/cmake/CheckPlatformSupport.cmake b/src/libcec/cmake/CheckPlatformSupport.cmake
index b8a16c8..677469e 100644
--- a/src/libcec/cmake/CheckPlatformSupport.cmake
+++ b/src/libcec/cmake/CheckPlatformSupport.cmake
@@ -22,14 +22,6 @@ set(PLATFORM_LIBREQUIRES "")
include(CheckFunctionExists)
include(FindPkgConfig)
-# defaults
-set(HAVE_RANDR 0)
-set(HAVE_LIBUDEV 0)
-set(HAVE_RPI_API 0)
-set(HAVE_TDA995X_API 0)
-set(HAVE_EXYNOS_API 0)
-set(HAVE_P8_USB_DETECT 0)
-set(HAVE_DRM_EDID_PARSER 0)
# Pulse-Eight devices are always supported
set(HAVE_P8_USB 1)
--
2.7.1

View file

@ -5,14 +5,14 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - Exynos support on v7
# - patch to remove default to zero forces
# - patch for ODROID-C2 CEC driver
# - Amlogic support on v8
# - upstream commit to fix AOCEC build
buildarch=14
pkgname=libcec
pkgver=3.1.0
pkgrel=2.1
pkgver=4.0.0
pkgrel=1
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter"
arch=('i686' 'x86_64')
url="http://libcec.pulse-eight.com/"
@ -20,16 +20,14 @@ license=('GPL')
makedepends=('cmake')
depends=('udev' 'lockdev' 'p8-platform' 'libxrandr')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/$pkgname/archive/$pkgname-$pkgver.tar.gz"
'0001-remove-default-to-zero.patch'
'https://patch-diff.githubusercontent.com/raw/Pulse-Eight/libcec/pull/218.patch')
sha256sums=('09109d21a1b03f42c9e341d12600f2e4c41038d640269fa75408e2d36126f921'
'33ce3121e393d7f5c162487d82aac9372a246cdb6eca73f0cfbde61bfaffa50f'
'7801b62f66925c36d475b9570aec636581df554406fee3973af5a34f2400f512')
'https://github.com/Pulse-Eight/libcec/commit/399e177a56fc4b216ee6e7fb400c03c9b91be283.patch')
sha256sums=('4c6ee8e44f2e6b28e3dfbee6c77df8d18605150ef69ab0564728b79a92a646ed'
'd5faf272bce29942286dc44daa51d0480629f6818ae011379d1e4b73dd373cca')
prepare() {
cd "$pkgname-$pkgname-$pkgver"
patch -p1 -i ../0001-remove-default-to-zero.patch
patch -p1 -i ../218.patch
patch -p1 -i ../399e177a56fc4b216ee6e7fb400c03c9b91be283.patch
}
build() {