mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox to 109.0.1-1
This commit is contained in:
parent
388b1c782d
commit
312d8a5916
2 changed files with 3 additions and 34 deletions
|
@ -1,25 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: stransky <stransky@redhat.com>
|
||||
Date: Thu, 15 Dec 2022 08:09:22 +0000
|
||||
Subject: [PATCH] Bug 1804973 [Wayland] Check size for valid EGLWindows only
|
||||
r=emilio
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D164651
|
||||
---
|
||||
widget/gtk/MozContainerWayland.cpp | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/widget/gtk/MozContainerWayland.cpp b/widget/gtk/MozContainerWayland.cpp
|
||||
index 954c650af533..2a4a492077c3 100644
|
||||
--- a/widget/gtk/MozContainerWayland.cpp
|
||||
+++ b/widget/gtk/MozContainerWayland.cpp
|
||||
@@ -704,6 +704,9 @@ bool moz_container_wayland_egl_window_needs_size_update(MozContainer* container,
|
||||
nsIntSize aSize,
|
||||
int aScale) {
|
||||
MozContainerWayland* wl_container = &container->wl_container;
|
||||
+ if (!wl_container->eglwindow) {
|
||||
+ return false;
|
||||
+ }
|
||||
if (wl_container->buffer_scale != aScale) {
|
||||
return true;
|
||||
}
|
|
@ -10,7 +10,7 @@
|
|||
highmem=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=109.0
|
||||
pkgver=109.0.1
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
url="https://www.mozilla.org/firefox/"
|
||||
|
@ -70,25 +70,22 @@ source=(
|
|||
$pkgname.desktop
|
||||
identity-icons-brand.svg
|
||||
0001-libwebrtc-screen-cast-sync.patch
|
||||
0002-Bug-1804973-Wayland-Check-size-for-valid-EGLWindows-.patch
|
||||
build-arm-libopus.patch
|
||||
)
|
||||
validpgpkeys=(
|
||||
'14F26682D0916CDD81E37B6D61B7B526D98F0353' # Mozilla Software Releases <release@mozilla.com>
|
||||
)
|
||||
sha256sums=('0678a03b572b5992fb85f0923a25b236acf81e5ea2c08e549b63a56076a69351'
|
||||
sha256sums=('5e43fdfb3923ee3a7ae7bc91ef3377a3fc6f8a0c1b87436c19b29458b0d731d9'
|
||||
'SKIP'
|
||||
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
|
||||
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9'
|
||||
'b1ce6936749ab1614bbce4fddc87058341ed207dde77af609fdc5ac83538517a'
|
||||
'34439dfb17371520e5e99444096ded97325ab2559b9039ae16055975d015ac51'
|
||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9')
|
||||
b2sums=('8032c4250c975dfbe159eac8db3a8909c45b9ceccba206f7a5aba9650bcb40df658a50890efa5572d9cacc22411d6f1a2253905fff2d0791604debfebd986c29'
|
||||
b2sums=('37370cced42da5850ad8cc4d90c0e7c1a700b9fa5c281c57ef7c3c243898b7ac55a8f183360585b24b164b8572816c9e216114594371bac3f2e3c1d85c2f6408'
|
||||
'SKIP'
|
||||
'e18f2c22e394ca3b6758bc130245b254947e4d15921be3da443d6d7c3c4b0d22ead1b39fbc10a4f896edd19e2a1dffbd1cbb34dc4beb0621a6ddb70ccc53b3a7'
|
||||
'63a8dd9d8910f9efb353bed452d8b4b2a2da435857ccee083fc0c557f8c4c1339ca593b463db320f70387a1b63f1a79e709e9d12c69520993e26d85a3d742e34'
|
||||
'3a7de17f0a56c4ccbbd4754a63a8798f787e87acc947b0fc0c1e5086c99337979b7f66a741fdc5475b34085eaf80dbc99d742c22a95d6ed412e38012794a44c9'
|
||||
'ad4618e6c0e6ac8cca387579f26e8f9a0eaab8e6f8ac8f9e2ad179bce09f5247848a9ce78d4042f3e400771f9c0914e8d6504f792d002481529e755f5eaf8916'
|
||||
'6e5980e56343a23bce4fcda58f6abc8f2debca0c278c87b09e53abb17ff15849c26e8df3bbff2388985f8fe5a4e9be9982c602ef7159546f0ae335fca1000a41')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -113,9 +110,6 @@ prepare() {
|
|||
# https://src.fedoraproject.org/rpms/firefox/blob/rawhide/f/libwebrtc-screen-cast-sync.patch
|
||||
patch -Np1 -i ../0001-libwebrtc-screen-cast-sync.patch
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1804973
|
||||
patch -Np1 -i ../0002-Bug-1804973-Wayland-Check-size-for-valid-EGLWindows-.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
||||
|
|
Loading…
Reference in a new issue