extra/meson to 0.45.0-1

This commit is contained in:
Kevin Mihelich 2018-03-06 22:26:27 +00:00
parent e054aaa01d
commit 31319c07a2
2 changed files with 5 additions and 40 deletions

View file

@ -1,30 +0,0 @@
From 89d4decc9cdda01590c2a734c0f58924bcf30777 Mon Sep 17 00:00:00 2001
Message-Id: <89d4decc9cdda01590c2a734c0f58924bcf30777.1517146929.git.jan.steffens@gmail.com>
From: Dylan Baker <dylan@pnwbakers.com>
Date: Tue, 19 Dec 2017 20:05:24 -0800
Subject: [PATCH 1/2] tests: skip objc nsstring test if gnustep is not
installed
---
test cases/objc/2 nsstring/meson.build | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/test cases/objc/2 nsstring/meson.build b/test cases/objc/2 nsstring/meson.build
index a877d746..7f2483f4 100644
--- a/test cases/objc/2 nsstring/meson.build
+++ b/test cases/objc/2 nsstring/meson.build
@@ -5,7 +5,10 @@ if host_machine.system() == 'darwin'
elif host_machine.system() == 'cygwin'
error('MESON_SKIP_TEST GNUstep is not packaged for Cygwin.')
else
- dep = dependency('gnustep')
+ dep = dependency('gnustep', required : false)
+ if not dep.found()
+ error('MESON_SKIP_TEST: GNUstep is not installed')
+ endif
if host_machine.system() == 'linux' and meson.get_compiler('objc').get_id() == 'clang'
error('MESON_SKIP_TEST: GNUstep is broken on Linux with Clang')
endif
--
2.16.1

View file

@ -7,7 +7,7 @@
# - remove checkdepend on dmd
pkgname=meson
pkgver=0.44.1
pkgver=0.45.0
pkgrel=1
pkgdesc='High productivity build system'
url='http://mesonbuild.com/'
@ -21,19 +21,14 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt4' 'qt5-b
'doxygen' 'vulkan-validation-layers' 'openmpi' 'openssh' 'mercurial' 'gtk-sharp-2'
'qt5-tools' 'libwmf' 'valgrind')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
0001-tests-skip-objc-nsstring-test-if-gnustep-is-not-inst.patch
arch-meson)
sha512sums=('1ecccccfa24ec2c5c144f8c13fd95d250b59cb22b79676a2a1a6f9ed30a7b08adb71d5882b2d4421d07689ad6dd6d6aef139ac33f628e55a1d428cbc40b4d93e'
sha512sums=('4bf9168b1481c0b82c42ec93543d6835c0a961f6e123d41c13b2d7983132f77bf55ea70afe4c531706a307c83b248c3f8e6dcd0116792be41408b59efe835dd1'
'SKIP'
'04a0f113ba5f1ae57591fad3f5ecf812ef88b8809b4ffe063e82f6548e728a1a7bd51c171a948873884c2631fc10a9cd141f56de22cd7cf766cdb74996840eec'
'b9f86ded46ad7fc4c4cbd997bd2210e363f02189377d9159cae4a52d0bd8bb9e02de1680bc76f63ecd923922f9cbdba40efbe09231dc24fc1d445ed97c2f5132')
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
prepare() {
cd ${pkgname}-${pkgver}
# Skip gnustep tests
patch -Np1 -i ../0001-tests-skip-objc-nsstring-test-if-gnustep-is-not-inst.patch
}
build() {
@ -58,9 +53,9 @@ package() {
cd ${pkgname}-${pkgver}
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
for _f in data/syntax-highlighting/vim/*/*; do
install -Dt "${pkgdir}/usr/share/vim/vimfiles/$(basename "$(dirname "$_f")")" -m644 "$_f"
done
mkdir -p "${pkgdir}/usr/share/vim/vimfiles"
cp -rt "${pkgdir}/usr/share/vim/vimfiles" data/syntax-highlighting/vim/*
install -Dt "${pkgdir}/usr/share/emacs/site-lisp" -m644 data/syntax-highlighting/emacs/*
install -Dt "${pkgdir}/usr/share/zsh/site-functions" -m644 data/shell-completions/zsh/*