mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qemu to 2.9.0-2
This commit is contained in:
parent
25e15adde4
commit
3143fe3479
2 changed files with 34 additions and 3 deletions
|
@ -13,7 +13,7 @@ pkgname=(qemu qemu-headless qemu-arch-extra qemu-headless-arch-extra
|
||||||
qemu-block-{iscsi,rbd,gluster} qemu-guest-agent)
|
qemu-block-{iscsi,rbd,gluster} qemu-guest-agent)
|
||||||
pkgdesc="A generic and open source machine emulator and virtualizer"
|
pkgdesc="A generic and open source machine emulator and virtualizer"
|
||||||
pkgver=2.9.0
|
pkgver=2.9.0
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
arch=(i686 x86_64)
|
arch=(i686 x86_64)
|
||||||
license=(GPL2 LGPL2.1)
|
license=(GPL2 LGPL2.1)
|
||||||
url="http://wiki.qemu.org/"
|
url="http://wiki.qemu.org/"
|
||||||
|
@ -24,12 +24,14 @@ makedepends=(spice-protocol python2 ceph libiscsi glusterfs)
|
||||||
source=("$url/download/${pkgname}-${pkgver}.tar.bz2"{,.sig}
|
source=("$url/download/${pkgname}-${pkgver}.tar.bz2"{,.sig}
|
||||||
qemu.sysusers
|
qemu.sysusers
|
||||||
qemu-ga.service
|
qemu-ga.service
|
||||||
65-kvm.rules)
|
65-kvm.rules
|
||||||
|
allow_elf64.patch)
|
||||||
sha256sums=('00bfb217b1bb03c7a6c3261b819cfccbfb5a58e3e2ceff546327d271773c6c14'
|
sha256sums=('00bfb217b1bb03c7a6c3261b819cfccbfb5a58e3e2ceff546327d271773c6c14'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'dd43e2ef062b071a0b9d0d5ea54737f41600ca8a84a8aefbebb1ff09f978acfb'
|
'dd43e2ef062b071a0b9d0d5ea54737f41600ca8a84a8aefbebb1ff09f978acfb'
|
||||||
'c39bcde4a09165e64419fd2033b3532378bba84d509d39e2d51694d44c1f8d88'
|
'c39bcde4a09165e64419fd2033b3532378bba84d509d39e2d51694d44c1f8d88'
|
||||||
'60dcde5002c7c0b983952746e6fb2cf06d6c5b425d64f340f819356e561e7fc7')
|
'60dcde5002c7c0b983952746e6fb2cf06d6c5b425d64f340f819356e561e7fc7'
|
||||||
|
'13a6d9e678bdc9e1f051006cfd0555f5a80582368f54c8a1bb5a78ece3832ac4')
|
||||||
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
|
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
|
||||||
|
|
||||||
case $CARCH in
|
case $CARCH in
|
||||||
|
@ -45,6 +47,8 @@ prepare() {
|
||||||
|
|
||||||
cd ${pkgname}-${pkgver}
|
cd ${pkgname}-${pkgver}
|
||||||
sed -i 's/vte-2\.90/vte-2.91/g' configure
|
sed -i 's/vte-2\.90/vte-2.91/g' configure
|
||||||
|
|
||||||
|
patch -p1 < ../allow_elf64.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
27
extra/qemu/allow_elf64.patch
Normal file
27
extra/qemu/allow_elf64.patch
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
commit 3c72765ec760a51f0e879dc792be82c93141e318
|
||||||
|
Author: Anatol Pomozov <anatol.pomozov@gmail.com>
|
||||||
|
Date: Tue Jun 6 20:07:03 2017 -0700
|
||||||
|
|
||||||
|
Remove restriction that prevents bootimg elf64 images
|
||||||
|
|
||||||
|
It is possible to create a 64 bit elf image that has valid multiboot header.
|
||||||
|
qemu should be able to boot such images.
|
||||||
|
|
||||||
|
Signed-off-by: Anatol Pomozov <anatol.pomozov@gmail.com>
|
||||||
|
|
||||||
|
diff --git a/hw/i386/multiboot.c b/hw/i386/multiboot.c
|
||||||
|
index 663f35a658..cf1b4f5fb3 100644
|
||||||
|
--- a/hw/i386/multiboot.c
|
||||||
|
+++ b/hw/i386/multiboot.c
|
||||||
|
@@ -192,11 +192,6 @@ int load_multiboot(FWCfgState *fw_cfg,
|
||||||
|
int kernel_size;
|
||||||
|
fclose(f);
|
||||||
|
|
||||||
|
- if (((struct elf64_hdr*)header)->e_machine == EM_X86_64) {
|
||||||
|
- fprintf(stderr, "Cannot load x86-64 image, give a 32bit one.\n");
|
||||||
|
- exit(1);
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
kernel_size = load_elf(kernel_filename, NULL, NULL, &elf_entry,
|
||||||
|
&elf_low, &elf_high, 0, I386_ELF_MACHINE,
|
||||||
|
0, 0);
|
Loading…
Reference in a new issue