extra/gnutls to 3.0.13-2

This commit is contained in:
Kevin Mihelich 2012-02-21 08:21:51 -05:00
parent 94a1b53650
commit 315eea3dbf
2 changed files with 42 additions and 8 deletions

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 145025 2011-12-15 06:57:18Z andyrtr $
# $Id: PKGBUILD 150689 2012-02-20 10:15:52Z andyrtr $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
@ -7,25 +7,31 @@
plugrel=1
pkgname=gnutls
pkgver=3.0.12
pkgrel=1
pkgver=3.0.13
pkgrel=2
pkgdesc="A library which provides a secure layer over a reliable transport layer"
arch=('i686' 'x86_64')
license=('GPL3' 'LGPL')
url="http://www.gnu.org/software/gnutls/"
install=gnutls.install
options=('!libtool' '!zipman' 'makeflags')
depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle>=2.4' 'p11-kit')
source=(ftp://ftp.gnu.org/gnu/gnutls/${pkgname}-${pkgver}.tar.xz)
md5sums=('685fe5c00786c04b39e9aac362fa0cac')
options=('!libtool' '!zipman')
depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle>=2.4' 'p11-kit>=0.11')
makedepends=('strace')
source=(ftp://ftp.gnu.org/gnu/gnutls/${pkgname}-${pkgver}.tar.xz{,.sig}
buildfix.diff)
md5sums=('ec549be557f31ea8c1738cb441ef23ec'
'a6a9a1d148abd6377e7634eb03bdaf7c'
'9b2a32b41391d95aeb8ddae3756fa191')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
# fix hanging make check - http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commit;h=642e6b5ca996325dc0ca6401a3b87039408b2585
patch -Np1 -i ${srcdir}/buildfix.diff
./configure --prefix=/usr \
--with-zlib \
--disable-static \
--disable-guile \
--disable-valgrind-tests # x86_64 test are all passed. some fail in i686 chroot
--disable-valgrind-tests
make
}

View file

@ -0,0 +1,28 @@
index 17f6d3f..cc01dcd 100644 (file)
--- a/tests/mini-loss-time.c
+++ b/tests/mini-loss-time.c
@@ -267,6 +267,7 @@ static void start (int server_packet, int client_packet)
{
/* parent */
server (fd[0], server_packet);
+ kill(child, SIGTERM);
}
else
{
--- a/src/libopts/m4/libopts.m4
+++ b/src/libopts/m4/libopts.m4
@@ -487,9 +487,9 @@ AC_DEFUN([LIBOPTS_CHECK_COMMON],[
fi])
AC_ARG_ENABLE([libopts-install],
- AC_HELP_STRING([--disable-libopts-install],
- [Do not install libopts with client installation]))
- AM_CONDITIONAL([INSTALL_LIBOPTS],[test "X${enable_libopts_install}" != Xno])
+ AC_HELP_STRING([--enable-libopts-install],
+ [Install libopts with client installation]))
+ AM_CONDITIONAL([INSTALL_LIBOPTS],[test "X${enable_libopts_install}" = Xyes])
[if test -z "${NEED_LIBOPTS_DIR}" ; then]
AC_MSG_CHECKING([whether autoopts-config can be found])