mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/kwin fix
This commit is contained in:
parent
3c034ada06
commit
31b588cb9f
3 changed files with 6 additions and 90 deletions
|
@ -1,12 +1,8 @@
|
|||
# $Id: PKGBUILD 224438 2014-10-15 16:56:29Z andrea $
|
||||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM on armv6h: Arno Rehn <arno@arnorehn.de>
|
||||
# - Find Broadcom's VideoCore GLES and EGL libraries instead of mesa's libs.
|
||||
# - Remove forced compilation of the EGLonX part (not available on the r-pi)
|
||||
# - Fix general compilation errors.
|
||||
# - Proper upstream patches for the above are pending.
|
||||
# remove when bumped upstream
|
||||
|
||||
pkgname=kwin
|
||||
pkgver=5.4.0
|
||||
|
@ -18,40 +14,17 @@ license=('LGPL')
|
|||
depends=('qt5-multimedia' 'plasma-framework' 'knewstuff' 'xcb-util-cursor' 'kinit'
|
||||
'hicolor-icon-theme' 'kwayland' 'kdecoration')
|
||||
makedepends=('extra-cmake-modules' 'qt5-tools' 'kdoctools')
|
||||
groups=('plasma-next')
|
||||
groups=('plasma')
|
||||
install=${pkgname}.install
|
||||
conflicts=('kdebase-workspace')
|
||||
source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.tar.xz"
|
||||
"rpi_fix_build.patch"
|
||||
"kwin_remove_eglonxbackend.patch")
|
||||
md5sums=('38b4a6d540ec6bbe94c0ec658c47eb5c'
|
||||
'65af20bd49436056c93932ad7f80f7dd'
|
||||
'7bfedcb642b0d6b517cc9e639c9b9c16')
|
||||
source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.tar.xz")
|
||||
md5sums=('38b4a6d540ec6bbe94c0ec658c47eb5c')
|
||||
|
||||
prepare() {
|
||||
mkdir build
|
||||
|
||||
# Raspberry Pi
|
||||
if [ "$CARCH" == 'armv6h' ]; then
|
||||
cd ${pkgname}-${pkgver}
|
||||
patch -p1 -i ../rpi_fix_build.patch
|
||||
#patch -p1 -i ../kwin_remove_eglonxbackend.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
# Raspberry Pi
|
||||
if [ "$CARCH" == 'armv6h' ]; then
|
||||
VC_INCLUDE_DIR="/opt/vc/include;/opt/vc/include/interface/vcos/pthreads;/opt/vc/include/interface/vmcs_host/linux"
|
||||
VC_EGL_LIB="/opt/vc/lib/libEGL.so"
|
||||
VC_GLESv2_LIB="/opt/vc/lib/libGLESv2.so"
|
||||
|
||||
CMAKE_EXTRA_CONFIG_OPTIONS="-DOPENGLES_EGL_INCLUDE_DIR=$VC_INCLUDE_DIR \
|
||||
-DOPENGLES_EGL_LIBRARY=$VC_EGL_LIB \
|
||||
-DOPENGLES_INCLUDE_DIR=$VC_INCLUDE_DIR \
|
||||
-DOPENGLES_LIBRARY=$VC_GLESv2_LIB"
|
||||
fi
|
||||
|
||||
cd build
|
||||
cmake ../${pkgname}-${pkgver} \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
|
@ -59,8 +32,7 @@ build() {
|
|||
-DLIB_INSTALL_DIR=lib \
|
||||
-DLIBEXEC_INSTALL_DIR=lib \
|
||||
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
|
||||
-DBUILD_TESTING=OFF \
|
||||
$CMAKE_EXTRA_CONFIG_OPTIONS
|
||||
-DBUILD_TESTING=OFF
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2015-04-23 04:08:00.000000000 -0600
|
||||
+++ b/CMakeLists.txt 2015-05-03 17:59:09.416829142 -0600
|
||||
@@ -414,7 +414,7 @@
|
||||
endif()
|
||||
|
||||
if(KWIN_HAVE_EGL)
|
||||
- set(kwin_KDEINIT_SRCS ${kwin_KDEINIT_SRCS} abstract_egl_backend.cpp eglonxbackend.cpp)
|
||||
+ set(kwin_KDEINIT_SRCS ${kwin_KDEINIT_SRCS} abstract_egl_backend.cpp)
|
||||
endif()
|
||||
|
||||
if(HAVE_WAYLAND)
|
||||
diff -urN a/scene_opengl.cpp b/scene_opengl.cpp
|
||||
--- a/scene_opengl.cpp 2015-04-23 04:06:05.000000000 -0600
|
||||
+++ b/scene_opengl.cpp 2015-05-03 17:59:40.756785872 -0600
|
||||
@@ -28,7 +28,6 @@
|
||||
*********************************************************************/
|
||||
#include "scene_opengl.h"
|
||||
#ifdef KWIN_HAVE_EGL
|
||||
-#include "eglonxbackend.h"
|
||||
#endif // KWIN_HAVE_EGL
|
||||
#ifndef KWIN_HAVE_OPENGLES
|
||||
#include "glxbackend.h"
|
||||
@@ -501,7 +500,7 @@
|
||||
} else
|
||||
#endif // HAVE_WAYLAND
|
||||
{
|
||||
- backend = new EglOnXBackend();
|
||||
+ backend = NULL;
|
||||
}
|
||||
#endif // KWIN_HAVE_EGL
|
||||
break;
|
|
@ -1,24 +0,0 @@
|
|||
diff -urN a/libkwineffects/kwinglplatform.cpp b/libkwineffects/kwinglplatform.cpp
|
||||
--- a/libkwineffects/kwinglplatform.cpp 2015-02-21 13:21:17.000000000 -0700
|
||||
+++ b/libkwineffects/kwinglplatform.cpp 2015-03-01 16:01:13.843985675 -0700
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <QStringList>
|
||||
#include <QDebug>
|
||||
|
||||
+#include <X11/Xlib.h>
|
||||
+
|
||||
#include <sys/utsname.h>
|
||||
|
||||
#include <iostream>
|
||||
diff -urN a/libkwineffects/kwingltexture.cpp b/libkwineffects/kwingltexture.cpp
|
||||
--- a/libkwineffects/kwingltexture.cpp 2015-02-21 13:21:17.000000000 -0700
|
||||
+++ b/libkwineffects/kwingltexture.cpp 2015-03-01 16:01:13.843985675 -0700
|
||||
@@ -320,7 +320,7 @@
|
||||
bool GLTexture::isNull() const
|
||||
{
|
||||
Q_D(const GLTexture);
|
||||
- return None == d->m_texture;
|
||||
+ return 0 == d->m_texture;
|
||||
}
|
||||
|
||||
QSize GLTexture::size() const
|
Loading…
Reference in a new issue