From 4064fcf599f49dd05629a16500282a9e2764ce74 Mon Sep 17 00:00:00 2001
From: Jason Plum <max@warheads.net>
Date: Sat, 7 Mar 2015 20:15:58 -0500
Subject: [PATCH] uboot-usbarmory: fix loadfdt

---
 alarm/uboot-usbarmory/PKGBUILD    | 2 +-
 alarm/uboot-usbarmory/alarm.patch | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/alarm/uboot-usbarmory/PKGBUILD b/alarm/uboot-usbarmory/PKGBUILD
index 30602597c..b82a9a4f8 100644
--- a/alarm/uboot-usbarmory/PKGBUILD
+++ b/alarm/uboot-usbarmory/PKGBUILD
@@ -15,7 +15,7 @@ source=("u-boot-${pkgver}::git+https://github.com/inversepath/u-boot-usbarmory.g
         'alarm.patch'
         'uEnv.txt')
 md5sums=('SKIP'
-         'f21fec4a935f94f16dff8d48b2a2501e'
+         '05f616b9caeca1a6f71e279512276f98'
          'd41d8cd98f00b204e9800998ecf8427e')
 
 prepare() {
diff --git a/alarm/uboot-usbarmory/alarm.patch b/alarm/uboot-usbarmory/alarm.patch
index cc18beb92..5fc3303d9 100644
--- a/alarm/uboot-usbarmory/alarm.patch
+++ b/alarm/uboot-usbarmory/alarm.patch
@@ -55,7 +55,7 @@ index e00ec7b..cfd457b 100644
 +        "root=${mmcroot} ${mmcrootextra}\0" \
 +    "loadramdisk=load mmc ${bootpart} ${rdaddr} ${bootdir}/${rdfile}\0" \
 +    "loadimage=load mmc ${bootpart} ${loadaddr} ${bootdir}/${bootfile}\0" \
-+    "loadfdt=load mmc ${bootpart} ${fdtaddr} ${bootdir}/${fdtfile}\0" \
++    "loadfdt=load mmc ${bootpart} ${fdtaddr} ${fdtdir}/${fdtfile}\0" \
 +    "loadbootenv=load mmc ${mmcdev} ${loadaddr} ${bootdir}/${bootenv}\0" \
 +    "importbootenv=echo Importing environment from mmc ...; "\
 +        "env import -t $loadaddr $filesize\0" \