alarm/uboot-odroid-c1 to 2011.03-6

This commit is contained in:
Kevin Mihelich 2015-01-13 02:58:21 +00:00
parent 115651b5a4
commit 31e54d92b4
5 changed files with 28 additions and 77 deletions

View file

@ -1,7 +1,7 @@
From 199913f814f1c21d612514ee6455940096fdaf50 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 21 Dec 2014 18:04:05 -0700
Subject: [PATCH 1/3] remove cross-compiling
Subject: [PATCH 1/2] remove cross-compiling
---
arch/arm/config.mk | 2 +-

View file

@ -1,7 +1,7 @@
From 8464678df565088ae553a204be9b3ce3e16f5d57 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 22 Dec 2014 09:55:32 -0700
Subject: [PATCH 2/3] sd_fusing tweaks
Subject: [PATCH 2/2] sd_fusing tweaks
---
sd_fuse/sd_fusing.sh | 13 ++++++-------

View file

@ -1,64 +0,0 @@
From 058a12620603ec49004cd4e054aa7e8a665a954e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 10 Jan 2015 11:51:52 -0700
Subject: [PATCH 3/3] environment fixes
---
include/configs/hardkernel/odroidc.h | 34 ++++++++++++++++------------------
1 file changed, 16 insertions(+), 18 deletions(-)
diff --git a/include/configs/hardkernel/odroidc.h b/include/configs/hardkernel/odroidc.h
index 2099f3b..c31790b 100644
--- a/include/configs/hardkernel/odroidc.h
+++ b/include/configs/hardkernel/odroidc.h
@@ -119,21 +119,12 @@
#define CONFIG_EXTRA_ENV_SETTINGS \
"boardname=ODROIDC\0" \
- "bootargs=root=" MK_STR(CONFIG_DEFAULT_ROOT) " rw " \
- "console=" CONFIG_CONSOLE_PROTOCOL " no_console_suspend\0" \
- "bootcmd="\
- "cfgload;" \
- "setenv bootargs root=" MK_STR(CONFIG_DEFAULT_ROOT) " rw " \
- "console=" CONFIG_CONSOLE_PROTOCOL " no_console_suspend " \
- "vdaccfg=${vdac_config} " \
- "logo=osd1,loaded,${fb_addr},${outputmode},full " \
- "hdmimode=${hdmimode} " \
- "cvbsmode=${cvbsmode} " \
- "hdmitx=${cecconfig} " \
- "androidboot.serialno=${fbt_id#}; " \
- "movi read boot 0 0x12000000;" \
- "movi read dtb 0 0x12800000;" \
- "bootm 0x12000000 - 0x12800000\0" \
+ "optargs=\0" \
+ "mmcargs=setenv bootargs console=ttyS0,115200n8 no_console_suspend " \
+ "root=/dev/mmcblk0p1 rw rootwait " \
+ "vdaccfg=0xa000 logo=osd1,loaded,0x7900000,720p,full dmfc=3 cvbsmode=576cvbs " \
+ "hdmimode=${m} m_bpp=${m_bpp} vout=${vout_mode} ${disableuhs} " \
+ "${optargs}\0" \
"bootm_low=0x00000000\0" \
"bootm_size=0x80000000\0" \
"bootpath=u-boot.bin\0" \
@@ -163,9 +154,16 @@
"movi read logo 0 ${loadaddr_logo};" \
"bmp display ${loadaddr_logo}; bmp scale\0" \
"vdac_config=0x10\0" \
- "video_dev=tvout\0"
-
-#define CONFIG_BOOTCOMMAND "bootm"
+ "video_dev=tvout\0" \
+ "loadimage=ext4load mmc 0:1 0x21000000 /boot/uImage\0" \
+ "loadfdt=ext4load mmc 0:1 0x21800000 /boot/dtbs/meson8b_odroidc.dtb\0"
+
+#define CONFIG_BOOTCOMMAND \
+ "cfgload;" \
+ "run loadimage;" \
+ "run loadfdt;" \
+ "run mmcargs;" \
+ "bootm 0x21000000 - 0x21800000;"
#define CONFIG_AUTO_COMPLETE 1
#define CONFIG_ENV_SIZE (32 * 1024) // unit: bytes
--
2.2.1

View file

@ -5,7 +5,7 @@ buildarch=4
pkgname=uboot-odroid-c1
pkgver=2011.03
pkgrel=5
pkgrel=6
pkgdesc="U-Boot for ODROID-C1"
arch=('armv7h')
url="https://github.com/hardkernel/u-boot"
@ -17,20 +17,17 @@ _commit=e7d4447d551ccba5d60be8b11697aa0ab49086c4
source=("https://github.com/hardkernel/u-boot/archive/${_commit}.tar.gz"
'boot.ini'
'0001-remove-cross-compiling.patch'
'0002-sd_fusing-tweaks.patch'
'0003-environment-fixes.patch')
'0002-sd_fusing-tweaks.patch')
md5sums=('0fc20cde97358ab04b22b946d563e970'
'a9e2adb320a058236b1317c7f873c07c'
'112dd04a3e5e383ad8bdcdfe81423a05'
'd395e29e94e23151cb921ceb16ec3b88'
'1b3dded4a457d7d7e1c03035d1f24d51')
'68a723c690d35b16fc09fe8d0dd32e04'
'fb9e00cfdc765b60c61b42060bde6fc2'
'beeec86a4903a3ce6d1e7956ad9250c4')
prepare() {
cd u-boot-${_commit}
git apply ../0001-remove-cross-compiling.patch
git apply ../0002-sd_fusing-tweaks.patch
git apply ../0003-environment-fixes.patch
}
build() {

View file

@ -32,7 +32,25 @@ setenv m_bpp "32"
# UHS Card Configuration
# Uncomment the line below to __DISABLE__ UHS-1 MicroSD support
# This might break boot for some brand models of cards.
setenv disableuhs "disableuhs"
# setenv disableuhs "disableuhs"
# Uncomment and set the line below to append additional bootargs
# setenv optargs ""
# Disable VPU (Video decoding engine, Saves RAM!!!)
# 0 = disabled
# 1 = enabled
setenv vpu "1"
# Disable HDMI Output (Again, saves ram!)
# 0 = disabled
# 1 = enabled
setenv hdmioutput "1"
setenv bootargs "console=ttyS0,115200n8 root=/dev/mmcblk0p1 rootwait rw no_console_suspend vdaccfg=0xa000 logo=osd1,loaded,0x7900000,720p,full dmfc=3 cvbsmode=576cvbs hdmimode=${m} m_bpp=${m_bpp} vout=${vout_mode} ${disableuhs}"
ext4load mmc 0:1 0x21000000 /boot/uImage
ext4load mmc 0:1 0x21800000 /boot/dtbs/meson8b_odroidc.dtb
fdt addr 21800000
if test "${vpu}" = "0"; then fdt rm /mesonstream; fdt rm /vdec; fdt rm /ppmgr; fi
if test "${hdmioutput}" = "0"; then fdt rm /mesonfb; fi
bootm 0x21000000 - 0x21800000