mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added community/suil
This commit is contained in:
parent
f41129ed95
commit
31e73f92ca
2 changed files with 78 additions and 0 deletions
28
community/suil/0001-remove-cocoa-check.patch
Normal file
28
community/suil/0001-remove-cocoa-check.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
From 668bdedae8ed61527d6cf94751248f9aa9c40a5c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 22 Dec 2018 15:09:54 -0700
|
||||
Subject: [PATCH] remove cocoa check
|
||||
|
||||
Mis-detects on ARM for whatever reason.
|
||||
---
|
||||
wscript | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/wscript b/wscript
|
||||
index 89ab039..352e569 100644
|
||||
--- a/wscript
|
||||
+++ b/wscript
|
||||
@@ -91,10 +91,6 @@ def configure(conf):
|
||||
if not conf.options.no_qt5:
|
||||
autowaf.check_pkg(conf, 'Qt5Widgets', uselib_store='QT5',
|
||||
atleast_version='5.1.0', mandatory=False)
|
||||
- if conf.check_cxx(header_name = 'QMacCocoaViewContainer',
|
||||
- uselib = 'QT5',
|
||||
- mandatory = False):
|
||||
- autowaf.define(conf, 'SUIL_WITH_COCOA_IN_QT5', 1)
|
||||
|
||||
conf.check_cc(define_name = 'HAVE_LIBDL',
|
||||
lib = 'dl',
|
||||
--
|
||||
2.19.2
|
||||
|
50
community/suil/PKGBUILD
Normal file
50
community/suil/PKGBUILD
Normal file
|
@ -0,0 +1,50 @@
|
|||
# Maintainer: David Runge <dave@sleepmap.de>
|
||||
# Contributor: Ray Rashif <schiv@archlinux.org>
|
||||
# Contributor: speps <speps at aur dot archlinux dot org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to skip qt5 cocoa check, broken on ARM
|
||||
|
||||
pkgname=suil
|
||||
pkgver=0.10.2
|
||||
pkgrel=1
|
||||
pkgdesc="A lightweight C library for loading and wrapping LV2 plugin UIs"
|
||||
arch=('x86_64')
|
||||
url="https://drobilla.net/software/suil/"
|
||||
license=('custom:ISC')
|
||||
makedepends=('gtk2' 'gtk3' 'lv2' 'python' 'qt5-base')
|
||||
optdepends=('qt5-base: Qt5 UI wrapping support'
|
||||
'gtk2: GTK+ 2.x UI wrapping support'
|
||||
'gtk3: GTK+ 3.x UI wrapping support')
|
||||
source=("https://download.drobilla.net/${pkgname}-${pkgver}.tar.bz2"{,.sig}
|
||||
'0001-remove-cocoa-check.patch')
|
||||
sha512sums=('8f5b4d772e58dfc4563a5102d189d886218fdc56e74c9d8c118f7bbbcc5d056904c2c8d132f993187416145383d3d8cb4787e2f8c113e57ad47e5d4def7f2fba'
|
||||
'SKIP'
|
||||
'34fbc8637a6d43160a59f84cf015bb0238182455d3ab1bdd14c2344d68abc232fea50f5602ffe5d9c48f7df2967440e98c786f9a10c917886186927efd269798')
|
||||
validpgpkeys=('907D226E7E13FA337F014A083672782A9BF368F3') # David Robillard
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
# remove local call to ldconfig
|
||||
sed -i "/ldconfig/d" wscript
|
||||
patch -p1 -i ../0001-remove-cocoa-check.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
python waf configure --prefix=/usr
|
||||
python waf build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
python waf install --destdir="${pkgdir}"
|
||||
# license
|
||||
install -vDm 644 COPYING \
|
||||
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
||||
# docs
|
||||
install -t "$pkgdir/usr/share/doc/${pkgname}" \
|
||||
-vDm 644 {AUTHORS,NEWS,PACKAGING,README.md}
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
Loading…
Reference in a new issue