removed community/busybox

This commit is contained in:
Kevin Mihelich 2021-05-04 14:00:59 +00:00
parent 4b503cee21
commit 326e508f51
4 changed files with 0 additions and 1336 deletions

View file

@ -1,50 +0,0 @@
From 883cdb79a440d0425766f67aaef0cabde0a5060e Mon Sep 17 00:00:00 2001
From: Denys Vlasenko <vda.linux@googlemail.com>
Date: Sat, 9 Jan 2021 08:27:37 +0100
Subject: ash: fix ${unset_var/pattern/repl}
function old new delta
subevalvar 1349 1353 +4
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
---
shell/ash.c | 3 ++-
shell/ash_test/ash-vars/var_bash_repl_empty_var.right | 1 +
shell/ash_test/ash-vars/var_bash_repl_empty_var.tests | 2 ++
3 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/shell/ash.c b/shell/ash.c
index 37f9dd71b..76bf39ec2 100644
--- a/shell/ash.c
+++ b/shell/ash.c
@@ -7015,7 +7015,8 @@ subevalvar(char *start, char *str, int strloc,
slash_pos = -1;
if (repl) {
slash_pos = expdest - ((char *)stackblock() + strloc);
- STPUTC('/', expdest);
+ if (!(flag & EXP_DISCARD))
+ STPUTC('/', expdest);
//bb_error_msg("repl+1:'%s'", repl + 1);
p = argstr(repl + 1, (flag & EXP_DISCARD) | EXP_TILDE); /* EXP_TILDE: echo "${v/x/~}" expands ~ ! */
*repl = '/';
diff --git a/shell/ash_test/ash-vars/var_bash_repl_empty_var.right b/shell/ash_test/ash-vars/var_bash_repl_empty_var.right
index 892916783..cf8f088c1 100644
--- a/shell/ash_test/ash-vars/var_bash_repl_empty_var.right
+++ b/shell/ash_test/ash-vars/var_bash_repl_empty_var.right
@@ -1,2 +1,3 @@
+
Ok:0
diff --git a/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests b/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests
index 73a43d38e..22aaba560 100755
--- a/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests
+++ b/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests
@@ -1,3 +1,5 @@
+unset v
+echo ${v/*/w}
v=''
echo ${v/*/w}
echo Ok:$?
--
cgit v1.2.1

View file

@ -1,26 +0,0 @@
From 8f91696432cf597639154fcaa1bf4ec3c7af2d27 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 23 Feb 2020 14:56:53 -0700
Subject: [PATCH] comment time size check
busybox isn't ready for musl's 64-bit time changes on 32-bit architectures.
---
runit/runsv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/runit/runsv.c b/runit/runsv.c
index ccc762d78..fdb005c73 100644
--- a/runit/runsv.c
+++ b/runit/runsv.c
@@ -61,7 +61,7 @@ static void gettimeofday_ns(struct timespec *ts)
static void gettimeofday_ns(struct timespec *ts)
{
BUILD_BUG_ON(sizeof(struct timeval) != sizeof(struct timespec));
- BUILD_BUG_ON(sizeof(((struct timeval*)ts)->tv_usec) != sizeof(ts->tv_nsec));
+ //BUILD_BUG_ON(sizeof(((struct timeval*)ts)->tv_usec) != sizeof(ts->tv_nsec));
/* Cheat */
gettimeofday((void*)ts, NULL);
ts->tv_nsec *= 1000;
--
2.24.1

View file

@ -1,62 +0,0 @@
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
# Contributor: Jens Pranaitis <jens@jenux.homelinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix 32-bit FTBFS with new musl
pkgname=busybox
pkgver=1.32.1
pkgrel=4
pkgdesc="Utilities for rescue and embedded systems"
arch=("x86_64")
url="https://www.busybox.net"
license=('GPL')
makedepends=("ncurses" "musl" "kernel-headers-musl")
validpgpkeys=('C9E9416F76E610DBD09D040F47B70C55ACC9965B')
source=("$url/downloads/$pkgname-$pkgver.tar.bz2"{,.sig}
'0001-ash-fix-unset_var-pattern-repl.patch'
"CVE-2021-28831.patch::https://git.busybox.net/busybox/patch/?id=f25d254dfd4243698c31a4f3153d4ac72aa9e9bd"
"config"
"0001-comment-time-size-check.patch")
sha256sums=('9d57c4bd33974140fd4111260468af22856f12f5b5ef7c70c8d9b75c712a0dee'
'SKIP'
'4e4fb268c51e378a3ad0a12f903a601a136d31cae8b684a51ebabbc9a6cf9250'
'108096d1eee47136756e7250ac136aea926c4edaabe707fda1404022806f160b'
'0b1df86c2fd0c8869c67096777960bddf7db2c54efab5ad890fc83e1b3cbf027'
'd390c798540bf4369da42a575369e737e3e270c7d3c6c2bd141d1da939f4d219')
b2sums=('b0258345d40628d8c12b4cc5c3efdb318cfb469e029242942cdad22aeec5142963291a746fbac450b43a4a1f2f7e9204442456691fa98f18eeaa58c70d714caf'
'SKIP'
'6ce36c1e467c55b3405af58b19636daaf1ead2a5a630ed93c0e86912ecccbce359df3061718f99f08204e705eb1352c00801af3f4241e470f7d64ef6367f3c7e'
'1d70db3703e235c5f577f46753be456d45e40f2786ee3a152ebab667e122d31bc687c5ba41697ffb2eeb6aaa48d1b70465633c69e43573269668b10d099d59b0'
'1ad361dd163e589aa85822834b7e5ec421c1fc7bfab1e481520a8d90ee920c2f1a07709871f864173c3cfb6eacf60f54a4e2adba4e061ae1a9a883e368f1893e'
'2a227153f936850778a772794c4eaa3b72157b76d07ecd9b491f19c690dff258e2c6a755ef2372136235a5220688847e9357812e95d8bdc5550593831b2d592d')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 < ../0001-ash-fix-unset_var-pattern-repl.patch
patch -p1 -i ../CVE-2021-28831.patch
patch -p1 -i ../0001-comment-time-size-check.patch
}
build() {
cd "$srcdir/$pkgname-$pkgver"
cp "$srcdir"/config .config
# reproducible build
export KCONFIG_NOTIMESTAMP=1
make CC=musl-gcc
}
package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm0755 busybox "$pkgdir"/usr/bin/busybox
# docs
install -Dm644 docs/busybox.1 "$pkgdir"/usr/share/man/man1/busybox.1
for doc in BusyBox.html BusyBox.txt; do
install -Dm644 docs/$doc "$pkgdir"/usr/share/doc/$pkgname/$doc
done
}

File diff suppressed because it is too large Load diff