alarm/v8-3.16 to 3.16.8.1-2, fixes #729

This commit is contained in:
Kevin Mihelich 2014-02-26 01:20:16 +00:00
parent b934d31a2d
commit 329e4f842b
2 changed files with 19 additions and 8 deletions

View file

@ -1,6 +1,4 @@
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: Kaiting Chen <kaitocracy@gmail.com>
# Contributor: tocer <tocer.deng@gmail.com>
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: WarheadsSE <max@warheads.net>
# older v8 for mongodb
@ -8,7 +6,7 @@
pkgname=v8-3.16
_pkgname=v8
pkgver=3.16.8.1
pkgrel=1
pkgrel=2
pkgdesc='Fast and modern javascript engine'
arch=('i686' 'x86_64')
url='http://code.google.com/p/v8'
@ -17,8 +15,10 @@ depends=('gcc-libs')
makedepends=('subversion' 'python2')
provides=("v8=${pkgver}")
conflicts=('v8')
source=(http://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.bz2)
sha256sums=('b99ffa913e8f00b8fdb3b58cadf2addbbf60549a5be8d12a6c0b7095a36ac7e0')
source=(http://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.bz2
v8.common.gypi.patch)
sha256sums=('b99ffa913e8f00b8fdb3b58cadf2addbbf60549a5be8d12a6c0b7095a36ac7e0'
'774afb77874c04c5890173f553c6f6da83b3b848e1e6286f2af453163733420a')
prepare() {
cd $_pkgname-$pkgver
@ -37,12 +37,13 @@ if [ "$CARCH" == "arm" ]; then
VFP2=off
fi
if [ "$CARCH" == "armv6h" ]; then
GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=false -Dv8_can_use_vfp2_instructions=true -Darm7=0 -Darm_vfp=vfp"
GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=false -Dv8_can_use_vfp2_instructions=true -Darmv7=0 -Darm_fpu=vfp"
VFP3=off
VFP2=on
patch -p1 -i ../v8.common.gypi.patch
fi
if [ "$CARCH" == "armv7h" ]; then
GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=true -Dv8_can_use_vfp2_instructions=true -Darm7=1"
GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=true -Dv8_can_use_vfp2_instructions=true -Darmv7=1 -Darm_fpu=vfpv3-d16"
VFP3=on
VFP2=on
fi

View file

@ -0,0 +1,10 @@
--- a/build/common.gypi 2012-09-12 21:23:54.000000000 -0400
+++ a/build/common.gypi 2012-09-12 21:35:57.000000000 -0400
@@ -152,7 +152,6 @@
[ 'v8_use_arm_eabi_hardfloat=="true"', {
'defines': [
'USE_EABI_HARDFLOAT=1',
- 'CAN_USE_VFP2_INSTRUCTIONS',
],
'target_conditions': [
['_toolset=="target"', {