extra/mariadb to 10.3.13-3

This commit is contained in:
Kevin Mihelich 2019-03-01 19:30:56 +00:00
parent 17240f6028
commit 32fd49d2c3
3 changed files with 37 additions and 10 deletions

View file

@ -21,18 +21,18 @@ index 8d43b6db428..a96fbcc9d2c 100644
##
## Options previously available to be set via [mysqld_safe]
diff --git a/support-files/mariadb@.service.in b/support-files/mariadb@.service.in
index a2f5cff0828..83d75f80b87 100644
index a2f5cff0828..30631a8738a 100644
--- a/support-files/mariadb@.service.in
+++ b/support-files/mariadb@.service.in
@@ -41,7 +41,7 @@ Type=notify
@@ -138,7 +138,7 @@ UMask=007
# Setting this to true can break replication and the Type=notify settings
# See also bind-address mysqld option.
-PrivateNetwork=false
+PrivateNetwork=true
# If you don't use the /tmp directory for SELECT ... OUTFILE and
# LOAD DATA INFILE you can enable PrivateTmp=true for a little more security.
-PrivateTmp=false
+PrivateTmp=true
##############################################################################
## Package maintainers
##
## Options previously available to be set via [mysqld_safe]
From 0e4a158086b765aa3a12b84646aefb9b192443f7 Mon Sep 17 00:00:00 2001
From: Christian Hesse <mail@eworm.de>
Date: Tue, 29 Jan 2019 23:12:54 +0100

View file

@ -0,0 +1,21 @@
From 82da98556cf58f0fbb43c82e9c6ae1a887b6cf3d Mon Sep 17 00:00:00 2001
From: Oleksandr Byelkin <sanja@mariadb.com>
Date: Mon, 25 Feb 2019 15:57:08 +0100
Subject: [PATCH 2/2] MDEV-18605: Loss of column aliases by using view and
group
Preserv column name with copy fields even if it is function and Co.
diff --git a/sql/sql_select.cc b/sql/sql_select.cc
index 439853c2f66..0bc27f18d47 100644
--- a/sql/sql_select.cc
+++ b/sql/sql_select.cc
@@ -23914,7 +23914,9 @@ setup_copy_fields(THD *thd, TMP_TABLE_PARAM *param,
real_pos->type() == Item::COND_ITEM) &&
!real_pos->with_sum_func)
{ // Save for send fields
+ LEX_CSTRING real_name= pos->name;
pos= real_pos;
+ pos->name= real_name;
/* TODO:
In most cases this result will be sent to the user.
This should be changed to use copy_int or copy_real depending

View file

@ -9,7 +9,7 @@ pkgbase=mariadb
pkgname=('mariadb-libs' 'mariadb-clients' 'mariadb' 'mytop')
pkgdesc='Fast SQL database server, derived from MySQL'
pkgver=10.3.13
pkgrel=1
pkgrel=3
arch=('x86_64')
license=('GPL')
url='https://mariadb.org/'
@ -21,13 +21,15 @@ source=("https://mirrors.n-ix.net/mariadb/mariadb-$pkgver/source/mariadb-$pkgver
'0002-systemd-sysusers-tmpfiles.patch'
'0004-do-not-break-main-configuration-with-instantiated-one.patch'
'0005-fix-galera_recovery-with-fs.protected_regular-enabled.patch'
'0007-MDEV-18605-Loss-of-column-aliases-by-using-view-and-.patch'
'atomic.patch')
sha256sums=('b2aa857ef5b84f85a7ea60a1eac7b34c0ca5151c71a0d44ce2d7fb028d71459a'
'SKIP'
'5a443a403821931ce35759e9583d23cd809b3b5a5df5b8293ac8e33b9c0cbc0f'
'5b74e328e75369dfb68491a06dd53bd736e34f87281103ae0dd2f50401dc70d3'
'1cd009b473d5965c7cbe6d48fff272030a2ccdd9c7e67b4f837d03252786a09a'
'd12806e4f90cc0fc081205dd4c0a5e0e7c455844f04276811b61b57fd24f5545'
'66e0acac7436fd8925710ef5cc66ba1a8f63a385ce374f01ae83096cc33d97a0'
'98f0bd85e1729133d236831e934a3dd0c9bc6deebbff6aebe8a4bda17e457ac4'
'7769fd8eb2bb3a6644a2200d01918ff887be25638d79dbec25897fe0d87badc4')
prepare() {
@ -53,6 +55,10 @@ prepare() {
# https://github.com/MariaDB/server/pull/1137
patch -Np1 < ../0005-fix-galera_recovery-with-fs.protected_regular-enabled.patch
# MDEV-18605: Loss of column aliases by using view and group
# https://jira.mariadb.org/browse/MDEV-18605
patch -Np1 < ../0007-MDEV-18605-Loss-of-column-aliases-by-using-view-and-.patch
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
patch -p0 -i ../atomic.patch
fi