extra/stellarium to 0.13.2-1

This commit is contained in:
Kevin Mihelich 2015-01-27 12:52:01 +00:00
parent aa8551919c
commit 3303cb1779
4 changed files with 3 additions and 43 deletions

View file

@ -6,7 +6,7 @@
# - drop unsupported compiler flag
pkgname=stellarium
pkgver=0.13.1
pkgver=0.13.2
pkgrel=1
pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
arch=("i686" "x86_64")
@ -16,12 +16,8 @@ depends=('libpng' 'glu' 'libgl' 'freetype2' 'qt5-quick1' 'openssl'
'desktop-file-utils' 'xdg-utils' 'phonon')
install=stellarium.install
makedepends=('cmake' 'boost' 'mesa' 'mesa-libgl' 'qt5-tools')
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
stellarium.desktop
stellarium.png)
sha1sums=('0e9937de152f4b72204290b9a1893bfec8afbd21'
'c9cc79212542238227b5bd6af99f60fe056f4ab2'
'b890d3b6c4dcfcfcc696514202af11b2a50c0fea')
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
sha1sums=('ee6b631b6e64762d4972468299013de8d44abf43')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@ -35,10 +31,4 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
# install desktop file & pixmap
install -Dm644 "${srcdir}/stellarium.desktop" \
"${pkgdir}/usr/share/applications/stellarium.desktop"
install -Dm644 "${srcdir}/stellarium.png" \
"${pkgdir}/usr/share/pixmaps/stellarium.png"
}

View file

@ -1,21 +0,0 @@
diff -Naur stellarium-0.10.2-orig/src/core/StelTextureMgr.cpp stellarium-0.10.2/src/core/StelTextureMgr.cpp
--- stellarium-0.10.2-orig/src/core/StelTextureMgr.cpp 2010-01-21 17:04:57.000000000 -0500
+++ stellarium-0.10.2/src/core/StelTextureMgr.cpp 2010-01-21 17:06:55.000000000 -0500
@@ -513,7 +513,7 @@
fread (magic, 1, sizeof (magic), fp);
/* check for valid magic number */
- if (!png_check_sig (magic, sizeof (magic)))
+ if (png_sig_cmp (magic, 0, sizeof (magic)))
{
qWarning() << "error: \"" << filename << "\" is not a valid PNG image!";
fclose (fp);
@@ -576,7 +576,7 @@
/* convert 1-2-4 bits grayscale images to 8 bits
grayscale. */
if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
- png_set_gray_1_2_4_to_8 (png_ptr);
+ png_set_expand_gray_1_2_4_to_8 (png_ptr);
if (png_get_valid (png_ptr, info_ptr, PNG_INFO_tRNS))
png_set_tRNS_to_alpha (png_ptr);

View file

@ -1,9 +0,0 @@
[Desktop Entry]
Name=Stellarium nightsky renderer
GenericName=Nightsky renderer
Comment=A real-time nightsky renderer
Categories=Education;Science;Astronomy;
Icon=stellarium
Exec=stellarium
Terminal=false
Type=Application

Binary file not shown.

Before

Width:  |  Height:  |  Size: 18 KiB