mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
linux-veyron: kernel-CVE-2016-0728.patch
This commit is contained in:
parent
c8f8ef556a
commit
3305d1a3bf
2 changed files with 85 additions and 1 deletions
|
@ -7,7 +7,7 @@ pkgbase=linux-veyron
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="Veyron Chromebooks"
|
||||
pkgver=3.14.0
|
||||
pkgrel=16
|
||||
pkgrel=17
|
||||
_commit=68cdadeae00a55d7f7151d4b3809c0ecac9db57c
|
||||
arch=('armv7h')
|
||||
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-3.14"
|
||||
|
@ -21,6 +21,7 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
|
|||
'0002-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch'
|
||||
'0003-UPSTREAM-soc-rockchip-add-handler-for-usb-uart-funct.patch'
|
||||
'0004-fix-brcmfmac-oops-and-race-condition.patch'
|
||||
'kernel-CVE-2016-0728.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
|
@ -35,6 +36,7 @@ md5sums=('c55a86280cc755b056b1417f26bd6fa0'
|
|||
'20f8931f3795e5226829d48c3d470334'
|
||||
'e8f97028325c3999285839e521bb0f6e'
|
||||
'29ac9b84b8f84fbeb78ed32e049fcea5'
|
||||
'6470e9783bd1c7a8feddc2d67f07afd5'
|
||||
'0a923f72b30570ceae127cb82a0ea432'
|
||||
'22ad496bbbece67f9a825a2d60d8dc25'
|
||||
'04ed601ff47f6c8b6e9466735da7b32f'
|
||||
|
@ -50,6 +52,7 @@ prepare() {
|
|||
git apply 0002-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch
|
||||
git apply 0003-UPSTREAM-soc-rockchip-add-handler-for-usb-uart-funct.patch
|
||||
git apply 0004-fix-brcmfmac-oops-and-race-condition.patch
|
||||
git apply kernel-CVE-2016-0728.patch
|
||||
|
||||
cp config .config
|
||||
|
||||
|
|
81
core/linux-veyron/kernel-CVE-2016-0728.patch
Normal file
81
core/linux-veyron/kernel-CVE-2016-0728.patch
Normal file
|
@ -0,0 +1,81 @@
|
|||
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
|
||||
From: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Date: Tue, 19 Jan 2016 22:09:04 +0000
|
||||
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
|
||||
|
||||
This fixes CVE-2016-0728.
|
||||
|
||||
If a thread is asked to join as a session keyring the keyring that's already
|
||||
set as its session, we leak a keyring reference.
|
||||
|
||||
This can be tested with the following program:
|
||||
|
||||
#include <stddef.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
#include <keyutils.h>
|
||||
|
||||
int main(int argc, const char *argv[])
|
||||
{
|
||||
int i = 0;
|
||||
key_serial_t serial;
|
||||
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (keyctl(KEYCTL_SETPERM, serial,
|
||||
KEY_POS_ALL | KEY_USR_ALL) < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
for (i = 0; i < 100; i++) {
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
}
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
If, after the program has run, there something like the following line in
|
||||
/proc/keys:
|
||||
|
||||
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
|
||||
|
||||
with a usage count of 100 * the number of times the program has been run,
|
||||
then the kernel is malfunctioning. If leaked-keyring has zero usages or
|
||||
has been garbage collected, then the problem is fixed.
|
||||
|
||||
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Signed-off-by: David Howells <dhowells@redhat.com>
|
||||
Acked-by: Don Zickus <dzickus@redhat.com>
|
||||
Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||
Acked-by: Jarod Wilson <jarod@redhat.com>
|
||||
Signed-off-by: James Morris <james.l.morris@oracle.com>
|
||||
---
|
||||
security/keys/process_keys.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
|
||||
index a3f85d2..e6d50172 100644
|
||||
--- a/security/keys/process_keys.c
|
||||
+++ b/security/keys/process_keys.c
|
||||
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
|
||||
ret = PTR_ERR(keyring);
|
||||
goto error2;
|
||||
} else if (keyring == new->session_keyring) {
|
||||
+ key_put(keyring);
|
||||
ret = 0;
|
||||
goto error2;
|
||||
}
|
||||
--
|
||||
cgit v0.12
|
||||
|
Loading…
Reference in a new issue