mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/gdc to 4.9.2-2
This commit is contained in:
parent
d9c1153b83
commit
3306088131
2 changed files with 38 additions and 33 deletions
|
@ -7,20 +7,20 @@
|
|||
# - specifid build host
|
||||
# - replaced bugurl with our GitHub issue page
|
||||
|
||||
noautobuild=1
|
||||
#noautobuild=1
|
||||
|
||||
pkgname=('gdc' 'libgphobos-devel')
|
||||
pkgver=4.9.2
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url="https://github.com/D-Programming-GDC/GDC"
|
||||
license=('GPL')
|
||||
makedepends=('binutils>=2.23' 'git' 'gcc' 'make' 'perl' 'cloog' 'automake')
|
||||
makedepends=('binutils>=2.23' 'git' 'gcc' 'make' 'perl' 'automake')
|
||||
options=('!emptydirs' '!buildflags')
|
||||
_snapshot=4.8-20130725
|
||||
source=(
|
||||
"ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
|
||||
"gdc::git://github.com/D-Programming-GDC/GDC.git#branch=gdc-4.9"
|
||||
"gdc::git://github.com/D-Programming-GDC/GDC.git#tag=v2.066.1_gcc4.9"
|
||||
"git+https://github.com/D-Programming-GDC/GDMD.git"
|
||||
"folders.diff"
|
||||
)
|
||||
|
@ -28,7 +28,7 @@ sha256sums=(
|
|||
'2020c98295856aa13fda0f2f3a4794490757fc24bcca918d52cc8b4917b972dd'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'82f1ba0825164a74660bd5008d8f3acae1bacc3271c86475efc1601fe0da73c4'
|
||||
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
|
||||
)
|
||||
|
||||
groups=('dlang' 'dlang-gdc')
|
||||
|
|
|
@ -1,34 +1,39 @@
|
|||
diff --git a/gcc/d/d-incpath.cc b/gcc/d/d-incpath.cc
|
||||
index e04ddc6..168a033 100644
|
||||
--- a/gcc/d/d-incpath.cc
|
||||
+++ b/gcc/d/d-incpath.cc
|
||||
@@ -202,7 +202,7 @@ add_import_paths(const char *iprefix, const char *imultilib, bool stdinc)
|
||||
import_path = xstrdup(p->fname);
|
||||
|
||||
// Add D-specific suffix.
|
||||
- import_path = concat(import_path, "/d", NULL);
|
||||
+ import_path = concat(import_path, "/dlang/gdc", NULL);
|
||||
|
||||
// Ignore duplicate entries.
|
||||
bool found = false;
|
||||
diff --git a/libphobos/configure b/libphobos/configure
|
||||
index 2ff7114..f7f0660 100755
|
||||
--- a/libphobos/configure
|
||||
+++ b/libphobos/configure
|
||||
@@ -3883,7 +3883,7 @@ fi
|
||||
|
||||
|
||||
# Default case for install directory for D sources files.
|
||||
-gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
|
||||
+gdc_include_dir=${prefix}/include/dlang/gdc
|
||||
|
||||
|
||||
# Sanity check for the cross-compilation case:
|
||||
diff --git a/libphobos/configure.ac b/libphobos/configure.ac
|
||||
index 51d9b86..6ff04f1 100644
|
||||
index 84492dd..947f6a8 100644
|
||||
--- a/libphobos/configure.ac
|
||||
+++ b/libphobos/configure.ac
|
||||
@@ -239,9 +239,9 @@ else
|
||||
fi
|
||||
@@ -167,7 +167,7 @@ AC_SUBST(phobos_toolexecdir)
|
||||
AC_SUBST(phobos_toolexeclibdir)
|
||||
|
||||
if test "${gdc_host}" != "${gdc_target}"; then
|
||||
- gdc_include_dir='${libdir}/gcc/${host_alias}'/${d_gcc_ver}/include/d
|
||||
+ gdc_include_dir='${libdir}/gcc/${host_alias}'/${d_gcc_ver}/include/dlang
|
||||
else
|
||||
- gdc_include_dir='${prefix}'/include/d/${d_gcc_ver}
|
||||
+ gdc_include_dir='${prefix}'/include/dlang/gdc
|
||||
fi
|
||||
# Default case for install directory for D sources files.
|
||||
-gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
|
||||
+gdc_include_dir=${prefix}/include/dlang/gdc
|
||||
AC_SUBST(gdc_include_dir)
|
||||
AC_ARG_WITH([cross-host],
|
||||
|
||||
diff --git a/gcc/d/Make-lang.in b/gcc/d/Make-lang.in
|
||||
index 17e5c45..8a656b1 100644
|
||||
--- a/gcc/d/Make-lang.in
|
||||
+++ b/gcc/d/Make-lang.in
|
||||
@@ -25,10 +25,10 @@ D_TARGET_INSTALL_NAME = $(target_alias)-$(shell echo gdc|sed '$(program_transfor
|
||||
|
||||
# This should be configured
|
||||
ifeq ($(host), $(target))
|
||||
- D_include_dir = `echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include/d/$(version)
|
||||
+ D_include_dir = `echo $(exec_prefix) | sed -e 's|^$(prefix)||' -e 's|/[^/]*|/..|g'`/include/dlang/gdc
|
||||
gcc_d_include_dir = $(libsubdir)/$(unlibsubdir)/..$(D_include_dir)
|
||||
else
|
||||
- gcc_d_include_dir = $(libsubdir)/include/d
|
||||
+ gcc_d_include_dir = $(libsubdir)/include/dlang/gdc
|
||||
endif
|
||||
|
||||
|
||||
dnl Checks for header files.
|
||||
|
|
Loading…
Reference in a new issue