mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/meson: fix
This commit is contained in:
parent
50b71c8ae7
commit
33168239a3
1 changed files with 18 additions and 10 deletions
|
@ -1,15 +1,23 @@
|
|||
run_unittests.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
unittests/linuxliketests.py | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git c/run_unittests.py i/run_unittests.py
|
||||
index 15312731c..f9a0e494f 100755
|
||||
--- c/run_unittests.py
|
||||
+++ i/run_unittests.py
|
||||
@@ -7101,6 +7101,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise unittest.SkipTest('asan not available on Cygwin')
|
||||
diff --git c/unittests/linuxliketests.py i/unittests/linuxliketests.py
|
||||
index 81cca06dd..88b49b63e 100644
|
||||
--- c/unittests/linuxliketests.py
|
||||
+++ i/unittests/linuxliketests.py
|
||||
@@ -343,6 +343,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise SkipTest('asan not available on Cygwin')
|
||||
if is_openbsd():
|
||||
raise unittest.SkipTest('-fsanitize=address is not supported on OpenBSD')
|
||||
+ raise unittest.SkipTest('cannot run sanitizers in containers without ptrace')
|
||||
raise SkipTest('-fsanitize=address is not supported on OpenBSD')
|
||||
+ raise SkipTest('cannot run sanitizers in containers without ptrace')
|
||||
|
||||
testdir = os.path.join(self.framework_test_dir, '7 gnome')
|
||||
self.init(testdir, extra_args=['-Db_sanitize=address', '-Db_lundef=false'])
|
||||
@@ -974,6 +975,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise SkipTest('asan not available on Cygwin')
|
||||
if is_openbsd():
|
||||
raise SkipTest('-fsanitize=address is not supported on OpenBSD')
|
||||
+ raise SkipTest('cannot run sanitizers in containers without ptrace')
|
||||
|
||||
testdir = os.path.join(self.common_test_dir, '13 pch')
|
||||
self.init(testdir, extra_args=['-Db_sanitize=address', '-Db_lundef=false'])
|
||||
|
|
Loading…
Reference in a new issue