mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/systemd to 214-2.1
This commit is contained in:
parent
3ed38eb546
commit
332793722c
2 changed files with 38 additions and 6 deletions
25
core/systemd/0001-disable-xattr-mount.patch
Normal file
25
core/systemd/0001-disable-xattr-mount.patch
Normal file
|
@ -0,0 +1,25 @@
|
||||||
|
From 1ad6e53cf9a4ed81ec421c8d777707a29e58d9c3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Tue, 24 Jun 2014 05:36:29 -0600
|
||||||
|
Subject: [PATCH] disable xattr mount
|
||||||
|
|
||||||
|
---
|
||||||
|
src/core/mount-setup.c | 2 --
|
||||||
|
1 file changed, 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/core/mount-setup.c b/src/core/mount-setup.c
|
||||||
|
index ae8447c..42b5677 100644
|
||||||
|
--- a/src/core/mount-setup.c
|
||||||
|
+++ b/src/core/mount-setup.c
|
||||||
|
@@ -93,8 +93,6 @@ static const MountPoint mount_table[] = {
|
||||||
|
NULL, MNT_FATAL|MNT_IN_CONTAINER },
|
||||||
|
{ "tmpfs", "/sys/fs/cgroup", "tmpfs", "mode=755", MS_NOSUID|MS_NOEXEC|MS_NODEV|MS_STRICTATIME,
|
||||||
|
NULL, MNT_FATAL|MNT_IN_CONTAINER },
|
||||||
|
- { "cgroup", "/sys/fs/cgroup/systemd", "cgroup", "none,name=systemd,xattr", MS_NOSUID|MS_NOEXEC|MS_NODEV,
|
||||||
|
- NULL, MNT_FATAL|MNT_IN_CONTAINER },
|
||||||
|
{ "cgroup", "/sys/fs/cgroup/systemd", "cgroup", "none,name=systemd", MS_NOSUID|MS_NOEXEC|MS_NODEV,
|
||||||
|
NULL, MNT_FATAL|MNT_IN_CONTAINER },
|
||||||
|
{ "pstore", "/sys/fs/pstore", "pstore", NULL, MS_NOSUID|MS_NOEXEC|MS_NODEV,
|
||||||
|
--
|
||||||
|
1.9.0
|
||||||
|
|
|
@ -2,12 +2,12 @@
|
||||||
# Maintainer: Tom Gundersen <teg@jklm.no>
|
# Maintainer: Tom Gundersen <teg@jklm.no>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - --disable-xattr; ARM just has too many old, hacked up kernels
|
# - patch to remove xattr mount
|
||||||
|
|
||||||
pkgbase=systemd
|
pkgbase=systemd
|
||||||
pkgname=('systemd' 'libsystemd' 'systemd-sysvcompat')
|
pkgname=('systemd' 'libsystemd' 'systemd-sysvcompat')
|
||||||
pkgver=214
|
pkgver=214
|
||||||
pkgrel=2
|
pkgrel=2.1
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url="http://www.freedesktop.org/wiki/Software/systemd"
|
url="http://www.freedesktop.org/wiki/Software/systemd"
|
||||||
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gobject-introspection' 'gperf'
|
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gobject-introspection' 'gperf'
|
||||||
|
@ -18,11 +18,19 @@ options=('strip' 'debug')
|
||||||
source=("http://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
|
source=("http://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
|
||||||
'initcpio-hook-udev'
|
'initcpio-hook-udev'
|
||||||
'initcpio-install-systemd'
|
'initcpio-install-systemd'
|
||||||
'initcpio-install-udev')
|
'initcpio-install-udev'
|
||||||
|
'0001-disable-xattr-mount.patch')
|
||||||
md5sums=('eac4f9fc5bd18a0efc3fc20858baacf3'
|
md5sums=('eac4f9fc5bd18a0efc3fc20858baacf3'
|
||||||
'29245f7a240bfba66e2b1783b63b6b40'
|
'29245f7a240bfba66e2b1783b63b6b40'
|
||||||
'66cca7318e13eaf37c5b7db2efa69846'
|
'66cca7318e13eaf37c5b7db2efa69846'
|
||||||
'bde43090d4ac0ef048e3eaee8202a407')
|
'bde43090d4ac0ef048e3eaee8202a407'
|
||||||
|
'097c8e2a7d2b10d7cf4ce720afbe231f')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "$pkgname-$pkgver"
|
||||||
|
|
||||||
|
patch -p1 -i ../0001-disable-xattr-mount.patch
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$pkgname-$pkgver"
|
cd "$pkgname-$pkgver"
|
||||||
|
@ -39,8 +47,7 @@ build() {
|
||||||
--disable-kdbus \
|
--disable-kdbus \
|
||||||
--with-sysvinit-path= \
|
--with-sysvinit-path= \
|
||||||
--with-sysvrcnd-path= \
|
--with-sysvrcnd-path= \
|
||||||
--with-firmware-path="/usr/lib/firmware/updates:/usr/lib/firmware" \
|
--with-firmware-path="/usr/lib/firmware/updates:/usr/lib/firmware"
|
||||||
--disable-xattr
|
|
||||||
|
|
||||||
make
|
make
|
||||||
}
|
}
|
||||||
|
|
Loading…
Reference in a new issue