community/luminancehdr to 2.5.0-1

This commit is contained in:
David Beauchamp 2017-04-18 17:55:24 -04:00
parent fe609e4e19
commit 332ec0877a
3 changed files with 8 additions and 38 deletions

View file

@ -7,30 +7,26 @@
# - patch to remove sse and sse2 flags
pkgname=luminancehdr
pkgver=2.4.0
pkgrel=9
pkgver=2.5.0
pkgrel=1
pkgdesc='Open source graphical user interface application that aims to provide a workflow for HDR imaging'
arch=('i686' 'x86_64')
url='http://qtpfsgui.sourceforge.net/'
license=('GPL')
depends=('exiv2' 'fftw' 'gsl' 'lcms2' 'libraw' 'openexr' 'qt5-webkit' 'ccfits' 'desktop-file-utils' 'hicolor-icon-theme')
depends=('exiv2' 'fftw' 'gsl' 'lcms2' 'libraw' 'openexr' 'qt5-webengine' 'qt5-svg'
'qt5-webkit' 'ccfits' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('cmake' 'boost' 'gtest' 'qt5-tools' 'patch')
optdepends=('hugin: align image stack functionality')
changelog=$pkgname.changelog
options=('!emptydirs')
source=(http://sourceforge.net/projects/qtpfsgui/files/luminance/$pkgver/luminance-hdr-$pkgver.tar.bz2
qt5_printsupport.diff
strip-sse.patch)
sha256sums=('14014eadab099944f051dd99447f6f47d455ffb0e4e0272d93a8e71fd96ad401'
'be2aaf8f544b086b770cec3db026e8ef7057bf3797961efeb8465197e4332c01'
sha256sums=('f5caf3316d1763058b1b0f2a6963df34465fbf918b7abeee5245a51fc14a7942'
'f74a1d27684a7a8fa3223e1bf8e04bd2158925b8f1d0b32ef167910920511974')
prepare() {
cd "${srcdir}"/luminance-hdr-$pkgver
#Fix build error with Qt >= 5.3.2
patch -Np1 -i "${srcdir}"/qt5_printsupport.diff
patch -p0 -i ../strip-sse.patch
}

View file

@ -1,3 +1,6 @@
2017-04-18 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* luminancehdr 2.5.0-1
2017-01-07 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* luminancehdr 2.4.0-9 libraw 0.18 rebuild

View file

@ -1,29 +0,0 @@
Description: Fix build error with Qt >= 5.3.2
Upstream's 07e36ef892343b01bf13545866823e6a55044382 does essentially the
same thing.
Author: Andreas Metzler <ametzler@debian.org>
Bug-Debian: https://bugs.debian.org/763224
Origin: vendor
Forwarded: not-needed
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,7 @@ find_package(Qt5Xml)
find_package(Qt5Sql)
find_package(Qt5Network)
find_package(Qt5LinguistTools)
+find_package(Qt5PrintSupport)
IF(WIN32)
find_package(Qt5WinExtras)
ENDIF()
--- a/src/HelpBrowser/CMakeLists.txt
+++ b/src/HelpBrowser/CMakeLists.txt
@@ -29,7 +29,7 @@ QT5_WRAP_UI(FILES_UI_H ${FILES_UI})
ADD_LIBRARY(helpbrowser ${FILES_H} ${FILES_CPP} ${FILES_MOC} ${FILES_UI_H} ${FILES_HXX})
-qt5_use_modules(helpbrowser Core Concurrent Gui Widgets Xml WebKit WebKitWidgets)
+qt5_use_modules(helpbrowser Core Concurrent Gui Widgets Xml WebKit WebKitWidgets PrintSupport)
SET(FILES_TO_TRANSLATE ${FILES_TO_TRANSLATE} ${FILES_CPP} ${FILES_H} ${FILES_UI} ${FILES_HXX} PARENT_SCOPE)
SET(LUMINANCE_MODULES_GUI ${LUMINANCE_MODULES_GUI} helpbrowser PARENT_SCOPE)