diff --git a/core/zlib/PKGBUILD b/core/zlib/PKGBUILD
old mode 100755
new mode 100644
index 286d14700..a3f9d765f
--- a/core/zlib/PKGBUILD
+++ b/core/zlib/PKGBUILD
@@ -1,42 +1,37 @@
-# Maintainer: Mike Staszel <mikestaszel@plugboxlinux.org>
+# $Id: PKGBUILD 148443 2012-01-31 23:47:54Z pierre $
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
 
-# Plugbox changes: Removed the GCC patch (CFLAGS="${CFLAGS/-O2/-O3} -f...)
-#                   Added --shared to the end of ./configure
-#
-# Absolutely positively make sure you make these changes. Plugbox will
-# crash, burn, die, and stop working without them.
+# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
+#  - added --shared to configure
 
+plugrel=1
 
 pkgname=zlib
-pkgver=1.2.5
-pkgrel=4
-plugrel=1
+pkgver=1.2.6
+pkgrel=1
 pkgdesc='Compression library implementing the deflate compression method found in gzip and PKZIP'
-arch=('arm')
+arch=('i686' 'x86_64')
 license=('custom')
 url="http://www.zlib.net/"
 depends=('glibc')
-options=('!makeflags')
-source=("http://zlib.net/zlib-${pkgver}.tar.gz"
-        'zlib-1.2.5-lfs-decls.patch')
-md5sums=('c735eab2d659a96e5a594c9e8541ad63'
-         '4cb279ea3beab621f3526bf7b7ab99e5')
+source=("http://zlib.net/current/zlib-${pkgver}.tar.gz")
+md5sums=('618e944d7c7cd6521551e30b32322f4a')
 
 build() {
 	cd ${srcdir}/zlib-$pkgver
-
-	# see http://bugs.archlinux.org/task/19280
-	patch -p1 -i ${srcdir}/zlib-1.2.5-lfs-decls.patch || return 1
-
 	./configure --prefix=/usr --shared
-
-	make || return 1
+	make
 
 	grep -A 24 '^  Copyright' zlib.h > LICENSE
 }
 
+check() {
+	cd ${srcdir}/zlib-$pkgver
+	make test
+}
+
 package() {
 	cd ${srcdir}/zlib-$pkgver
-	make install DESTDIR=${pkgdir} || return 1
+	make install DESTDIR=${pkgdir}
 	install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/zlib/LICENSE
 }
diff --git a/core/zlib/zlib-1.2.5-lfs-decls.patch b/core/zlib/zlib-1.2.5-lfs-decls.patch
deleted file mode 100644
index 36e26af03..000000000
--- a/core/zlib/zlib-1.2.5-lfs-decls.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: zlib-1.2.5/zlib.h
-===================================================================
---- zlib-1.2.5.orig/zlib.h
-+++ zlib-1.2.5/zlib.h
-@@ -1578,7 +1578,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
- #  define gzoffset gzoffset64
- #  define adler32_combine adler32_combine64
- #  define crc32_combine crc32_combine64
--#  ifdef _LARGEFILE64_SOURCE
-+#  ifndef _LARGEFILE64_SOURCE
-      ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
-      ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
-      ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));