diff --git a/extra/calligra/PKGBUILD b/extra/calligra/PKGBUILD
index 73e70e945..28ab31e5b 100644
--- a/extra/calligra/PKGBUILD
+++ b/extra/calligra/PKGBUILD
@@ -10,26 +10,28 @@
 
 pkgname=calligra
 pkgdesc="A set of applications for productivity and creative usage"
-pkgver=3.0.1
-pkgrel=9
+pkgver=3.1.0
+pkgrel=1
 arch=(x86_64)
 url='https://www.calligra-suite.org/'
 license=(FDL1.2 GPL2 LGPL)
 depends=(kcmutils knotifyconfig kross kactivities kdiagram kreport libspnav kdelibs4support
-         gsl openexr kcontacts kcalcore qca-qt5 poppler-qt5 libodfgen qt5-webkit cauchy khtml)
+         gsl openexr kcontacts qca-qt5 poppler-qt5 libodfgen qt5-webkit cauchy khtml)
 makedepends=(extra-cmake-modules kdoctools python kdesignerplugin boost openjpeg akonadi-contacts
-             libwpg okular eigen marble-common pstoedit libvisio libetonyek libwps)
+             libwpg okular eigen marble-common pstoedit libvisio libetonyek libwps libgit2)
 optdepends=('libwpg: Corel WordPerfect Graphics image importer'
             'libwps: Microsoft Works file word processor format import'
             'libvisio: Microsoft Visio import filter'
             'libetonyek: Apple Keynote import filter'
             'pstoedit: EPS to SVG filter'
             'poppler: PDF to SVG filter'
-            'openjpeg: PDF to SVG filer')
-conflicts=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs calligra-plan
+            'openjpeg: PDF to SVG filer'
+            'libgit2: Calligra Gemini git plugin'
+            'kirigami2: for Calligra Gemini')
+conflicts=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs
            calligra-plugins calligra-sheets calligra-stage calligra-words calligra-l10n calligra-meta
            calligra-flow calligra-braindump calligra-gemini calligra-handbook)
-replaces=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs calligra-plan
+replaces=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs
           calligra-plugins calligra-sheets calligra-stage calligra-words calligra-l10n calligra-meta)
 for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb nl \
              pl pt pt_br ru sk sv uk zh_cn zh_tw; do
@@ -37,11 +39,9 @@ for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb n
   replaces+=(calligra-l10n-$_lang)
 done
 source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
-        calligra-kcalcore-17.12.patch::"https://cgit.kde.org/calligra.git/patch/?id=9a02a545"
         'calligra-2.9.11-gcc6_arm.patch')
-sha256sums=('452bddc4e03cfbf48de508b991dc94209d386d86bf010ea9d10afed0f5694db2'
+sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
             'SKIP'
-            '83b8eff3e5fa50decf826b22912d0f77ae855c230c470ad4c260870a888cdce0'
             '33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
 validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD  # Boudewijn Rempt <foundation@krita.org>
               42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
@@ -50,7 +50,6 @@ prepare() {
   mkdir -p build
 
   cd $pkgbase-$pkgver
-  patch -p1 -i ../calligra-kcalcore-17.12.patch # Fix build with kcalcore 17.12
   patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
 }