extra/mesa to 18.0.0-4

This commit is contained in:
Kevin Mihelich 2018-04-14 16:33:24 +00:00
parent 99d484ed70
commit 3388384d1d
2 changed files with 20 additions and 1 deletions

View file

@ -10,7 +10,7 @@ pkgbase=mesa
pkgname=('libva-mesa-driver' 'mesa-vdpau' 'mesa')
pkgdesc="An open-source implementation of the OpenGL specification"
pkgver=18.0.0
pkgrel=3
pkgrel=4
arch=('x86_64')
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
'libxshmfence' 'libxxf86vm' 'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols'
@ -23,6 +23,7 @@ source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
0001-glvnd-fix-gl-dot-pc.patch
fix-install.diff
fix-versions.diff
ndebug.diff
"atomic.patch::https://cgit.freedesktop.org/mesa/mesa/patch/?id=498faea103aa7966b435f21d8ff5e36172389b1e")
sha512sums=('1494bb09357896a2505b3dcfec772268e28c765804f21e144948a314f1d79d99ff9f21062ef5860eb5a5a568b305a9c954585924a7ac8890fe1ebd8df3bcc396'
'SKIP'
@ -31,6 +32,7 @@ sha512sums=('1494bb09357896a2505b3dcfec772268e28c765804f21e144948a314f1d79d99ff9
'75849eca72ca9d01c648d5ea4f6371f1b8737ca35b14be179e14c73cc51dca0739c333343cdc228a6d464135f4791bcdc21734e2debecd29d57023c8c088b028'
'da32ac3b025282c584bfc962723151b6e11887e59e35086c616a987cb3a471051d60f2b303a91f37106ebb75621cbd9b3f560036f5beb88518cfe9d75c45ee03'
'836f06af6feaa79a16bedd7a136d637b7f16e53d98b8b267554d98b5ff8c3fa45955b9e3ce0b8366d86860194e9147baf0257614fff85a471e2b90bbb3b1f5ab'
'9ca216f8a84e767e4df2d02135004b173cb7905368573402cb8329e8e53101c5b519bf9b74cebfeab9ccd550b6c62c0fc88ec9a9e631023e011bb5634522c034'
'75cd21bccc84a6b6b0de39c6d209c8bee0e5143b486433184ca078e8bc6797d30746be3ce5f7a89eea9bc3c7e2d68880412511fd6b9946252c7c7638523c6caa')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
@ -51,6 +53,10 @@ prepare() {
# this is upstreamable
patch -Np1 -i ../fix-versions.diff
# define NDEBUG for non-debug builds, like configure does
# this is upstreamable
patch -Np1 -i ../ndebug.diff
# file missing from tarball
cp ../meson_get_version.py bin/

13
extra/mesa/ndebug.diff Normal file
View file

@ -0,0 +1,13 @@
diff --git i/meson.build w/meson.build
index a4dfa62255..931e0389e6 100644
--- i/meson.build
+++ w/meson.build
@@ -705,6 +705,8 @@ endif
# Define DEBUG for debug builds only (debugoptimized is not included on this one)
if get_option('buildtype') == 'debug'
pre_args += '-DDEBUG'
+else
+ pre_args += '-DNDEBUG'
endif
if get_option('shader-cache')