extra/libreoffice-fresh to 7.3.0-3

This commit is contained in:
David Beauchamp 2022-02-05 15:20:34 -05:00
parent 82286d1828
commit 3397ac7b58
2 changed files with 83 additions and 2 deletions

View file

@ -0,0 +1,76 @@
From db43e8a2a02adaa3571137b82855c01fad4c2534 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Wed, 2 Feb 2022 16:21:43 +0000
Subject: rhbz#2047319 drop the SolarMutex before QApplication::init()
https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/24#note_383915
reproducible with with qt5-qtwayland-5.15.2-17.fc35.x86_64 and
export OOO_FORCE_DESKTOP=plasma5
export SAL_USE_VCLPLUGIN=gtk3
Change-Id: Icdf6b8709865c723c266e6400169b33639a1b0e4
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/129428
Tested-by: Jenkins
Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
---
shell/Library_kf5be.mk | 1 +
shell/source/backends/kf5be/kf5backend.cxx | 23 +++++++++++++++--------
2 files changed, 16 insertions(+), 8 deletions(-)
diff --git a/shell/Library_kf5be.mk b/shell/Library_kf5be.mk
index 628145176e0f..157f8b9836f8 100644
--- a/shell/Library_kf5be.mk
+++ b/shell/Library_kf5be.mk
@@ -20,6 +20,7 @@ $(eval $(call gb_Library_use_libraries,kf5be1,\
cppu \
cppuhelper \
sal \
+ vcl \
))
$(eval $(call gb_Library_set_componentfile,kf5be1,shell/source/backends/kf5be/kf5be1))
diff --git a/shell/source/backends/kf5be/kf5backend.cxx b/shell/source/backends/kf5be/kf5backend.cxx
index e9e10e60fd27..2b41414c54cd 100644
--- a/shell/source/backends/kf5be/kf5backend.cxx
+++ b/shell/source/backends/kf5be/kf5backend.cxx
@@ -41,6 +41,7 @@
#include <rtl/ustring.hxx>
#include <sal/types.h>
#include <uno/current_context.hxx>
+#include <vcl/svapp.hxx>
#include <osl/process.h>
#include <osl/thread.h>
@@ -172,14 +173,20 @@ void initQApp(std::map<OUString, css::beans::Optional<css::uno::Any>>& rSettings
unsetenv("SESSION_MANAGER");
}
- std::unique_ptr<QApplication> app(new QApplication(nFakeArgc, pFakeArgv));
- QObject::connect(app.get(), &QObject::destroyed, app.get(), [nFakeArgc, pFakeArgv]() {
- for (int i = 0; i < nFakeArgc; ++i)
- free(pFakeArgv[i]);
- delete[] pFakeArgv;
- });
-
- readKDESettings(rSettings);
+ {
+ // rhbz#2047319 drop the SolarMutex during the execution of QApplication::init()
+ // https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/24#note_383915
+ SolarMutexReleaser aReleaser; // rhbz#2047319 drop the SolarMutex during the execution
+
+ std::unique_ptr<QApplication> app(new QApplication(nFakeArgc, pFakeArgv));
+ QObject::connect(app.get(), &QObject::destroyed, app.get(), [nFakeArgc, pFakeArgv]() {
+ for (int i = 0; i < nFakeArgc; ++i)
+ free(pFakeArgv[i]);
+ delete[] pFakeArgv;
+ });
+
+ readKDESettings(rSettings);
+ }
if (session_manager != nullptr)
{
--
cgit v1.2.1

View file

@ -21,7 +21,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=7.3.0.3
pkgver=7.3.0
pkgrel=2
pkgrel=3
arch=('x86_64')
license=('LGPL3')
url="https://www.libreoffice.org/"
@ -71,6 +71,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
make-pyuno-work-with-system-wide-module-install.diff
fix-lto-build-without-clang.patch
0001_drop_the_SolarMutex_before_QApplication.patch
soffice-template.desktop.in
libreoffice-fresh.sh libreoffice-fresh.csh)
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -120,10 +121,11 @@ sha256sums=('98d369c9541f0c3286345b93f448f2ceb2e344865ee01bdd58f3bb27f08f3f25'
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'bbbeec2ed1b9b3054e70c4cee9837a40fb89a11edbb73718533945f109ea683e'
'81a8551aaea0ab1750d36fb8bfbd04340a43eaab349a43c1384d21ef6504ab47'
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
'de20f36d45f0fecc2d94176dd3ec7226ab07fa8ffb9b0bc73c200349a9273de1')
prepare() {
cd libreoffice-$_LOver
@ -146,6 +148,9 @@ prepare() {
# fix LTO build when clang is not present
patch -Np1 -i "${srcdir}"/fix-lto-build-without-clang.patch
# fix crash on start - FS#73471
patch -Np1 -i "${srcdir}"/0001_drop_the_SolarMutex_before_QApplication.patch
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
case "$i" in