extra/claws-mail to 3.8.1-1

This commit is contained in:
Kevin Mihelich 2012-06-28 08:51:42 -04:00
parent e9a2787bb0
commit 3421e590f4
2 changed files with 4 additions and 25 deletions

View file

@ -7,8 +7,8 @@
plugrel=1
pkgname=claws-mail
pkgver=3.8.0
pkgrel=3
pkgver=3.8.1
pkgrel=1
pkgdesc="A GTK+ based e-mail client."
arch=('i686' 'x86_64')
license=('GPL3')
@ -24,14 +24,11 @@ replaces=('sylpheed-claws')
provides=('claws')
options=(!libtool)
install=claws-mail.install
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2
buildfix_gnutls3.diff)
md5sums=('df9f1657d7f34959a2205344d952c2e3'
'0c0956755ddcec939d916af35310ee3f')
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2)
md5sums=('d388929fb1c8f04d4bcb2139faaf9e70')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -Np0 -i ${srcdir}/buildfix_gnutls3.diff
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py

View file

@ -1,18 +0,0 @@
Index: src/common/ssl_certificate.c
===================================================================
RCS file: //claws/src/common/ssl_certificate.c,v
retrieving revision 1.4.2.40
retrieving revision 1.4.2.41
diff -u -r1.4.2.40 -r1.4.2.41
--- src/common/ssl_certificate.c 30 Aug 2011 06:18:09 -0000 1.4.2.40
+++ src/common/ssl_certificate.c 16 May 2012 05:43:14 -0000 1.4.2.41
@@ -686,7 +686,7 @@
gnutls_x509_privkey * key,
gnutls_x509_crt_t * cert)
{
- gnutls_pkcs12_bag bag = NULL;
+ gnutls_pkcs12_bag_t bag = NULL;
int index = 0;
int ret;