mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/protobuf to 27.3-1
This commit is contained in:
parent
99ba7e2ac1
commit
3433a26b40
4 changed files with 14 additions and 51 deletions
|
@ -1,6 +1,6 @@
|
|||
pkgbase = protobuf
|
||||
pkgdesc = Protocol Buffers - Google's data interchange format
|
||||
pkgver = 27.2
|
||||
pkgver = 27.3
|
||||
pkgrel = 1
|
||||
url = https://developers.google.com/protocol-buffers/
|
||||
arch = x86_64
|
||||
|
@ -18,12 +18,10 @@ pkgbase = protobuf
|
|||
depends = glibc
|
||||
depends = zlib
|
||||
depends = abseil-cpp
|
||||
source = https://github.com/protocolbuffers/protobuf/archive/v27.2/protobuf-27.2.tar.gz
|
||||
source = https://github.com/protocolbuffers/protobuf/archive/v27.3/protobuf-27.3.tar.gz
|
||||
source = https://github.com/protocolbuffers/protobuf/commit/2e62ef1e.patch
|
||||
source = soversion.patch
|
||||
sha512sums = 664c66b62cf1ed0c65d9b910d8e67d4d5d471113697f1b8edf1573cd5c0fc8e850ac53ce984e48e6c6b9cbbefa12f8530058384e7388e65a59c1e46d03772397
|
||||
sha512sums = 18bc71031bbcbc3810a9985fa670465040f06a6c104ab8079b56bdfc499bb6cec40805a0cefd455031142490a576dc60aa8000523877ac0353b93558e9beabbd
|
||||
sha512sums = f0813a415cff5639e4709400f15b0c5565294e7907ae164e620b76258734c643115d8e5170bf0e4aee264c347fb7e01ac4be60d19be2a91c0ce9c561dad8c8e9
|
||||
sha512sums = a3a555f17a069dd4aa0d683d3126915077fe4211ae6532a4947fb76a9eeb1ed7d25d29ada8dc372435a08aad1aa14374d88e92ac7c195510f57609efaf9d341d
|
||||
sha512sums = f42d9bd702abe2c7fc4dcb07d050376287ac60b0b7e2fde0d7a9e9df24a620866bee5fd7de2e3b216095376de47e1fe7443cca74c9a9e85c1a0bc42e8973a280
|
||||
|
||||
pkgname = protobuf
|
||||
provides = libprotoc.so
|
||||
|
@ -33,5 +31,5 @@ pkgname = protobuf
|
|||
|
||||
pkgname = python-protobuf
|
||||
pkgdesc = Python 3 bindings for Google Protocol Buffers
|
||||
depends = protobuf=27.2
|
||||
depends = protobuf=27.3
|
||||
depends = python
|
||||
|
|
5
extra/protobuf/.nvchecker.toml
Normal file
5
extra/protobuf/.nvchecker.toml
Normal file
|
@ -0,0 +1,5 @@
|
|||
[protobuf]
|
||||
source = "git"
|
||||
git = "https://github.com/protocolbuffers/protobuf.git"
|
||||
prefix = "v"
|
||||
exclude_regex = ".*(pre|rc|alpha|beta|dev).*"
|
|
@ -16,10 +16,9 @@
|
|||
|
||||
pkgbase='protobuf'
|
||||
pkgname=('protobuf')
|
||||
pkgver=27.2
|
||||
pkgver=27.3
|
||||
pkgrel=1
|
||||
# Note: python-protobuf needs to be updated alongside this package to the same version
|
||||
# Note: libphonenumber needs a rebuild for every version bump
|
||||
pkgdesc="Protocol Buffers - Google's data interchange format"
|
||||
arch=('x86_64')
|
||||
url='https://developers.google.com/protocol-buffers/'
|
||||
|
@ -43,15 +42,12 @@ checkdepends=(
|
|||
python-numpy
|
||||
)
|
||||
source=(https://github.com/protocolbuffers/protobuf/archive/v$pkgver/$pkgname-$pkgver.tar.gz
|
||||
https://github.com/protocolbuffers/protobuf/commit/2e62ef1e.patch
|
||||
soversion.patch)
|
||||
sha512sums=('664c66b62cf1ed0c65d9b910d8e67d4d5d471113697f1b8edf1573cd5c0fc8e850ac53ce984e48e6c6b9cbbefa12f8530058384e7388e65a59c1e46d03772397'
|
||||
'18bc71031bbcbc3810a9985fa670465040f06a6c104ab8079b56bdfc499bb6cec40805a0cefd455031142490a576dc60aa8000523877ac0353b93558e9beabbd'
|
||||
'f0813a415cff5639e4709400f15b0c5565294e7907ae164e620b76258734c643115d8e5170bf0e4aee264c347fb7e01ac4be60d19be2a91c0ce9c561dad8c8e9')
|
||||
https://github.com/protocolbuffers/protobuf/commit/2e62ef1e.patch)
|
||||
sha512sums=('a3a555f17a069dd4aa0d683d3126915077fe4211ae6532a4947fb76a9eeb1ed7d25d29ada8dc372435a08aad1aa14374d88e92ac7c195510f57609efaf9d341d'
|
||||
'f42d9bd702abe2c7fc4dcb07d050376287ac60b0b7e2fde0d7a9e9df24a620866bee5fd7de2e3b216095376de47e1fe7443cca74c9a9e85c1a0bc42e8973a280')
|
||||
|
||||
prepare() {
|
||||
patch -d $pkgname-$pkgver -p1 < 2e62ef1e.patch # Fix cmake config compatibility mode
|
||||
patch -d $pkgbase-$pkgver -p1 < soversion.patch # Restore soversion
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
diff --git a/cmake/libprotobuf-lite.cmake b/cmake/libprotobuf-lite.cmake
|
||||
index 9b1de677b4f..276c99c489e 100644
|
||||
--- a/cmake/libprotobuf-lite.cmake
|
||||
+++ b/cmake/libprotobuf-lite.cmake
|
||||
@@ -30,6 +30,7 @@ if(protobuf_BUILD_SHARED_LIBS)
|
||||
endif()
|
||||
set_target_properties(libprotobuf-lite PROPERTIES
|
||||
VERSION ${protobuf_VERSION}
|
||||
+ SOVERSION ${protobuf_VERSION_MINOR}
|
||||
OUTPUT_NAME ${LIB_PREFIX}protobuf-lite
|
||||
DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
|
||||
add_library(protobuf::libprotobuf-lite ALIAS libprotobuf-lite)
|
||||
diff --git a/cmake/libprotobuf.cmake b/cmake/libprotobuf.cmake
|
||||
index aa3efc9a68a..0f34d20b97d 100644
|
||||
--- a/cmake/libprotobuf.cmake
|
||||
+++ b/cmake/libprotobuf.cmake
|
||||
@@ -33,6 +33,7 @@ if(protobuf_BUILD_SHARED_LIBS)
|
||||
endif()
|
||||
set_target_properties(libprotobuf PROPERTIES
|
||||
VERSION ${protobuf_VERSION}
|
||||
+ SOVERSION ${protobuf_VERSION_MINOR}
|
||||
OUTPUT_NAME ${LIB_PREFIX}protobuf
|
||||
DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
|
||||
add_library(protobuf::libprotobuf ALIAS libprotobuf)
|
||||
diff --git a/cmake/libprotoc.cmake b/cmake/libprotoc.cmake
|
||||
index 72b4a1abb92..91e8bbeb04e 100644
|
||||
--- a/cmake/libprotoc.cmake
|
||||
+++ b/cmake/libprotoc.cmake
|
||||
@@ -24,6 +24,7 @@ endif()
|
||||
set_target_properties(libprotoc PROPERTIES
|
||||
COMPILE_DEFINITIONS LIBPROTOC_EXPORTS
|
||||
VERSION ${protobuf_VERSION}
|
||||
+ SOVERSION ${protobuf_VERSION_MINOR}
|
||||
OUTPUT_NAME ${LIB_PREFIX}protoc
|
||||
DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
|
||||
add_library(protobuf::libprotoc ALIAS libprotoc)
|
Loading…
Reference in a new issue