extra/firefox to 95.0-1

This commit is contained in:
Kevin Mihelich 2021-12-08 00:27:38 +00:00
parent 81d13cc24c
commit 345e976061
2 changed files with 13 additions and 17 deletions

View file

@ -9,10 +9,10 @@ Subject: [PATCH] Use remoting name for GDK application names
2 files changed, 6 insertions(+), 12 deletions(-)
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
index 332f340179d3..840ad794f606 100644
index 60ea6966cccf..ae862aba01b3 100644
--- a/toolkit/xre/nsAppRunner.cpp
+++ b/toolkit/xre/nsAppRunner.cpp
@@ -4285,11 +4285,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
@@ -4299,11 +4299,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
// consistently.
// Set program name to the one defined in application.ini.
@ -26,11 +26,11 @@ index 332f340179d3..840ad794f606 100644
// Initialize GTK here for splash.
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
index 60de473de07a..004c066575c1 100644
index 7090bd2ef350..76bda087be72 100644
--- a/widget/gtk/nsAppShell.cpp
+++ b/widget/gtk/nsAppShell.cpp
@@ -24,6 +24,8 @@
# include "WakeLockListener.h"
@@ -27,6 +27,8 @@
# include "nsIObserverService.h"
#endif
#include "gfxPlatform.h"
+#include "nsAppRunner.h"
@ -38,7 +38,7 @@ index 60de473de07a..004c066575c1 100644
#include "ScreenHelperGTK.h"
#include "HeadlessScreenHelper.h"
#include "mozilla/widget/ScreenManager.h"
@@ -152,13 +154,9 @@ nsresult nsAppShell::Init() {
@@ -256,13 +258,9 @@ nsresult nsAppShell::Init() {
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
//
// Only bother doing this for the parent process, since it's the one

View file

@ -11,8 +11,8 @@ buildarch=12
highmem=1
pkgname=firefox
pkgver=94.0.2
pkgrel=2
pkgver=95.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@ -20,7 +20,8 @@ url="https://www.mozilla.org/firefox/"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack nodejs cbindgen nasm
python-setuptools python-psutil python-zstandard lld dump_syms)
python-setuptools python-psutil python-zstandard lld dump_syms
wasi-compiler-rt wasi-libc wasi-libc++ wasi-libc++abi)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@ -31,13 +32,11 @@ options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
build-arm-libopus.patch
0001-Use-remoting-name-for-GDK-application-names.patch
0002-Bug-1735905-Upgrade-cubeb-pulse-to-fix-a-race-condit.patch
$pkgname.desktop identity-icons-brand.svg)
sha256sums=('899ba1c806549034793d7e8ca53f4c845d783c810338f314f3d653d39649e575'
sha256sums=('7fa3e43f6ec710b2ebba0e99db713a56d13d85f1f23c4a1399bb594fd74864de'
'SKIP'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'51cca2cab0fa9798f96b81ed24c238b2a7c98524f589ec500224bac9797b66fb'
'744d3956ba60c63fed81903700a4cf66c13d2898944e4e86ac0d3b1e3f222fff'
'a7a5ea4680c0a4c6eb5a5f99970008f5ad3e2f29f0d6d050aa651bce8c713718'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -62,10 +61,6 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
# https://bugzilla.opensuse.org/show_bug.cgi?id=1192067
# https://bugzilla.mozilla.org/show_bug.cgi?id=1735905
patch -Np1 -i ../0002-Bug-1735905-Upgrade-cubeb-pulse-to-fix-a-race-condit.patch
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@ -80,6 +75,7 @@ ac_add_options --enable-release
#ac_add_options --enable-rust-simd
ac_add_options --enable-linker=lld
ac_add_options --disable-bootstrap
ac_add_options --with-wasi-sysroot=/usr/share/wasi-sysroot
# Branding
ac_add_options --enable-official-branding