mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/percona 5.6. 13
This commit is contained in:
parent
a7501b990f
commit
34b6bccde5
4 changed files with 1190 additions and 814 deletions
|
@ -4,7 +4,7 @@
|
|||
# - added alarm.patch
|
||||
|
||||
pkgname=percona-server
|
||||
pkgver=5.5.33_rel31.1
|
||||
pkgver=5.6.13_rel61.0
|
||||
pkgrel=1
|
||||
pkgdesc="A backwards-compatible drop-in replacement for MySQL that provides improved performance, diagnostics and instrumentation"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -21,16 +21,17 @@ options=('!libtool' 'emptydirs')
|
|||
backup=('etc/mysql/my.cnf')
|
||||
install=percona.install
|
||||
source=("http://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona-Server-${pkgver/_rel/-}/source/Percona-Server-${pkgver/_/-}.tar.gz"
|
||||
'0001-MDEV-4902-sql_yacc.yy-incompatible-with-bison-3.patch'
|
||||
'mysqld-post.sh'
|
||||
'mysqld.service'
|
||||
'mysqld-tmpfile.conf'
|
||||
'mysql56-bufsize.patch'
|
||||
'mysql56-bison3.patch'
|
||||
'alarm.patch')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/Percona-Server-${pkgver/_/-}"
|
||||
sed -i 's|ADD_SUBDIRECTORY(libmysqld/examples)|# ADD_SUBDIRECTORY(libmysqld/examples)|' CMakeLists.txt
|
||||
patch -p1 -i "$srcdir/0001-MDEV-4902-sql_yacc.yy-incompatible-with-bison-3.patch"
|
||||
patch -p0 -i "$srcdir/mysql56-bufsize.patch"
|
||||
patch -p1 -i "$srcdir/mysql56-bison3.patch"
|
||||
patch -p1 -i "${srcdir}/alarm.patch"
|
||||
}
|
||||
|
||||
|
@ -76,7 +77,7 @@ build() {
|
|||
-DWITH_FEDERATED_STORAGE_ENGINE=OFF \
|
||||
-DWITH_EXAMPLE_STORAGE_ENGINE=OFF \
|
||||
-DCMAKE_C_FLAGS="-fPIC ${CFLAGS} -fno-strict-aliasing -DBIG_JOINS=1 -fomit-frame-pointer" \
|
||||
-DCMAKE_CXX_FLAGS="-fPIC ${CXXFLAGS} -fno-strict-aliasing -DBIG_JOINS=1 -felide-constructors -fno-rtti -fpermissive"
|
||||
-DCMAKE_CXX_FLAGS="-fPIC ${CXXFLAGS} -fno-strict-aliasing -DBIG_JOINS=1 -felide-constructors -fno-rtti"
|
||||
|
||||
make
|
||||
}
|
||||
|
@ -85,7 +86,7 @@ package() {
|
|||
cd "${srcdir}"/build
|
||||
make DESTDIR=${pkgdir} install
|
||||
|
||||
install -Dm644 "${pkgdir}"/usr/share/mysql/my-medium.cnf "${pkgdir}"/etc/mysql/my.cnf
|
||||
install -Dm644 "${pkgdir}"/usr/share/mysql/my-default.cnf "${pkgdir}"/etc/mysql/my.cnf
|
||||
install -Dm755 "${srcdir}"/mysqld-post.sh "${pkgdir}"/usr/bin/mysqld-post
|
||||
install -Dm644 "${srcdir}"/mysqld-tmpfile.conf "${pkgdir}"/usr/lib/tmpfiles.d/mysqld.conf
|
||||
install -Dm644 "${srcdir}"/mysqld.service "${pkgdir}"/usr/lib/systemd/system/mysqld.service
|
||||
|
@ -107,9 +108,10 @@ package() {
|
|||
install -dm700 "${pkgdir}"/var/lib/mysql
|
||||
}
|
||||
|
||||
sha256sums=('2039ae974d0973b765a4cdc7ffa1dc75ebd93540769fb134b3a8dc521dfc0b3a'
|
||||
'35f5e7819d6c24863f3319462676ea989fd58f8a334925432444b6bf5c42fdaf'
|
||||
sha256sums=('6fa6c240f08c3aedacbefe31559128d239c7f18089c5bba64136698bd64910c8'
|
||||
'82a241d9fa4032187a26597d044e94ba810b209b53a7ce14bb6eb92555993a48'
|
||||
'9bc66470f3f80534c0bb62f9f8325ccf60b164f421f74ad74a963f065d7b1869'
|
||||
'badf6a701d9dc6ea3b4ddca26cb0f42b6236432ccdbc14c64962147802594a60'
|
||||
'1039e232a7778544b00eb215c93bb06c588c95c2fd49cfb162dc50eb4dfbf729'
|
||||
'89aab4eafa97cd0e40b61871a472fd90b4372e69c7af0d86145e5a7de9c8d4ee'
|
||||
'e33db2d543bd8cba732c1387adc3d67017aaec27a9c5618695063acd374777a0')
|
||||
|
|
File diff suppressed because it is too large
Load diff
20
community/percona-server/mysql56-bufsize.patch
Normal file
20
community/percona-server/mysql56-bufsize.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- storage/innobase/row/row0log.cc.orig 2013-10-14 09:44:46.060172260 +0200
|
||||
+++ storage/innobase/row/row0log.cc 2013-10-14 10:05:51.822170509 +0200
|
||||
@@ -2364,7 +2364,7 @@
|
||||
and be ignored when the operation is unsupported. */
|
||||
fallocate(index->online_log->fd,
|
||||
FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE,
|
||||
- ofs, srv_buf_size);
|
||||
+ ofs, srv_sort_buf_size);
|
||||
#endif /* FALLOC_FL_PUNCH_HOLE */
|
||||
|
||||
next_mrec = index->online_log->head.block;
|
||||
@@ -3153,7 +3153,7 @@
|
||||
and be ignored when the operation is unsupported. */
|
||||
fallocate(index->online_log->fd,
|
||||
FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE,
|
||||
- ofs, srv_buf_size);
|
||||
+ ofs, srv_sort_buf_size);
|
||||
#endif /* FALLOC_FL_PUNCH_HOLE */
|
||||
|
||||
next_mrec = index->online_log->head.block;
|
|
@ -6,7 +6,7 @@ fi
|
|||
post_install(){
|
||||
groupadd -g 89 mysql &>/dev/null
|
||||
useradd -u 89 -g mysql -d $datadir -s /bin/false mysql &>/dev/null
|
||||
|
||||
|
||||
if [[ ! -e $datadir ]]; then
|
||||
install -dm700 $datadir
|
||||
usr/bin/mysql_install_db --user=mysql --basedir=/usr --datadir=$datadir
|
||||
|
@ -20,7 +20,7 @@ post_upgrade(){
|
|||
getent group mysql >/dev/null 2>&1 || groupadd -g 89 mysql &>/dev/null
|
||||
getent passwd mysql >/dev/null 2>&1 || useradd -u 89 -g mysql -d $datadir -s /bin/false mysql &>/dev/null
|
||||
|
||||
if [ "$(vercmp $2 5.5)" -lt 0 ]; then
|
||||
if [ "$(vercmp $2 5.6)" -lt 0 ]; then
|
||||
echo " >> "
|
||||
echo " >> Major version update. Consider restart the service, and then running mysql_upgrade after it."
|
||||
echo " >> "
|
||||
|
|
Loading…
Reference in a new issue