mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
removing extra/avahi, we can makedepend on mono now
This commit is contained in:
parent
744565645f
commit
34ee0f42cc
5 changed files with 0 additions and 133 deletions
|
@ -1,17 +0,0 @@
|
|||
|
||||
2009-04-23 Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
|
||||
* Updated for i686: 0.6.25
|
||||
|
||||
2009-03-21 Eric Belanger <eric@archlinux.org>
|
||||
|
||||
* Added optdepends for avahi-discover (close FS#11250)
|
||||
|
||||
2009-01-04 Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
|
||||
* Updated for i686: 0.6.24
|
||||
|
||||
2008-07-22 Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
|
||||
* Updated for i686: 0.6.23
|
||||
|
|
@ -1,84 +0,0 @@
|
|||
# $Id: PKGBUILD 118164 2011-04-05 16:57:59Z bisson $
|
||||
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
|
||||
|
||||
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
|
||||
# - removed makedepend on mono
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=avahi
|
||||
pkgver=0.6.30
|
||||
pkgrel=2
|
||||
pkgdesc='A multicast/unicast DNS-SD framework'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.avahi.org/'
|
||||
license=('LGPL')
|
||||
depends=('expat' 'libdaemon' 'glib2' 'dbus' 'libcap' 'gdbm')
|
||||
optdepends=('gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
|
||||
'gtk2: gtk2 bindings'
|
||||
'qt3: qt3 bindings'
|
||||
'qt: qt bindings'
|
||||
'pygtk: avahi-bookmarks, avahi-discover'
|
||||
'twisted: avahi-bookmarks'
|
||||
'dbus-python: avahi-discover'
|
||||
'nss-mdns: NSS support for mDNS')
|
||||
makedepends=('qt' 'qt3' 'pygtk' 'intltool' 'dbus-python'
|
||||
'gtk-sharp-2' 'gobject-introspection' 'gtk3')
|
||||
backup=(etc/avahi/avahi-daemon.conf etc/avahi/services/{sftp-,}ssh.service)
|
||||
install=avahi.install
|
||||
conflicts=('howl' 'mdnsresponder')
|
||||
provides=('howl' 'mdnsresponder')
|
||||
replaces=('howl' 'mdnsresponder')
|
||||
options=('!libtool')
|
||||
source=(http://www.avahi.org/download/avahi-${pkgver}.tar.gz
|
||||
avahi-daemon-dbus.patch
|
||||
gnome-nettool.png)
|
||||
sha1sums=('5b77443537600a00770e4c77e3c443eeb5861d06'
|
||||
'41e9f23efa0b5a5f7b0f14a86cfb0677ece84c61'
|
||||
'cf56387c88aed246b9f435efc182ef44de4d52f3')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
sed -i 's/netdev/network/g' avahi-daemon/avahi-dbus.conf
|
||||
patch -Np0 -i "${srcdir}/avahi-daemon-dbus.patch"
|
||||
|
||||
# pygtk requires python2; make it explicit in case other python are installed: FS#21865
|
||||
PYTHON=python2 \
|
||||
PKG_CONFIG_PATH=/opt/qt/lib/pkgconfig \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--disable-static \
|
||||
--disable-monodoc \
|
||||
--disable-doxygen-doc \
|
||||
--disable-xmltoman \
|
||||
--enable-compat-libdns_sd \
|
||||
--enable-compat-howl \
|
||||
--with-distro=archlinux \
|
||||
--with-avahi-priv-access-group=network \
|
||||
--with-autoipd-user=avahi \
|
||||
--with-autoipd-group=avahi \
|
||||
--with-systemdsystemunitdir=/lib/systemd/system # See FS#20999
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
# howl and mdnsresponder compatability
|
||||
cd "${pkgdir}"/usr/include
|
||||
ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h
|
||||
ln -s avahi-compat-howl howl
|
||||
cd "${pkgdir}"/usr/lib/pkgconfig
|
||||
ln -s avahi-compat-howl.pc howl.pc
|
||||
|
||||
sed -i '1c #!/usr/bin/python2' "$pkgdir"/usr/bin/avahi-{bookmarks,discover}
|
||||
|
||||
install -D -m 644 "${srcdir}"/gnome-nettool.png "${pkgdir}"/usr/share/pixmaps/gnome-nettool.png
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
--- initscript/archlinux/avahi-daemon.in 2010-08-17 22:23:46.510293144 +0200
|
||||
+++ initscript/archlinux/avahi-daemon.in 2010-08-17 22:46:58.110163026 +0200
|
||||
@@ -33,6 +35,8 @@
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
+ ck_daemon dbus && /etc/rc.d/dbus start
|
||||
+ modprobe capability &> /dev/null
|
||||
stat_busy "Starting $DESC"
|
||||
$DAEMON -D > /dev/null 2>&1
|
||||
if [ $? -gt 0 ]; then
|
|
@ -1,21 +0,0 @@
|
|||
post_install() {
|
||||
getent group avahi &>/dev/null || groupadd -r -g 84 avahi >/dev/null
|
||||
getent passwd avahi &>/dev/null || useradd -r -u 84 -g avahi -d / -s /bin/false -c avahi avahi >/dev/null
|
||||
|
||||
cat <<EOF
|
||||
==> The following daemons may be added to DAEMONS in /etc/rc.conf:
|
||||
==> avahi-daemon: the mdns responder, you probably want this.
|
||||
==> dbus needs to be running when you start it.
|
||||
==> avahi-dnsconfd: daemon used for peer-to-peer automatic dns
|
||||
==> configuration on dhcp-less networks.
|
||||
|
||||
==> To use some of the client applications you will have to install python.
|
||||
==> In addition, pygtk is required for the graphical ones and
|
||||
==> twisted for avahi-bookmarks.
|
||||
EOF
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
getent passwd avahi &>/dev/null && userdel avahi >/dev/null
|
||||
getent group avahi &>/dev/null && groupdel avahi >/dev/null
|
||||
}
|
Binary file not shown.
Before Width: | Height: | Size: 4.4 KiB |
Loading…
Reference in a new issue