community/mplayer-vaapi to 36265-2

This commit is contained in:
Kevin Mihelich 2013-07-18 13:13:58 +00:00
parent 1cfd659430
commit 34f53d7b82
2 changed files with 33 additions and 7 deletions

View file

@ -7,8 +7,8 @@
# - remove --enable-runtime-cpudetection from configure
pkgname=mplayer-vaapi
pkgver=35107
pkgrel=8
pkgver=36265
pkgrel=2
pkgdesc="A movie player, compiled with vaapi support"
arch=('i686' 'x86_64')
url="http://gitorious.org/vaapi/mplayer"
@ -23,28 +23,35 @@ makedepends=('unzip' 'live-media' 'yasm' 'ladspa' 'git' 'mesa')
provides=("mplayer=$pkgver")
conflicts=('mplayer')
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
source=(http://pkgbuild.com/~foutrelis/mplayer-vaapi-$pkgver.tar.xz
source=(http://pkgbuild.com/~foutrelis/sources/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
cdio-includes.patch
tweak-desktop-file.patch
demux-gif.patch
subreader-fix-srt-parsing.patch)
options=('!buildflags' '!emptydirs')
install=mplayer-vaapi.install
sha256sums=('a6c645625cc2cd6ca48764db302c926049f831e757857ece351b37b674e05e56'
sha256sums=('5747c28c30c15d1000fb655a8abaa4b22483746d0e82775b27466948ae0c549a'
'SKIP'
'72e6c654f9733953ad2466d0ea1a52f23e753791d8232d90f13293eb1b358720'
'5a09fb462729a4e573568f9e8c1f57dbe7f69c0b68cfa4f6d70b3e52c450d93b'
'6774f57c027474388497606edfccbb33509cc78b573cdc322dd0955764c6f9c2'
'8b6cd325d89ff8bce3662c6aaa9b61b8e6163c6574e09b575426a1eed02b8ad3')
prepare() {
cd "$srcdir/mplayer-vaapi-$pkgver"
cd "$srcdir/$pkgname-$pkgver"
patch -Np0 -i "$srcdir/cdio-includes.patch"
patch -d etc -Np0 -i "$srcdir/tweak-desktop-file.patch"
# https://bugs.archlinux.org/task/36039
patch -Np0 -i "$srcdir/demux-gif.patch"
# http://bugzilla.mplayerhq.hu/show_bug.cgi?id=2139
patch -Np0 -i "$srcdir/subreader-fix-srt-parsing.patch"
}
build() {
cd "$srcdir/mplayer-vaapi-$pkgver"
cd "$srcdir/$pkgname-$pkgver"
./configure \
--prefix=/usr \
@ -73,7 +80,7 @@ build() {
}
package() {
cd "$srcdir/mplayer-vaapi-$pkgver"
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"

View file

@ -0,0 +1,19 @@
--- libmpdemux/demux_gif.c-old 2012-08-20 08:47:01.000000000 -0600
+++ libmpdemux/demux_gif.c 2013-07-05 11:27:55.488387360 -0600
@@ -45,6 +45,16 @@
#define GIF_SIGNATURE (('G' << 16) | ('I' << 8) | 'F')
+static void PrintGifError(void)
+{
+ char *Err = GifErrorString();
+
+ if (Err != NULL)
+ fprintf(stderr, "\nGIF-LIB error: %s.\n", Err);
+ else
+ fprintf(stderr, "\nGIF-LIB undefined error %d.\n", GifError());
+}
+
#ifndef CONFIG_GIF_TVT_HACK
// not supported by certain versions of the library
static int my_read_gif(GifFileType *gif, uint8_t *buf, int len)