mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
revert the 'fixing' of openssl, split into separate package
This commit is contained in:
parent
998b651998
commit
351bb234d1
6 changed files with 2053 additions and 8 deletions
86
core/openssl-cryptodev/PKGBUILD
Normal file
86
core/openssl-cryptodev/PKGBUILD
Normal file
|
@ -0,0 +1,86 @@
|
|||
# $Id$
|
||||
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - use linux-armv4 target for our architectures
|
||||
|
||||
plugrel=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=openssl-cryptodev
|
||||
_pkgname=openssl
|
||||
_ver=1.0.0g
|
||||
# use a pacman compatible version scheme
|
||||
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
|
||||
pkgrel=1
|
||||
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security'
|
||||
arch=('i686' 'x86_64')
|
||||
url='https://www.openssl.org'
|
||||
license=('custom:BSD')
|
||||
depends=('perl')
|
||||
optdepends=('ca-certificates')
|
||||
options=('!makeflags')
|
||||
backup=('etc/ssl/openssl.cnf')
|
||||
conflicts=('openssl')
|
||||
provides=("openssl=${pkgver}")
|
||||
source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"
|
||||
"https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz.asc"
|
||||
'fix-manpages.patch'
|
||||
'no-rpath.patch'
|
||||
'ca-dir.patch'
|
||||
'openssl-digests.patch')
|
||||
md5sums=('07ecbe4324f140d157478637d6beccf1'
|
||||
'34315cf0fbbd1d18435948eb9712fcdf'
|
||||
'5bbc0655bda2af95bc8eb568963ce8ba'
|
||||
'dc78d3d06baffc16217519242ce92478'
|
||||
'3bf51be3a1bbd262be46dc619f92aa90'
|
||||
'8c36b135ec9c2573ca987f252df41e5d')
|
||||
|
||||
# keep an upgrade path for older installations
|
||||
PKGEXT='.pkg.tar.gz'
|
||||
|
||||
build() {
|
||||
cd $srcdir/$_pkgname-$_ver
|
||||
|
||||
if [ "${CARCH}" == 'x86_64' ]; then
|
||||
openssltarget='linux-x86_64'
|
||||
elif [ "${CARCH}" == 'i686' ]; then
|
||||
openssltarget='linux-elf'
|
||||
elif [ "${CARCH}" == 'arm' -o "${CARCH}" == 'armv7h' ]; then
|
||||
openssltarget='linux-armv4'
|
||||
fi
|
||||
|
||||
# avoid conflicts with other man pages
|
||||
# see http://www.linuxfromscratch.org/patches/downloads/openssl/
|
||||
patch -p1 -i $srcdir/fix-manpages.patch
|
||||
# remove rpath: http://bugs.archlinux.org/task/14367
|
||||
patch -p0 -i $srcdir/no-rpath.patch
|
||||
# set ca dir to /etc/ssl by default
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
# fix cryptodev digest support
|
||||
patch -p0 -i $srcdir/openssl-digests.patch
|
||||
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
|
||||
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
|
||||
-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS -DHASH_MAX_LEN=64 \
|
||||
shared threads zlib enable-md2 \
|
||||
"${openssltarget}" \
|
||||
-Wa,--noexecstack "${CFLAGS}"
|
||||
|
||||
make depend
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $srcdir/$_pkgname-$_ver
|
||||
# the test fails due to missing write permissions in /etc/ssl
|
||||
# revert this patch for make test
|
||||
patch -p0 -R -i $srcdir/ca-dir.patch
|
||||
make test
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/$_pkgname-$_ver
|
||||
make INSTALL_PREFIX=$pkgdir MANDIR=/usr/share/man install
|
||||
install -D -m644 LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
|
||||
}
|
33
core/openssl-cryptodev/ca-dir.patch
Normal file
33
core/openssl-cryptodev/ca-dir.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- apps/CA.pl.in 2006-04-28 02:30:49.000000000 +0200
|
||||
+++ apps/CA.pl.in 2010-04-01 00:35:02.600553509 +0200
|
||||
@@ -53,7 +53,7 @@
|
||||
$X509="$openssl x509";
|
||||
$PKCS12="$openssl pkcs12";
|
||||
|
||||
-$CATOP="./demoCA";
|
||||
+$CATOP="/etc/ssl";
|
||||
$CAKEY="cakey.pem";
|
||||
$CAREQ="careq.pem";
|
||||
$CACERT="cacert.pem";
|
||||
--- apps/CA.sh 2009-10-15 19:27:47.000000000 +0200
|
||||
+++ apps/CA.sh 2010-04-01 00:35:02.600553509 +0200
|
||||
@@ -68,7 +68,7 @@
|
||||
X509="$OPENSSL x509"
|
||||
PKCS12="openssl pkcs12"
|
||||
|
||||
-if [ -z "$CATOP" ] ; then CATOP=./demoCA ; fi
|
||||
+if [ -z "$CATOP" ] ; then CATOP=/etc/ssl ; fi
|
||||
CAKEY=./cakey.pem
|
||||
CAREQ=./careq.pem
|
||||
CACERT=./cacert.pem
|
||||
--- apps/openssl.cnf 2009-04-04 20:09:43.000000000 +0200
|
||||
+++ apps/openssl.cnf 2010-04-01 00:35:02.607220681 +0200
|
||||
@@ -39,7 +39,7 @@
|
||||
####################################################################
|
||||
[ CA_default ]
|
||||
|
||||
-dir = ./demoCA # Where everything is kept
|
||||
+dir = /etc/ssl # Where everything is kept
|
||||
certs = $dir/certs # Where the issued certs are kept
|
||||
crl_dir = $dir/crl # Where the issued crl are kept
|
||||
database = $dir/index.txt # database index file.
|
1920
core/openssl-cryptodev/fix-manpages.patch
Normal file
1920
core/openssl-cryptodev/fix-manpages.patch
Normal file
File diff suppressed because it is too large
Load diff
11
core/openssl-cryptodev/no-rpath.patch
Normal file
11
core/openssl-cryptodev/no-rpath.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.shared.no-rpath 2005-06-23 22:47:54.000000000 +0200
|
||||
+++ Makefile.shared 2005-11-16 22:35:37.000000000 +0100
|
||||
@@ -153,7 +153,7 @@
|
||||
NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
|
||||
SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
|
||||
|
||||
-DO_GNU_APP=LDFLAGS="$(CFLAGS) -Wl,-rpath,$(LIBRPATH)"
|
||||
+DO_GNU_APP=LDFLAGS="$(CFLAGS)"
|
||||
|
||||
#This is rather special. It's a special target with which one can link
|
||||
#applications without bothering with any features that have anything to
|
|
@ -23,14 +23,12 @@ source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
|
|||
"https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz.asc"
|
||||
'fix-manpages.patch'
|
||||
'no-rpath.patch'
|
||||
'ca-dir.patch'
|
||||
'openssl-digests.patch')
|
||||
'ca-dir.patch')
|
||||
md5sums=('07ecbe4324f140d157478637d6beccf1'
|
||||
'34315cf0fbbd1d18435948eb9712fcdf'
|
||||
'5bbc0655bda2af95bc8eb568963ce8ba'
|
||||
'dc78d3d06baffc16217519242ce92478'
|
||||
'3bf51be3a1bbd262be46dc619f92aa90'
|
||||
'8c36b135ec9c2573ca987f252df41e5d')
|
||||
'3bf51be3a1bbd262be46dc619f92aa90')
|
||||
|
||||
# keep an upgrade path for older installations
|
||||
PKGEXT='.pkg.tar.gz'
|
||||
|
@ -53,12 +51,9 @@ build() {
|
|||
patch -p0 -i $srcdir/no-rpath.patch
|
||||
# set ca dir to /etc/ssl by default
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
# fix cryptodev digest support
|
||||
patch -p0 -i $srcdir/openssl-digests.patch
|
||||
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
|
||||
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
|
||||
-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS -DHASH_MAX_LEN=64 \
|
||||
shared threads zlib enable-md2 \
|
||||
shared zlib enable-md2 \
|
||||
"${openssltarget}" \
|
||||
-Wa,--noexecstack "${CFLAGS}"
|
||||
|
||||
|
|
Loading…
Reference in a new issue