diff --git a/extra/chromium/PKGBUILD b/extra/chromium/PKGBUILD
index c2ea9f16a..e84b5926a 100644
--- a/extra/chromium/PKGBUILD
+++ b/extra/chromium/PKGBUILD
@@ -15,8 +15,8 @@ buildarch=12
 highmem=1
 
 pkgname=chromium
-pkgver=80.0.3987.87
-pkgrel=2
+pkgver=80.0.3987.100
+pkgrel=1
 _launcher_ver=6
 pkgdesc="A web browser built for speed, simplicity, and security"
 arch=('x86_64')
@@ -41,13 +41,12 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
         fix-building-with-system-zlib.patch
         remove-verbose-logging-in-local-unique-font-matching.patch
         fix-building-with-unbundled-libxml.patch
-        fix-browser-frame-view-not-getting-a-relayout.patch
         rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
         rebuild-Linux-frame-button-cache-when-activation.patch
         chromium-widevine.patch
         chromium-skia-harmony.patch
         0001-crashpad-include-limits.patch)
-sha256sums=('f51f6fca5d9abbef855aa6b5bf427410c6e96ae58b64a7d45f843868cfb0ac8e'
+sha256sums=('e9464c4045a9afca90ddb9a085c32b302944073ef920365af1d7244902a7200b'
             '04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
             '0a8d1af2a3734b5f99ea8462940e332db4acee7130fe436ad3e4b7ad133e5ae5'
             '21f631851cdcb347f40793485b168cb5d0da65ae26ae39ba58d624c66197d0a5'
@@ -56,7 +55,6 @@ sha256sums=('f51f6fca5d9abbef855aa6b5bf427410c6e96ae58b64a7d45f843868cfb0ac8e'
             '18276e65c68a0c328601b12fefb7e8bfc632346f34b87e64944c9de8c95c5cfa'
             '5bc775c0ece84d67855f51b30eadcf96fa8163b416d2036e9f9ba19072f54dfe'
             'e530d1b39504c2ab247e16f1602359c484e9e8be4ef6d4824d68b14d29a7f60b'
-            '5db225565336a3d9b9e9f341281680433c0b7bb343dff2698b2acffd86585cbe'
             'ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db'
             '46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014'
             '709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070'
@@ -140,9 +138,6 @@ prepare() {
   # https://crbug.com/1043042
   patch -Np1 -i ../fix-building-with-unbundled-libxml.patch
 
-  # https://crbug.com/1046122
-  patch -Np1 -i ../fix-browser-frame-view-not-getting-a-relayout.patch
-
   # https://crbug.com/1049258
   patch -Np1 -i ../rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
   patch -Np1 -i ../rebuild-Linux-frame-button-cache-when-activation.patch
diff --git a/extra/chromium/fix-browser-frame-view-not-getting-a-relayout.patch b/extra/chromium/fix-browser-frame-view-not-getting-a-relayout.patch
deleted file mode 100644
index fbdd026ff..000000000
--- a/extra/chromium/fix-browser-frame-view-not-getting-a-relayout.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From c73968d63c456d4aaf55c5cd439b42403a3bbeb1 Mon Sep 17 00:00:00 2001
-From: Tom Anderson <thomasanderson@chromium.org>
-Date: Mon, 3 Feb 2020 19:53:50 +0000
-Subject: [PATCH] Fix browser frame view not getting a relayout after a state
- change
-
-views::NonClientView has 2 things: a views::NonClientFrameView and a
-views::ClientView. We were previously only invalidating the layout on
-the ClientView after a state change.  This was causing the browser
-frame to paint as if it were still maximized after restoring from
-a maximized state on Linux.  Invalidating the layout of the frame view
-fixes the issue.
-
-BUG=1046122
-R=sky
-
-Change-Id: I7da525efe1f436564ffffb410afe294e901e5d89
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2033759
-Reviewed-by: Scott Violet <sky@chromium.org>
-Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
-Cr-Commit-Position: refs/heads/master@{#737890}
----
- .../widget/desktop_aura/desktop_window_tree_host_platform.cc    | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-index 9abbce89586..6c00d49eb3f 100644
---- a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-+++ b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-@@ -717,6 +717,8 @@ void DesktopWindowTreeHostPlatform::Relayout() {
-   NonClientView* non_client_view = widget->non_client_view();
-   // non_client_view may be NULL, especially during creation.
-   if (non_client_view) {
-+    if (non_client_view->frame_view())
-+      non_client_view->frame_view()->InvalidateLayout();
-     non_client_view->client_view()->InvalidateLayout();
-     non_client_view->InvalidateLayout();
-   }