extra/firefox to 105.0-1

This commit is contained in:
Kevin Mihelich 2022-09-20 23:15:15 +00:00
parent 4a9a76390f
commit 354fa5aef5
2 changed files with 2 additions and 40 deletions

View file

@ -10,7 +10,7 @@
highmem=1
pkgname=firefox
pkgver=104.0.2
pkgver=105.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
@ -29,12 +29,10 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'xdg-desktop-portal: Screensharing with Wayland')
options=(!emptydirs !makeflags !strip !lto !debug)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
arc4random.diff
build-arm-libopus.patch
$pkgname.desktop identity-icons-brand.svg)
sha256sums=('72bba06f04e7745f6b02951906413eb1c15a7e253e06e373302162c6219f286a'
sha256sums=('2b5becbb89aa2b2007ba8c86ad517aeae1b54904d007d9d3acbf054be6a0ed62'
'SKIP'
'714ca50b2ce0cac470dbd5a60e9a0101b28072f08a5e7a9bba94fef2058321c4'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
@ -57,9 +55,6 @@ prepare() {
mkdir mozbuild
cd firefox-$pkgver
# Unbreak build with glibc 2.36
#patch -Np1 -i ../arc4random.diff
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key

View file

@ -1,33 +0,0 @@
diff --git i/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h w/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h
index 101d39d455107..3764806240f9f 100644
--- i/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h
+++ w/ipc/chromium/src/third_party/libevent/linux/event2/event-config.h
@@ -30,13 +30,13 @@
/* #undef EVENT__HAVE_AFUNIX_H 1 */
/* Define to 1 if you have the `arc4random' function. */
-/* #undef EVENT__HAVE_ARC4RANDOM */
+#define EVENT__HAVE_ARC4RANDOM 1
/* Define to 1 if you have the `arc4random_addrandom' function. */
/* #undef EVENT__HAVE_ARC4RANDOM_ADDRANDOM */
/* Define to 1 if you have the `arc4random_buf' function. */
-/* #undef EVENT__HAVE_ARC4RANDOM_BUF */
+#define EVENT__HAVE_ARC4RANDOM_BUF 1
/* Define to 1 if you have the <arpa/inet.h> header file. */
#define EVENT__HAVE_ARPA_INET_H 1
diff --git i/toolkit/crashreporter/client/ping.cpp w/toolkit/crashreporter/client/ping.cpp
index 57cf85de80b79..93a2f6e80ad0b 100644
--- i/toolkit/crashreporter/client/ping.cpp
+++ w/toolkit/crashreporter/client/ping.cpp
@@ -53,7 +53,7 @@ static string GenerateUUID() {
CFRelease(uuid);
#elif defined(HAVE_ARC4RANDOM_BUF) // Android, BSD, ...
- arc4random_buf(id, sizeof(UUID));
+ arc4random_buf(&id, sizeof(UUID));
#else // Linux
int fd = open("/dev/urandom", O_RDONLY);