extra/kdebindings-python to 4.9.2-2

This commit is contained in:
Kevin Mihelich 2012-10-18 03:34:29 +00:00
parent 18e268ffb1
commit 355bbe2a57
2 changed files with 103 additions and 5 deletions

View file

@ -8,7 +8,7 @@ pkgbase=kdebindings-python
pkgname=('kdebindings-python'
'kdebindings-python2')
pkgver=4.9.2
pkgrel=1
pkgrel=2
url='https://projects.kde.org/projects/kde/kdebindings/pykde4'
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL')
@ -16,23 +16,26 @@ groups=('kdebindings')
makedepends=('cmake' 'automoc4' 'boost' 'kdepim-runtime' 'python2-pyqt'
'pyqt' 'qscintilla' 'python2-sip' 'python-sip')
source=("http://download.kde.org/stable/${pkgver}/src/pykde4-${pkgver}.tar.xz"
"pykde4-4.4.4-arm-sip.patch")
"pykde4-4.4.4-arm-sip.patch"
'pyqt495.patch')
sha1sums=('44b3f02797c43a59f8c3a91131a2488a733cfa11'
'20d37a8b127eebffc4556352168786036969ee78')
'20d37a8b127eebffc4556352168786036969ee78'
'0935c32e55806873f2d088613594559285da7e9c')
build() {
export PYTHONDONTWRITEBYTECODE="TRUE"
cd "${srcdir}/pykde4-${pkgver}"
patch -Np3 -i "${srcdir}/pykde4-4.4.4-arm-sip.patch"
patch -p1 -i "${srcdir}"/pyqt495.patch
cd "${srcdir}"
mkdir build
cd build
cmake ../pykde4-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_EXECUTABLE=/usr/bin/python \
-DPYTHON_LIBRARY=/usr/lib/libpython3.2mu.so.1.0
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DPYTHON_LIBRARY=/usr/lib/libpython3.3m.so.1.0
make
cd ..

View file

@ -0,0 +1,95 @@
From: Luca Beltrame <lbeltrame@kde.org>
Date: Mon, 01 Oct 2012 18:47:56 +0000
Subject: Remove duplicated QVector<int> definition, since it's in PyQt now.
X-Git-Url: http://quickgit.kde.org/?p=pykde4.git&amp;a=commitdiff&amp;h=017822bd0dfc83fe9a7a483ecc33f4aab839a3c6
---
Remove duplicated QVector<int> definition, since it's in PyQt now.
Simon, if you have time, please review if everything is OK.
CCMAIL: simon@simonzone.com
---
--- a/sip/kdecore/typedefs.sip
+++ b/sip/kdecore/typedefs.sip
@@ -951,78 +951,4 @@
%End
};
-%MappedType QVector<int>
-{
-%TypeHeaderCode
-#include <qvector.h>
-%End
-
-%ConvertFromTypeCode
- // Create the list.
- PyObject *l;
-
- if ((l = PyList_New(sipCpp->size())) == NULL)
- return NULL;
-
- // Set the list elements.
- for (int i = 0; i < sipCpp->size(); ++i)
- {
- int t = (sipCpp->at(i));
-
-#if PY_MAJOR_VERSION >= 3
- PyObject *tobj = PyLong_FromLong(t);
-#else
- PyObject *tobj = PyInt_FromLong(t);
-#endif
-
- PyList_SET_ITEM(l, i, tobj);
- }
-
- return l;
-%End
-
-%ConvertToTypeCode
- // Check the type if that is all that is required.
- if (sipIsErr == NULL)
- {
- if (!PyList_Check(sipPy))
- return 0;
-
- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i) {
- PyObject *tobj = PyList_GET_ITEM(sipPy, i);
-#if PY_MAJOR_VERSION >= 3
- if (!PyNumber_Check(tobj))
-#else
- if (!PyInt_Check(tobj))
-#endif
- return 0;
- }
- return 1;
- }
-
- QVector<int> *qv = new QVector<int>;
-
- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i)
- {
- PyObject *tobj = PyList_GET_ITEM(sipPy, i);
- #if PY_MAJOR_VERSION >= 3
- int t = PyLong_AsLong (tobj);
-#else
- int t = PyInt_AS_LONG (tobj);
-#endif
-
- if (*sipIsErr)
- {
- delete qv;
- return 0;
- }
-
- qv->append(t);
- }
-
- *sipCppPtr = qv;
-
- return sipGetState(sipTransferObj);
-%End
-};
-
+