diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
index d9f8a10ba..c5639bc3c 100644
--- a/extra/webkit2gtk/PKGBUILD
+++ b/extra/webkit2gtk/PKGBUILD
@@ -8,13 +8,13 @@
 highmem=1
 
 pkgname=webkit2gtk
-pkgver=2.10.7
+pkgver=2.10.8
 pkgrel=1
 pkgdesc="GTK+ Web content engine library"
 arch=('i686' 'x86_64')
 url="http://webkitgtk.org/"
 license=('custom')
-depends=('libxt' 'libxslt' 'enchant' 'geoclue2' 'gst-plugins-base-libs'
+depends=('libxt' 'libxslt' 'enchant' 'geoclue2' 'gst-plugins-base-libs' 'gst-plugins-bad'
 	 'libsecret' 'libwebp' 'harfbuzz-icu' 'gtk3' 'libnotify' 'hyphen')
 makedepends=('gtk2' 'gperf' 'gobject-introspection' 'ruby' 'gtk-doc' 'cmake' 'python')
 optdepends=('gtk2: Netscape plugin support'
@@ -22,13 +22,15 @@ optdepends=('gtk2: Netscape plugin support'
             'gst-plugins-good: media decoding'
             'gst-libav: nonfree media decoding')
 options=('!emptydirs')
-source=(http://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz)
-sha256sums=('990d62c82ed6dede31a6ff0a82d847f16b812842ff3e1093d17113627652864e')
+source=(http://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz isnan.patch)
+sha256sums=('313682b23f03c457b28a7ef2d5bdb70a8174cca1d32e0a853fb36fa4dcf928a9'
+            '958732bcf77befc534af25e26b57772a42b77b99d88a4904484e7c3f943b0a0e')
 
 prepare() {
   mkdir build
 
   cd webkitgtk-$pkgver
+  patch -Np1 -i ../isnan.patch
   sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
   rm -r Source/ThirdParty/gtest/
   rm -r Source/ThirdParty/qunit/