mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/mkinitcpio-busybox to 1.20.2-1
This commit is contained in:
parent
e7e2f1da29
commit
35b116cb27
2 changed files with 19 additions and 5 deletions
|
@ -3,12 +3,10 @@
|
|||
# Maintainer: Thomas Bächler <thomas@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed -mtune, changed -march to v7/v5 compat
|
||||
|
||||
plugrel=1
|
||||
# - removed -mtune, changed -march to v7/v6/v5 compat
|
||||
|
||||
pkgname=mkinitcpio-busybox
|
||||
pkgver=1.20.1
|
||||
pkgver=1.20.2
|
||||
pkgrel=1
|
||||
pkgdesc="base initramfs tools"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -17,8 +15,10 @@ license=('GPL')
|
|||
depends=('glibc')
|
||||
options=('!buildflags')
|
||||
source=("http://busybox.net/downloads/busybox-$pkgver.tar.bz2"
|
||||
'glibc-2.16.patch'
|
||||
'config')
|
||||
sha256sums=('3e515d8abefd8583ebabffdcfccecb3b8deacf2cef7c69ab1d8755a012ec68c9'
|
||||
sha256sums=('eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882'
|
||||
'fb5b6e2a0de4db5401322e5c2474ad8ce6a58615dad45b7109cfe045baf2c88d'
|
||||
'd8064ed6ec21868e4afe057445e2d852b353abd595132cb1ca3ba345988772f0')
|
||||
|
||||
build() {
|
||||
|
@ -26,6 +26,8 @@ build() {
|
|||
|
||||
if [ ${CARCH} = "armv7h" ]; then
|
||||
ARMCARCH="armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16"
|
||||
elif [ ${CARCH} = "armv6h" ]; then
|
||||
ARMCARCH="armv6 -mfloat-abi=hard -mfpu=vfp"
|
||||
else
|
||||
ARMCARCH="armv5te"
|
||||
fi
|
||||
|
@ -35,6 +37,8 @@ build() {
|
|||
sed 's|^\(CONFIG_EXTRA_CFLAGS\)=.*|\1="-march='"$safeflags"'"|' \
|
||||
"$srcdir/config" > .config
|
||||
|
||||
patch -Np1 < "$srcdir/glibc-2.16.patch"
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
|
|
10
core/mkinitcpio-busybox/glibc-2.16.patch
Normal file
10
core/mkinitcpio-busybox/glibc-2.16.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/include/libbb.h.orig 2012-09-17 08:28:35.215518120 -0400
|
||||
+++ b/include/libbb.h 2012-09-17 08:28:49.807212925 -0400
|
||||
@@ -44,6 +44,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/time.h>
|
||||
#include <sys/types.h>
|
||||
+#include <sys/resource.h>
|
||||
#ifndef major
|
||||
# include <sys/sysmacros.h>
|
||||
#endif
|
Loading…
Reference in a new issue