added extra/lua51

This commit is contained in:
Kevin Mihelich 2013-12-07 18:08:56 +00:00
parent e4a402bd1e
commit 35d088245b
3 changed files with 143 additions and 0 deletions

64
extra/lua51/PKGBUILD Normal file
View file

@ -0,0 +1,64 @@
# $Id$
# Maintainer: Sébastien Luttringer <seblu@aur.archlinux.org>
# Contributor: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - use fPIC with armv7h
pkgname=lua51
pkgver=5.1.5
pkgrel=4
pkgdesc='Powerful lightweight programming language designed for extending applications'
arch=('i686' 'x86_64')
url='http://www.lua.org/'
depends=('readline')
license=('MIT')
options=('!makeflags' '!emptydirs')
source=(http://www.lua.org/ftp/lua-$pkgver.tar.gz
lua-arch.patch
lua-5.1-cflags.diff)
md5sums=('2e115fe26e435e33b0d5c022e4490567'
'fa25feb70ef9fec975b1c20da5098b3c'
'249582bf1fd861ccf492d2c35a9fe732')
prepare() {
cd lua-$pkgver
patch -p1 -i ../lua-arch.patch
patch -p1 -i ../lua-5.1-cflags.diff
}
build() {
cd lua-$pkgver
[[ $CARCH == armv7h ]] && export CFLAGS="$CFLAGS -fPIC"
sed -e 's:llua:llua5.1:' -e 's:/include:/include/lua5.1:' -i etc/lua.pc
sed -r -e '/^LUA_(SO|A|T)=/ s/lua/lua5.1/' -e '/^LUAC_T=/ s/luac/luac5.1/' \
-i src/Makefile
make MYCFLAGS="$CFLAGS" MYLDFLAGS="$LDFLAGS" linux
}
package() {
cd lua-$pkgver
make \
TO_BIN='lua5.1 luac5.1' \
TO_LIB="liblua5.1.a liblua5.1.so liblua5.1.so.5.1 liblua5.1.so.$pkgver" \
INSTALL_DATA='cp -d' \
INSTALL_TOP="$pkgdir"/usr \
INSTALL_INC="$pkgdir"/usr/include/lua5.1 \
INSTALL_MAN="$pkgdir"/usr/share/man/man1 \
install
install -Dm644 etc/lua.pc "$pkgdir"/usr/lib/pkgconfig/lua5.1.pc
install -d "$pkgdir/usr/share/doc/$pkgname"
install -m644 doc/*.{gif,png,css,html} "$pkgdir"/usr/share/doc/$pkgname
install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
ln -s liblua5.1.so "$pkgdir"/usr/lib/liblua.so.5.1
ln -s liblua5.1.so "$pkgdir"/usr/lib/liblua.so.$pkgver
cd "$pkgdir"/usr/share/man/man1
mv lua.1 lua5.1.1
mv luac.1 luac5.1.1
}

View file

@ -0,0 +1,13 @@
diff -Naur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
--- lua-5.1.orig/src/Makefile 2006-02-16 16:45:09.000000000 +0100
+++ lua-5.1/src/Makefile 2006-03-01 14:55:29.000000000 +0100
@@ -8,7 +8,8 @@
PLAT= none
CC= gcc
-CFLAGS= -O2 -Wall $(MYCFLAGS)
+CFLAGS ?= -O2 -Wall
+CFLAGS += $(MYCFLAGS)
AR= ar rcu
RANLIB= ranlib
RM= rm -f

View file

@ -0,0 +1,66 @@
diff -ur lua-5.1.4/etc/lua.pc lua-5.1.4-new/etc/lua.pc
--- lua-5.1.4/etc/lua.pc 2008-08-08 14:46:11.000000000 +0200
+++ lua-5.1.4-new/etc/lua.pc 2012-02-23 18:25:34.000000000 +0100
@@ -8,6 +8,6 @@
# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
-prefix= /usr/local
+prefix= /usr
INSTALL_BIN= ${prefix}/bin
INSTALL_INC= ${prefix}/include
INSTALL_LIB= ${prefix}/lib
diff -ur lua-5.1.4/src/luaconf.h lua-5.1.4-new/src/luaconf.h
--- lua-5.1.4/src/luaconf.h 2008-02-11 17:25:08.000000000 +0100
+++ lua-5.1.4-new/src/luaconf.h 2012-02-23 18:25:34.000000000 +0100
@@ -94,7 +94,7 @@
".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
#else
-#define LUA_ROOT "/usr/local/"
+#define LUA_ROOT "/usr/"
#define LUA_LDIR LUA_ROOT "share/lua/5.1/"
#define LUA_CDIR LUA_ROOT "lib/lua/5.1/"
#define LUA_PATH_DEFAULT \
diff -ur lua-5.1.4/src/Makefile lua-5.1.4-new/src/Makefile
--- lua-5.1.4/src/Makefile 2008-01-19 20:37:58.000000000 +0100
+++ lua-5.1.4-new/src/Makefile 2012-02-23 18:26:43.000000000 +0100
@@ -23,6 +23,7 @@
PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
LUA_A= liblua.a
+LUA_SO= liblua.so
CORE_O= lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
lundump.o lvm.o lzio.o
@@ -36,7 +37,7 @@
LUAC_O= luac.o print.o
ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
ALL_A= $(LUA_A)
default: $(PLAT)
@@ -51,6 +52,11 @@
$(AR) $@ $?
$(RANLIB) $@
+$(LUA_SO): $(CORE_O) $(LIB_O)
+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
+ ln -sf $(LUA_SO).$(R) $(LUA_SO)
+
$(LUA_T): $(LUA_O) $(LUA_A)
$(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
--- lua-5.1.4/Makefile 2008-08-12 02:40:48.000000000 +0200
+++ lua-5.1.4-new/Makefile 2012-02-23 19:06:32.000000000 +0100
@@ -53,7 +53,7 @@
all: $(PLAT)
$(PLATS) clean:
- cd src && $(MAKE) $@
+ cd src && $(MAKE) $@ V=$(V) R=$(R)
test: dummy
src/lua test/hello.lua