mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added core/kernel26-orion 2.6.39-1 for marvell orion
This commit is contained in:
parent
867b9b17cb
commit
35f5ad75fb
5 changed files with 786 additions and 0 deletions
BIN
core/kernel26-orion/2.6.39-orion.config
Normal file
BIN
core/kernel26-orion/2.6.39-orion.config
Normal file
Binary file not shown.
215
core/kernel26-orion/PKGBUILD
Normal file
215
core/kernel26-orion/PKGBUILD
Normal file
|
@ -0,0 +1,215 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@plugapps.com>
|
||||
# Maintainer: Kevin Mihelich <kevin@plugapps.com>
|
||||
# Contributor: Julian Langschaedel <meta.rb@gmail.com>
|
||||
|
||||
noautobuild=1
|
||||
plugrel=1
|
||||
|
||||
pkgbase="kernel26"
|
||||
pkgname=('kernel26-orion' 'kernel26-headers')
|
||||
_kernelname=${pkgname#kernel26}
|
||||
_basekernel=2.6.39
|
||||
pkgver=${_basekernel}.3
|
||||
_pkgrel=1
|
||||
pkgrel=${_pkgrel}
|
||||
#pkgrel=${_pkgrel}.${plugrel}
|
||||
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage' 'make')
|
||||
_patchname="patch-${pkgver}-${_pkgrel}-ARCH"
|
||||
#_patchname="patch-${pkgver}-1-ARCH"
|
||||
replaces=('kernel26-withlinux' 'kernel26-dockstar')
|
||||
arch=(arm)
|
||||
CARCH=arm
|
||||
KARCH=arm
|
||||
LDFLAGS=""
|
||||
license=('GPL2')
|
||||
url="http://www.kernel.org"
|
||||
source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
|
||||
ftp://ftp.archlinux.org/other/kernel26/${_patchname}.bz2
|
||||
${_basekernel}-orion.config
|
||||
archlinuxarm.patch)
|
||||
md5sums=('1aab7a741abe08d42e8eccf20de61e05'
|
||||
'b23d7def30e57242cfe088f4d8ca8baa'
|
||||
'effb50068f8f8baef57dd665a4e4065d'
|
||||
'77e8e011485c2061616214d07356132e')
|
||||
|
||||
|
||||
build() {
|
||||
echo $PATH
|
||||
cd ${srcdir}/linux-$_basekernel
|
||||
# Add -ARCH patches
|
||||
# See http://projects.archlinux.org/linux-2.6-ARCH.git/
|
||||
patch -Np1 -i ${srcdir}/${_patchname}
|
||||
|
||||
# Add Arch Linux ARM patch for ARMv5te plug computers
|
||||
patch -Np1 -i ${srcdir}/archlinuxarm.patch
|
||||
|
||||
# Copy in our configuration
|
||||
cp ../${_basekernel}-orion.config ./.config
|
||||
|
||||
# Prepare sources
|
||||
#make prepare
|
||||
# Configure the kernel. Replace the line below with one of your choice.
|
||||
#make menuconfig # CLI menu for configuration
|
||||
make nconfig # new CLI menu for configuration
|
||||
#make oldconfig # using old config from previous kernel version
|
||||
|
||||
# Copy back our configuration (use with new kernel version)
|
||||
#cp ./.config ../${_basekernel}.config
|
||||
|
||||
# Halt the build for configuration only
|
||||
#return 1
|
||||
|
||||
# Build!
|
||||
make ${MAKEFLAGS} zImage modules
|
||||
}
|
||||
|
||||
package_kernel26-orion() {
|
||||
pkgdesc="The Linux Kernel and modules"
|
||||
groups=('base')
|
||||
depends=('coreutils' 'module-init-tools>=3.12-2' 'devio')
|
||||
replaces=('kernel24' 'kernel24-scsi' 'kernel26-scsi'
|
||||
'alsa-driver' 'ieee80211' 'hostap-driver26'
|
||||
'pwc' 'nforce' 'squashfs' 'unionfs' 'ivtv'
|
||||
'zd1211' 'kvm-modules' 'iwlwifi' 'rt2x00-cvs'
|
||||
'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm'
|
||||
'kernel26-withlinux' 'kernel26-dockstar')
|
||||
provides=('kernel26=2.6.39')
|
||||
install=kernel26.install
|
||||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
|
||||
KARCH=arm
|
||||
cd ${srcdir}/linux-$_basekernel
|
||||
# get kernel version
|
||||
_kernver="$(make kernelrelease)"
|
||||
mkdir -p ${pkgdir}/{lib/modules,lib/firmware,boot}
|
||||
make INSTALL_MOD_PATH=${pkgdir} modules_install
|
||||
cp System.map ${pkgdir}/boot/System.map26${_kernelname}
|
||||
cp arch/$KARCH/boot/zImage ${pkgdir}/boot/zImage
|
||||
|
||||
# set correct depmod command for install
|
||||
sed \
|
||||
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
|
||||
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
||||
-i $startdir/kernel26.install
|
||||
|
||||
# remove build and source links
|
||||
rm -f ${pkgdir}/lib/modules/${_kernver}/{source,build}
|
||||
# remove the firmware
|
||||
rm -rf ${pkgdir}/lib/firmware
|
||||
# gzip -9 all modules to save 100MB of space
|
||||
find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
|
||||
}
|
||||
|
||||
package_kernel26-headers() {
|
||||
pkgdesc="Header files and scripts for building modules for kernel26"
|
||||
KARCH=arm
|
||||
|
||||
mkdir -p ${pkgdir}/lib/modules/${_kernver}
|
||||
cd ${pkgdir}/lib/modules/${_kernver}
|
||||
ln -sf ../../../usr/src/linux-${_kernver} build
|
||||
cd ${srcdir}/linux-$_basekernel
|
||||
install -D -m644 Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/Makefile
|
||||
install -D -m644 kernel/Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/kernel/Makefile
|
||||
install -D -m644 .config \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/.config
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include
|
||||
|
||||
for i in acpi asm-generic config crypto drm generated linux math-emu \
|
||||
media net pcmcia scsi sound trace video xen; do
|
||||
cp -a include/$i ${pkgdir}/usr/src/linux-${_kernver}/include/
|
||||
done
|
||||
|
||||
# copy arch includes for external modules
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH
|
||||
cp -a arch/$KARCH/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-kirkwood
|
||||
cp -a arch/$KARCH/mach-kirkwood/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-kirkwood/
|
||||
|
||||
# copy files necessary for later builds, like nvidia and vmware
|
||||
cp Module.symvers ${pkgdir}/usr/src/linux-${_kernver}
|
||||
cp -a scripts ${pkgdir}/usr/src/linux-${_kernver}
|
||||
# fix permissions on scripts dir
|
||||
chmod og-w -R ${pkgdir}/usr/src/linux-${_kernver}/scripts
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/.tmp_versions
|
||||
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel
|
||||
|
||||
cp arch/$KARCH/Makefile ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
if [ "$CARCH" = "i686" ]; then
|
||||
cp arch/$KARCH/Makefile_32.cpu ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
fi
|
||||
cp arch/$KARCH/kernel/asm-offsets.s ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel/
|
||||
|
||||
# add headers for lirc package
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video
|
||||
cp drivers/media/video/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/
|
||||
for i in bt8xx cpia2 cx25840 cx88 em28xx et61x251 pwc saa7134 sn9c102; do
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
|
||||
cp -a drivers/media/video/$i/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
|
||||
done
|
||||
# add docbook makefile
|
||||
install -D -m644 Documentation/DocBook/Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile
|
||||
# add dm headers
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
|
||||
cp drivers/md/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
|
||||
# add inotify.h
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/linux
|
||||
cp include/linux/inotify.h ${pkgdir}/usr/src/linux-${_kernver}/include/linux/
|
||||
# add wireless headers
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
|
||||
cp net/mac80211/*.h ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/9912
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core
|
||||
cp drivers/media/dvb/dvb-core/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core/
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/11194
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
|
||||
cp include/config/dvb/*.h ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
|
||||
# add dvb headers for http://mcentral.de/hg/~mrec/em28xx-new
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/13146
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
cp drivers/media/dvb/frontends/lgdt330x.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
cp drivers/media/video/msp3400-driver.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
# add dvb headers
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/20402
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-usb
|
||||
cp drivers/media/dvb/dvb-usb/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-usb/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends
|
||||
cp drivers/media/dvb/frontends/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/common/tuners
|
||||
cp drivers/media/common/tuners/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/common/tuners/
|
||||
# add xfs and shmem for aufs building
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/mm
|
||||
cp fs/xfs/xfs_sb.h ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h
|
||||
# copy in Kconfig files
|
||||
for i in `find . -name "Kconfig*"`; do
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/`echo $i | sed 's|/Kconfig.*||'`
|
||||
cp $i ${pkgdir}/usr/src/linux-${_kernver}/$i
|
||||
done
|
||||
|
||||
chown -R root.root ${pkgdir}/usr/src/linux-${_kernver}
|
||||
find ${pkgdir}/usr/src/linux-${_kernver} -type d -exec chmod 755 {} \;
|
||||
# strip scripts directory
|
||||
find ${pkgdir}/usr/src/linux-${_kernver}/scripts -type f -perm -u+w 2>/dev/null | while read binary ; do
|
||||
case "$(file -bi "$binary")" in
|
||||
*application/x-sharedlib*) # Libraries (.so)
|
||||
/usr/bin/strip $STRIP_SHARED "$binary";;
|
||||
*application/x-archive*) # Libraries (.a)
|
||||
/usr/bin/strip $STRIP_STATIC "$binary";;
|
||||
*application/x-executable*) # Binaries
|
||||
/usr/bin/strip $STRIP_BINARIES "$binary";;
|
||||
esac
|
||||
done
|
||||
|
||||
# remove unneeded architectures
|
||||
rm -rf ${pkgdir}/usr/src/linux-${_kernver}/arch/{alpha,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,x86,xtensa}
|
||||
}
|
466
core/kernel26-orion/archlinuxarm.patch
Normal file
466
core/kernel26-orion/archlinuxarm.patch
Normal file
|
@ -0,0 +1,466 @@
|
|||
diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/dockstar-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2011-05-18 22:06:34.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2011-07-01 13:18:36.000000000 -0600
|
||||
@@ -19,7 +19,6 @@
|
||||
#include <asm/mach-types.h>
|
||||
#include <asm/mach/arch.h>
|
||||
#include <mach/kirkwood.h>
|
||||
-#include <plat/mvsdio.h>
|
||||
#include "common.h"
|
||||
#include "mpp.h"
|
||||
|
||||
@@ -33,6 +32,10 @@
|
||||
.offset = MTDPART_OFS_NXTBLK,
|
||||
.size = SZ_4M
|
||||
}, {
|
||||
+ .name = "pogoplug",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = SZ_32M
|
||||
+ }, {
|
||||
.name = "root",
|
||||
.offset = MTDPART_OFS_NXTBLK,
|
||||
.size = MTDPART_SIZ_FULL
|
||||
@@ -45,17 +48,17 @@
|
||||
|
||||
static struct gpio_led dockstar_led_pins[] = {
|
||||
{
|
||||
- .name = "dockstar:green:health",
|
||||
+ .name = "status:green:health",
|
||||
.default_trigger = "default-on",
|
||||
.gpio = 46,
|
||||
.active_low = 1,
|
||||
},
|
||||
{
|
||||
- .name = "dockstar:orange:misc",
|
||||
+ .name = "status:orange:fault",
|
||||
.default_trigger = "none",
|
||||
.gpio = 47,
|
||||
.active_low = 1,
|
||||
- },
|
||||
+ }
|
||||
};
|
||||
|
||||
static struct gpio_led_platform_data dockstar_led_data = {
|
||||
@@ -73,8 +76,8 @@
|
||||
|
||||
static unsigned int dockstar_mpp_config[] __initdata = {
|
||||
MPP29_GPIO, /* USB Power Enable */
|
||||
- MPP46_GPIO, /* LED green */
|
||||
- MPP47_GPIO, /* LED orange */
|
||||
+ MPP47_GPIO, /* LED Orange */
|
||||
+ MPP46_GPIO, /* LED Green */
|
||||
0
|
||||
};
|
||||
|
||||
diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/goflexhome-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/goflexhome-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2011-07-01 13:25:34.000000000 -0600
|
||||
@@ -0,0 +1,123 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/goflexhome-setup.c
|
||||
+ *
|
||||
+ * Seagate GoFlex Home Setup
|
||||
+ *
|
||||
+ * This file is licensed under the terms of the GNU General Public
|
||||
+ * License version 2. This program is licensed "as is" without any
|
||||
+ * warranty of any kind, whether express or implied.
|
||||
+ */
|
||||
+
|
||||
+#include <linux/kernel.h>
|
||||
+#include <linux/init.h>
|
||||
+#include <linux/platform_device.h>
|
||||
+#include <linux/ata_platform.h>
|
||||
+#include <linux/mtd/partitions.h>
|
||||
+#include <linux/mv643xx_eth.h>
|
||||
+#include <linux/gpio.h>
|
||||
+#include <linux/leds.h>
|
||||
+#include <asm/mach-types.h>
|
||||
+#include <asm/mach/arch.h>
|
||||
+#include <mach/kirkwood.h>
|
||||
+#include "common.h"
|
||||
+#include "mpp.h"
|
||||
+
|
||||
+static struct mtd_partition goflexhome_nand_parts[] = {
|
||||
+ {
|
||||
+ .name = "u-boot",
|
||||
+ .offset = 0,
|
||||
+ .size = SZ_1M
|
||||
+ }, {
|
||||
+ .name = "uImage",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = SZ_2M + SZ_4M
|
||||
+ }, {
|
||||
+ .name = "root",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = MTDPART_SIZ_FULL
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static struct mv643xx_eth_platform_data goflexhome_ge00_data = {
|
||||
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
||||
+};
|
||||
+
|
||||
+static struct mv_sata_platform_data goflexhome_sata_data = {
|
||||
+ .n_ports = 1,
|
||||
+};
|
||||
+
|
||||
+static struct gpio_led goflexhome_led_pins[] = {
|
||||
+ {
|
||||
+ .name = "status:green:health",
|
||||
+ .default_trigger = "default-on",
|
||||
+ .gpio = 46,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:orange:fault",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 47,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:misc",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 40,
|
||||
+ .active_low = 0,
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+static struct gpio_led_platform_data goflexhome_led_data = {
|
||||
+ .leds = goflexhome_led_pins,
|
||||
+ .num_leds = ARRAY_SIZE(goflexhome_led_pins),
|
||||
+};
|
||||
+
|
||||
+static struct platform_device goflexhome_leds = {
|
||||
+ .name = "leds-gpio",
|
||||
+ .id = -1,
|
||||
+ .dev = {
|
||||
+ .platform_data = &goflexhome_led_data,
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+static unsigned int goflexhome_mpp_config[] __initdata = {
|
||||
+ MPP29_GPIO, /* USB Power Enable */
|
||||
+ MPP47_GPIO, /* LED Orange */
|
||||
+ MPP46_GPIO, /* LED Green */
|
||||
+ MPP40_GPIO, /* LED White */
|
||||
+ 0
|
||||
+};
|
||||
+
|
||||
+static void __init goflexhome_init(void)
|
||||
+{
|
||||
+ /*
|
||||
+ * Basic setup. Needs to be called early.
|
||||
+ */
|
||||
+ kirkwood_init();
|
||||
+
|
||||
+ /* setup gpio pin select */
|
||||
+ kirkwood_mpp_conf(goflexhome_mpp_config);
|
||||
+
|
||||
+ kirkwood_uart0_init();
|
||||
+ kirkwood_nand_init(ARRAY_AND_SIZE(goflexhome_nand_parts), 25);
|
||||
+
|
||||
+ if (gpio_request(29, "USB Power Enable") != 0 ||
|
||||
+ gpio_direction_output(29, 1) != 0)
|
||||
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
|
||||
+ kirkwood_ehci_init();
|
||||
+ kirkwood_ge00_init(&goflexhome_ge00_data);
|
||||
+ kirkwood_sata_init(&goflexhome_sata_data);
|
||||
+
|
||||
+ platform_device_register(&goflexhome_leds);
|
||||
+}
|
||||
+
|
||||
+MACHINE_START(GOFLEXHOME, "Seagate GoFlex Home")
|
||||
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
|
||||
+ .boot_params = 0x00000100,
|
||||
+ .init_machine = goflexhome_init,
|
||||
+ .map_io = kirkwood_map_io,
|
||||
+ .init_early = kirkwood_init_early,
|
||||
+ .init_irq = kirkwood_init_irq,
|
||||
+ .timer = &kirkwood_timer,
|
||||
+MACHINE_END
|
||||
+
|
||||
diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/goflexnet-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2011-07-01 13:25:49.000000000 -0600
|
||||
@@ -0,0 +1,176 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
|
||||
+ *
|
||||
+ * Seagate GoFlex Net Setup
|
||||
+ *
|
||||
+ * This file is licensed under the terms of the GNU General Public
|
||||
+ * License version 2. This program is licensed "as is" without any
|
||||
+ * warranty of any kind, whether express or implied.
|
||||
+ */
|
||||
+
|
||||
+#include <linux/kernel.h>
|
||||
+#include <linux/init.h>
|
||||
+#include <linux/platform_device.h>
|
||||
+#include <linux/ata_platform.h>
|
||||
+#include <linux/mtd/partitions.h>
|
||||
+#include <linux/mv643xx_eth.h>
|
||||
+#include <linux/gpio.h>
|
||||
+#include <linux/leds.h>
|
||||
+#include <asm/mach-types.h>
|
||||
+#include <asm/mach/arch.h>
|
||||
+#include <mach/kirkwood.h>
|
||||
+#include "common.h"
|
||||
+#include "mpp.h"
|
||||
+
|
||||
+static struct mtd_partition goflexnet_nand_parts[] = {
|
||||
+ {
|
||||
+ .name = "u-boot",
|
||||
+ .offset = 0,
|
||||
+ .size = SZ_1M
|
||||
+ }, {
|
||||
+ .name = "uImage",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = SZ_4M
|
||||
+ }, {
|
||||
+ .name = "pogoplug",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = SZ_32M
|
||||
+ }, {
|
||||
+ .name = "root",
|
||||
+ .offset = MTDPART_OFS_NXTBLK,
|
||||
+ .size = MTDPART_SIZ_FULL
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static struct mv643xx_eth_platform_data goflexnet_ge00_data = {
|
||||
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
||||
+};
|
||||
+
|
||||
+static struct mv_sata_platform_data goflexnet_sata_data = {
|
||||
+ .n_ports = 2,
|
||||
+};
|
||||
+
|
||||
+static struct gpio_led goflexnet_led_pins[] = {
|
||||
+ {
|
||||
+ .name = "status:green:health",
|
||||
+ .default_trigger = "default-on",
|
||||
+ .gpio = 46, // 0x4000
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:orange:fault",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 47, // 0x8000
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:left0",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 42, // 0x0400
|
||||
+ .active_low = 0,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:left1",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 43, // 0x0800
|
||||
+ .active_low = 0,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:left2",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 44, // 0x1000
|
||||
+ .active_low = 0,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:left3",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 45, // 0x2000
|
||||
+ .active_low = 0,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:right0",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 38, // 0x0040
|
||||
+ .active_low = 0,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:right1",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 39, // 0x0080
|
||||
+ .active_low = 0,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:right2",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 40, // 0x0100
|
||||
+ .active_low = 0,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:white:right3",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 41, // 0x0200
|
||||
+ .active_low = 0,
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+static struct gpio_led_platform_data goflexnet_led_data = {
|
||||
+ .leds = goflexnet_led_pins,
|
||||
+ .num_leds = ARRAY_SIZE(goflexnet_led_pins),
|
||||
+};
|
||||
+
|
||||
+static struct platform_device goflexnet_leds = {
|
||||
+ .name = "leds-gpio",
|
||||
+ .id = -1,
|
||||
+ .dev = {
|
||||
+ .platform_data = &goflexnet_led_data,
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+static unsigned int goflexnet_mpp_config[] __initdata = {
|
||||
+ MPP29_GPIO, /* USB Power Enable */
|
||||
+ MPP47_GPIO, /* LED Orange */
|
||||
+ MPP46_GPIO, /* LED Green */
|
||||
+ MPP45_GPIO, /* LED Left Capacity 3 */
|
||||
+ MPP44_GPIO, /* LED Left Capacity 2 */
|
||||
+ MPP43_GPIO, /* LED Left Capacity 1 */
|
||||
+ MPP42_GPIO, /* LED Left Capacity 0 */
|
||||
+ MPP41_GPIO, /* LED Right Capacity 3 */
|
||||
+ MPP40_GPIO, /* LED Right Capacity 2 */
|
||||
+ MPP39_GPIO, /* LED Right Capacity 1 */
|
||||
+ MPP38_GPIO, /* LED Right Capacity 0 */
|
||||
+ 0
|
||||
+};
|
||||
+
|
||||
+static void __init goflexnet_init(void)
|
||||
+{
|
||||
+ /*
|
||||
+ * Basic setup. Needs to be called early.
|
||||
+ */
|
||||
+ kirkwood_init();
|
||||
+
|
||||
+ /* setup gpio pin select */
|
||||
+ kirkwood_mpp_conf(goflexnet_mpp_config);
|
||||
+
|
||||
+ kirkwood_uart0_init();
|
||||
+ kirkwood_nand_init(ARRAY_AND_SIZE(goflexnet_nand_parts), 25);
|
||||
+
|
||||
+ if (gpio_request(29, "USB Power Enable") != 0 ||
|
||||
+ gpio_direction_output(29, 1) != 0)
|
||||
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
|
||||
+ kirkwood_ehci_init();
|
||||
+ kirkwood_ge00_init(&goflexnet_ge00_data);
|
||||
+ kirkwood_sata_init(&goflexnet_sata_data);
|
||||
+
|
||||
+ platform_device_register(&goflexnet_leds);
|
||||
+}
|
||||
+
|
||||
+MACHINE_START(GOFLEXNET, "Seagate GoFlex Net")
|
||||
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
|
||||
+ .boot_params = 0x00000100,
|
||||
+ .init_machine = goflexnet_init,
|
||||
+ .map_io = kirkwood_map_io,
|
||||
+ .init_early = kirkwood_init_early,
|
||||
+ .init_irq = kirkwood_init_irq,
|
||||
+ .timer = &kirkwood_timer,
|
||||
+MACHINE_END
|
||||
+
|
||||
diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/guruplug-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2011-05-18 22:06:34.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2011-07-01 13:18:36.000000000 -0600
|
||||
@@ -57,22 +57,24 @@
|
||||
|
||||
static struct gpio_led guruplug_led_pins[] = {
|
||||
{
|
||||
- .name = "guruplug:red:health",
|
||||
+ .name = "status:red:fault",
|
||||
+ .default_trigger = "none",
|
||||
.gpio = 46,
|
||||
.active_low = 1,
|
||||
},
|
||||
{
|
||||
- .name = "guruplug:green:health",
|
||||
+ .name = "status:green:health",
|
||||
+ .default_trigger = "default-on",
|
||||
.gpio = 47,
|
||||
.active_low = 1,
|
||||
},
|
||||
{
|
||||
- .name = "guruplug:red:wmode",
|
||||
+ .name = "status:red:wmode",
|
||||
.gpio = 48,
|
||||
.active_low = 1,
|
||||
},
|
||||
{
|
||||
- .name = "guruplug:green:wmode",
|
||||
+ .name = "status:green:wmode",
|
||||
.gpio = 49,
|
||||
.active_low = 1,
|
||||
},
|
||||
diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
||||
--- a/arch/arm/mach-kirkwood/Kconfig 2011-05-18 22:06:34.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig 2011-07-01 13:18:36.000000000 -0600
|
||||
@@ -64,6 +64,18 @@
|
||||
Say 'Y' here if you want your kernel to support the
|
||||
Seagate FreeAgent DockStar.
|
||||
|
||||
+config MACH_GOFLEXNET
|
||||
+ bool "Seagate GoFlex Net"
|
||||
+ help
|
||||
+ Say 'Y' here if you want your kernel to support the
|
||||
+ Seagate GoFlex Net.
|
||||
+
|
||||
+config MACH_GOFLEXHOME
|
||||
+ bool "Seagate GoFlex Home"
|
||||
+ help
|
||||
+ Say 'Y' here if you want your kernel to support the
|
||||
+ Seagate GoFlex Home.
|
||||
+
|
||||
config MACH_OPENRD
|
||||
bool
|
||||
|
||||
diff -urN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
|
||||
--- a/arch/arm/mach-kirkwood/Makefile 2011-05-18 22:06:34.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/Makefile 2011-07-01 13:18:36.000000000 -0600
|
||||
@@ -8,6 +8,8 @@
|
||||
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
|
||||
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
|
||||
obj-$(CONFIG_MACH_DOCKSTAR) += dockstar-setup.o
|
||||
+obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
|
||||
+obj-$(CONFIG_MACH_GOFLEXHOME) += goflexhome-setup.o
|
||||
obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
|
||||
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
|
||||
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
|
||||
diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/sheevaplug-setup.c
|
||||
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-05-18 22:06:34.000000000 -0600
|
||||
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-07-01 13:22:51.000000000 -0600
|
||||
@@ -64,7 +64,13 @@
|
||||
.active_low = 1,
|
||||
},
|
||||
{
|
||||
- .name = "plug:green:health",
|
||||
+ .name = "status:green:health",
|
||||
+ .default_trigger = "none",
|
||||
+ .gpio = 48,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "status:blue:health",
|
||||
.default_trigger = "default-on",
|
||||
.gpio = 49,
|
||||
.active_low = 1,
|
||||
@@ -87,7 +93,8 @@
|
||||
static unsigned int sheevaplug_mpp_config[] __initdata = {
|
||||
MPP29_GPIO, /* USB Power Enable */
|
||||
MPP46_GPIO, /* LED Red */
|
||||
- MPP49_GPIO, /* LED */
|
||||
+ MPP48_GPIO, /* LED Green */
|
||||
+ MPP49_GPIO, /* LED Blue */
|
||||
0
|
||||
};
|
||||
|
||||
@@ -95,7 +102,9 @@
|
||||
MPP29_GPIO, /* USB Power Enable */
|
||||
MPP44_GPIO, /* SD Write Protect */
|
||||
MPP47_GPIO, /* SD Card Detect */
|
||||
- MPP49_GPIO, /* LED Green */
|
||||
+ MPP46_GPIO, /* LED Red */
|
||||
+ MPP48_GPIO, /* LED Green */
|
||||
+ MPP49_GPIO, /* LED Blue */
|
||||
0
|
||||
};
|
||||
|
88
core/kernel26-orion/kernel26.install
Normal file
88
core/kernel26-orion/kernel26.install
Normal file
|
@ -0,0 +1,88 @@
|
|||
KERNEL_NAME=-orion
|
||||
KERNEL_VERSION=2.6.39-orion
|
||||
|
||||
post_install() {
|
||||
if [ -e "etc/machid.bin" ]; then
|
||||
echo "Saved machine type found. Patching Kernel"
|
||||
cp etc/machid.bin tmp/machid
|
||||
else
|
||||
echo "The kernel needs to be patched to include the machine type"
|
||||
echo ""
|
||||
echo "Please select your machine (enter any other value to skip):"
|
||||
|
||||
echo " 1. Marvell Orion-2 Development Board"
|
||||
echo " 2. Marvell Orion-NAS Reference Design"
|
||||
echo " 3. Buffalo Linkstation Pro/Live"
|
||||
echo " 4. Buffalo/Revogear Kurobox Pro"
|
||||
echo " 5. Buffalo Terastation Pro II/Live"
|
||||
echo " 6. Buffalo Linkstation Mini"
|
||||
echo " 7. Buffalo Linkstation LS-HGL"
|
||||
echo " 8. D-Link DNS-323"
|
||||
echo " 9. QNAP TS-109/TS-209"
|
||||
echo "10. QNAP TS-409"
|
||||
echo "11. Linksys WRT350N v2"
|
||||
echo "12. HP Media Vault mv2120"
|
||||
echo "13. LaCie Ethernet Disk mini V2"
|
||||
echo "14. LaCie Big Disk Network"
|
||||
echo "15. LaCie d2 Network"
|
||||
echo "16. LaCie 2Big Network"
|
||||
echo "17. Maxtor Shared Storage II"
|
||||
echo "18. Netgear WNR854T"
|
||||
echo "19. Marvell Orion-VoIP GE Reference Design"
|
||||
echo "20. Marvell Orion-VoIP FXO Reference Design"
|
||||
echo "21. Marvell Orion-1-90 AP GE Reference Design"
|
||||
echo "22. Buffalo Linkstation LiveV3 (LS-CHL)"
|
||||
echo -n "--> "
|
||||
|
||||
read arch
|
||||
|
||||
case $arch in
|
||||
1) devio > tmp/machid 'wl 0xe3a01c05,4' 'wl 0xe381104e,4' ;;
|
||||
2) devio > tmp/machid 'wl 0xe3a01c05,4' 'wl 0xe38110e4,4' ;;
|
||||
3) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe3811031,4' ;;
|
||||
4) devio > tmp/machid 'wl 0xe3a01c05,4' 'wl 0xe38110e5,4' ;;
|
||||
5) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe3811030,4' ;;
|
||||
6) devio > tmp/machid 'wl 0xe3a01c07,4' 'wl 0xe3811042,4' ;;
|
||||
7) devio > tmp/machid 'wl 0xe3a01c07,4' 'wl 0xe38110d5,4' ;;
|
||||
8) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe3811006,4' ;;
|
||||
9) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe381101d,4' ;;
|
||||
10) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe3811041,4' ;;
|
||||
11) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe3811061,4' ;;
|
||||
12) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe381109d,4' ;;
|
||||
13) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe38110dc,4' ;;
|
||||
14) devio > tmp/machid 'wl 0xe3a01c08,4' 'wl 0xe38110eb,4' ;;
|
||||
15) devio > tmp/machid 'wl 0xe3a01c08,4' 'wl 0xe38110ea,4' ;;
|
||||
16) devio > tmp/machid 'wl 0xe3a01c09,4' 'wl 0xe3811026,4' ;;
|
||||
17) devio > tmp/machid 'wl 0xe3a01c06,4' 'wl 0xe38110e6,4' ;;
|
||||
18) devio > tmp/machid 'wl 0xe3a01c07,4' 'wl 0xe3811009,4' ;;
|
||||
19) devio > tmp/machid 'wl 0xe3a01c07,4' 'wl 0xe3811014,4' ;;
|
||||
20) devio > tmp/machid 'wl 0xe3a01c07,4' 'wl 0xe381101a,4' ;;
|
||||
21) devio > tmp/machid 'wl 0xe3a01c07,4' 'wl 0xe3811066,4' ;;
|
||||
22) devio > tmp/machid 'wl 0xe3a01c0b,4' 'wl 0xe3811016,4' ;;
|
||||
esac
|
||||
|
||||
cp tmp/machid etc/machid.bin
|
||||
fi
|
||||
|
||||
echo "Generating patched zImage"
|
||||
cat boot/zImage >> tmp/machid
|
||||
|
||||
echo "Generating uImage"
|
||||
mkimage -A arm -O linux -T kernel -C none -a 0x00008000 -e 0x00008000 -d tmp/machid boot/uImage
|
||||
rm tmp/machid
|
||||
|
||||
# Just making sure kernel modules still work after we moved to .gz
|
||||
/sbin/depmod ${KERNEL_VERSION}
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
KERNEL_VERSION=2.6.39-orion
|
||||
}
|
||||
|
||||
op=$1
|
||||
shift
|
||||
$op $*
|
17
core/kernel26-orion/kernel26.preset
Normal file
17
core/kernel26-orion/kernel26.preset
Normal file
|
@ -0,0 +1,17 @@
|
|||
# mkinitcpio preset file for kernel26
|
||||
|
||||
########################################
|
||||
# DO NOT EDIT THIS LINE:
|
||||
source /etc/mkinitcpio.d/kernel26.kver
|
||||
########################################
|
||||
ALL_config="/etc/mkinitcpio.conf"
|
||||
|
||||
PRESETS=('default' 'fallback')
|
||||
|
||||
#default_config="/etc/mkinitcpio.conf"
|
||||
default_image="/boot/kernel26.img"
|
||||
#default_options=""
|
||||
|
||||
#fallback_config="/etc/mkinitcpio.conf"
|
||||
fallback_image="/boot/kernel26-fallback.img"
|
||||
fallback_options="-S autodetect"
|
Loading…
Reference in a new issue