community/rubberband to 1.9-1

This commit is contained in:
Kevin Mihelich 2020-09-11 14:03:42 +00:00
parent 09634823b1
commit 35faff7812
2 changed files with 14 additions and 11 deletions

View file

@ -1,4 +1,4 @@
From 44dd88d1e683d1695524b0a52712146a2713f031 Mon Sep 17 00:00:00 2001
From 6a926f8792843ec5fc13885259bd8fbbf55b5a0b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 12 Jun 2018 17:37:24 -0600
Subject: [PATCH] fix armv5 build
@ -8,7 +8,7 @@ Subject: [PATCH] fix armv5 build
1 file changed, 14 deletions(-)
diff --git a/src/system/sysutils.cpp b/src/system/sysutils.cpp
index 64f18bb..c11c2d7 100644
index 0b30b09..cd9751a 100644
--- a/src/system/sysutils.cpp
+++ b/src/system/sysutils.cpp
@@ -189,20 +189,6 @@ void system_specific_initialise()
@ -33,5 +33,5 @@ index 64f18bb..c11c2d7 100644
void system_specific_application_initialise()
--
2.16.2
2.28.0

View file

@ -6,20 +6,22 @@
# - patch to fix build on v5
pkgname=rubberband
pkgver=1.8.2
pkgrel=4
pkgver=1.9
pkgrel=1
pkgdesc="Time-stretching and pitch-shifting audio library and utility"
arch=('x86_64')
url="https://www.breakfastquay.com/rubberband/"
license=('GPL2')
depends=('fftw' 'gcc-libs' 'glibc' 'libsamplerate' 'libsndfile'
'libvamp-sdk.so')
makedepends=('ladspa' 'java-environment')
depends=('gcc-libs' 'glibc')
makedepends=('fftw' 'ladspa' 'java-environment' 'libsamplerate' 'libsndfile'
'vamp-plugin-sdk')
provides=('librubberband.so' 'librubberband-jni.so')
source=("$pkgname-$pkgver.tar.gz::https://github.com/breakfastquay/rubberband/archive/v$pkgver.tar.gz"
'0001-fix-armv5-build.patch')
sha512sums=('b70e41fb1f68487d67b3935682100138ba898adeec9c8e7f8caa30f7bc94389c847d72a1b0b04f042d16d4b57019cc82c0fe79c8f302c3174e603e9bd0289abf'
'a67d567afba2dc5439a58a0e099ad574ccb8c2c7544185a818ce5ae60c344c3affdcfbf69dcbc8db37bed955fb7388bd7981b8172e3ec56986032b8be0828ec2')
sha512sums=('4899f1def498e8e8dabf5d690d9716cbec9f6b7836776496fef2089dab75f52470128325b3b653a3136e5b226a31120869f028c8c9af9afac381700c7c57ccb5'
'2b9935a702c1198eae93e00b0c88429737064b0d3a252f314044eef02e1c8a09ff9c98124be6339b502a5821412e6a45f67860290a88f7295c2d05c060efcb7c')
b2sums=('88fc7c8b91e9ef7e78c6a00b08f165f3c8a14feefc82f972fdfe438272b64bd458840bc1a384b0f5da431085251e6e423404d26ce701900f83faeaa47b986b16'
'4a28b09d40a60b7bddd939690999137a864fafe1aaef315bf0ef89c69d85751ebda671ad8f132e2e9e7b518180c8c0751288bc7cb07f3c7496620a33a1509b91')
prepare() {
cd "$pkgname-$pkgver"
@ -37,9 +39,10 @@ build() {
}
package() {
depends+=('libfftw3.so' 'libsamplerate.so' 'libsndfile.so' 'libvamp-sdk.so')
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
# docs
install -vDm 644 {CHANGELOG,README.txt} \
install -vDm 644 {CHANGELOG,README.md} \
-t "${pkgdir}/usr/share/doc/${pkgname}/"
}