mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/krita to 4.4.1-7
This commit is contained in:
parent
745a591859
commit
360d214733
2 changed files with 20 additions and 4 deletions
|
@ -6,28 +6,31 @@
|
||||||
pkgname=krita
|
pkgname=krita
|
||||||
_pkgver=4.4.1
|
_pkgver=4.4.1
|
||||||
pkgver=${_pkgver/-/}
|
pkgver=${_pkgver/-/}
|
||||||
pkgrel=6
|
pkgrel=7
|
||||||
pkgdesc="Edit and paint images"
|
pkgdesc="Edit and paint images"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="https://krita.org"
|
url="https://krita.org"
|
||||||
license=(GPL3)
|
license=(GPL3)
|
||||||
depends=(kitemviews kitemmodels ki18n kcompletion kguiaddons kcrash qt5-svg qt5-multimedia quazip
|
depends=(kitemviews kitemmodels ki18n kcompletion kguiaddons kcrash qt5-svg qt5-multimedia quazip
|
||||||
gsl libraw exiv2 openexr fftw boost-libs giflib openjpeg2 hicolor-icon-theme)
|
gsl libraw exiv2 openexr fftw giflib openjpeg2 hicolor-icon-theme)
|
||||||
makedepends=(extra-cmake-modules kdoctools boost eigen poppler-qt5 opencolorio python-pyqt5 libheif
|
makedepends=(extra-cmake-modules kdoctools boost eigen poppler-qt5 opencolorio python-pyqt5 libheif
|
||||||
qt5-tools sip5 kseexpr)
|
qt5-tools sip5 kseexpr)
|
||||||
optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio: for the LUT docker'
|
optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio: for the LUT docker'
|
||||||
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter'
|
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter'
|
||||||
'kseexpr: SeExpr generator layer' 'kimageformats: PSD support')
|
'kseexpr: SeExpr generator layer' 'kimageformats: PSD support')
|
||||||
source=("https://download.kde.org/stable/krita/$_pkgver/$pkgname-$_pkgver.tar.gz"{,.sig}
|
source=("https://download.kde.org/stable/krita/$_pkgver/$pkgname-$_pkgver.tar.gz"{,.sig}
|
||||||
krita-kseexpr.patch::"https://invent.kde.org/graphics/krita/commit/bdebaf91.patch")
|
krita-kseexpr.patch::"https://invent.kde.org/graphics/krita/commit/bdebaf91.patch"
|
||||||
|
krita-c++14.patch)
|
||||||
sha256sums=('6f2daf068e4e5cef8a738ab47da443dc82ad1463090a4a1544b35201272c3817'
|
sha256sums=('6f2daf068e4e5cef8a738ab47da443dc82ad1463090a4a1544b35201272c3817'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'6aeec0c8d6bc29ae81e7dd1d971663c32cc0137888da4a1b4f50a69fc4491d80')
|
'6aeec0c8d6bc29ae81e7dd1d971663c32cc0137888da4a1b4f50a69fc4491d80'
|
||||||
|
'de84c3c1685e48392d4fb07daab56068cacfc2a846a52a9915b5f3e08357abd1')
|
||||||
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD' # Boudewijn Rempt <foundation@krita.org>
|
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD' # Boudewijn Rempt <foundation@krita.org>
|
||||||
'E9FB29E74ADEACC5E3035B8AB69EB4CF7468332F') # Dmitry Kazakov (main key) <dimula73@gmail.com>
|
'E9FB29E74ADEACC5E3035B8AB69EB4CF7468332F') # Dmitry Kazakov (main key) <dimula73@gmail.com>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
patch -d $pkgname-$pkgver -p1 -i ../krita-kseexpr.patch # Port to rebranded seexpr
|
patch -d $pkgname-$pkgver -p1 -i ../krita-kseexpr.patch # Port to rebranded seexpr
|
||||||
|
patch -d $pkgname-$pkgver -p1 -i ../krita-c++14.patch # Fix build with boost 1.75
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
13
extra/krita/krita-c++14.patch
Normal file
13
extra/krita/krita-c++14.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index 48d445b030..fe9bcb4765 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -7,7 +7,7 @@ cmake_minimum_required(VERSION 3.0.0 FATAL_ERROR)
|
||||||
|
set(MIN_QT_VERSION 5.9.0)
|
||||||
|
set(MIN_FRAMEWORKS_VERSION 5.44.0)
|
||||||
|
|
||||||
|
-set( CMAKE_CXX_STANDARD 11 )
|
||||||
|
+set( CMAKE_CXX_STANDARD 14 )
|
||||||
|
set( CMAKE_CXX_STANDARD_REQUIRED ON )
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue