mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/ffmpeg to 3.3.3-2
This commit is contained in:
parent
ba7f8a441a
commit
361c077edc
2 changed files with 106 additions and 3 deletions
|
@ -10,7 +10,7 @@
|
|||
|
||||
pkgname=ffmpeg
|
||||
pkgver=3.3.3
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
epoch=1
|
||||
pkgdesc='Complete solution to record, convert and stream audio and video'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -29,10 +29,18 @@ optdepends=('ladspa: LADSPA filters')
|
|||
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
|
||||
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
|
||||
'libswscale.so')
|
||||
source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc})
|
||||
source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
|
||||
'ffmpeg-openjpeg2.2.patch')
|
||||
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
|
||||
sha256sums=('d2a9002cdc6b533b59728827186c044ad02ba64841f1b7cd6c21779875453a1e'
|
||||
'SKIP')
|
||||
'SKIP'
|
||||
'490598f78d7879af8ef5b8d7f92ada83d0ee64f9609f6c7b989eb331c2539f68')
|
||||
|
||||
prepare() {
|
||||
cd ffmpeg-${pkgver}
|
||||
|
||||
patch -Np1 -i ../ffmpeg-openjpeg2.2.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ffmpeg-${pkgver}
|
||||
|
|
95
extra/ffmpeg/ffmpeg-openjpeg2.2.patch
Normal file
95
extra/ffmpeg/ffmpeg-openjpeg2.2.patch
Normal file
|
@ -0,0 +1,95 @@
|
|||
diff -rupN ffmpeg-3.3.3.orig/configure ffmpeg-3.3.3/configure
|
||||
--- ffmpeg-3.3.3.orig/configure 2017-07-29 19:49:29.000000000 +0200
|
||||
+++ ffmpeg-3.3.3/configure 2017-08-15 13:21:28.782566614 +0200
|
||||
@@ -1875,6 +1875,7 @@ HEADERS_LIST="
|
||||
machine_ioctl_meteor_h
|
||||
malloc_h
|
||||
opencv2_core_core_c_h
|
||||
+ openjpeg_2_2_openjpeg_h
|
||||
openjpeg_2_1_openjpeg_h
|
||||
openjpeg_2_0_openjpeg_h
|
||||
openjpeg_1_5_openjpeg_h
|
||||
@@ -5805,7 +5806,9 @@ enabled libopencv && { check_hea
|
||||
require opencv opencv2/core/core_c.h cvCreateImageHeader -lopencv_core -lopencv_imgproc; } ||
|
||||
require_pkg_config opencv opencv/cxcore.h cvCreateImageHeader; }
|
||||
enabled libopenh264 && require_pkg_config openh264 wels/codec_api.h WelsGetCodecVersion
|
||||
-enabled libopenjpeg && { { check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
+enabled libopenjpeg && { { check_lib openjpeg-2.2/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
+ check_lib openjpeg-2.2/openjpeg.h opj_version -lopenjp2 ||
|
||||
+ { check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 ||
|
||||
{ check_lib openjpeg-2.0/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
{ check_lib openjpeg-1.5/openjpeg.h opj_version -lopenjpeg -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
|
||||
diff -rupN ffmpeg-3.3.3.orig/libavcodec/libopenjpegdec.c ffmpeg-3.3.3/libavcodec/libopenjpegdec.c
|
||||
--- ffmpeg-3.3.3.orig/libavcodec/libopenjpegdec.c 2017-07-29 19:49:30.000000000 +0200
|
||||
+++ ffmpeg-3.3.3/libavcodec/libopenjpegdec.c 2017-08-15 13:21:28.869233484 +0200
|
||||
@@ -34,7 +34,9 @@
|
||||
#include "internal.h"
|
||||
#include "thread.h"
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H
|
||||
+# include <openjpeg-2.2/openjpeg.h>
|
||||
+#elif HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
# include <openjpeg-2.1/openjpeg.h>
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# include <openjpeg-2.0/openjpeg.h>
|
||||
@@ -44,7 +46,7 @@
|
||||
# include <openjpeg.h>
|
||||
#endif
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# define OPENJPEG_MAJOR_VERSION 2
|
||||
# define OPJ(x) OPJ_##x
|
||||
#else
|
||||
@@ -429,7 +431,7 @@ static int libopenjpeg_decode_frame(AVCo
|
||||
opj_stream_set_read_function(stream, stream_read);
|
||||
opj_stream_set_skip_function(stream, stream_skip);
|
||||
opj_stream_set_seek_function(stream, stream_seek);
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &reader, NULL);
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &reader);
|
||||
diff -rupN ffmpeg-3.3.3.orig/libavcodec/libopenjpegenc.c ffmpeg-3.3.3/libavcodec/libopenjpegenc.c
|
||||
--- ffmpeg-3.3.3.orig/libavcodec/libopenjpegenc.c 2017-07-29 19:49:30.000000000 +0200
|
||||
+++ ffmpeg-3.3.3/libavcodec/libopenjpegenc.c 2017-08-15 13:21:28.869233484 +0200
|
||||
@@ -32,7 +32,9 @@
|
||||
#include "avcodec.h"
|
||||
#include "internal.h"
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H
|
||||
+# include <openjpeg-2.2/openjpeg.h>
|
||||
+#elif HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
# include <openjpeg-2.1/openjpeg.h>
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# include <openjpeg-2.0/openjpeg.h>
|
||||
@@ -42,7 +44,7 @@
|
||||
# include <openjpeg.h>
|
||||
#endif
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
# define OPENJPEG_MAJOR_VERSION 2
|
||||
# define OPJ(x) OPJ_##x
|
||||
#else
|
||||
@@ -305,7 +307,7 @@ static av_cold int libopenjpeg_encode_in
|
||||
|
||||
opj_set_default_encoder_parameters(&ctx->enc_params);
|
||||
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
switch (ctx->cinema_mode) {
|
||||
case OPJ_CINEMA2K_24:
|
||||
ctx->enc_params.rsiz = OPJ_PROFILE_CINEMA_2K;
|
||||
@@ -769,7 +771,7 @@ static int libopenjpeg_encode_frame(AVCo
|
||||
opj_stream_set_write_function(stream, stream_write);
|
||||
opj_stream_set_skip_function(stream, stream_skip);
|
||||
opj_stream_set_seek_function(stream, stream_seek);
|
||||
-#if HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
+#if HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &writer, NULL);
|
||||
#elif HAVE_OPENJPEG_2_0_OPENJPEG_H
|
||||
opj_stream_set_user_data(stream, &writer);
|
Loading…
Reference in a new issue