diff --git a/community/supercollider/PKGBUILD b/community/supercollider/PKGBUILD
index 153ed961f..291ed9d6e 100644
--- a/community/supercollider/PKGBUILD
+++ b/community/supercollider/PKGBUILD
@@ -8,13 +8,13 @@
 _name=SuperCollider
 pkgname=supercollider
 pkgver=3.9.3
-pkgrel=4
+pkgrel=5
 pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
 arch=('x86_64')
 url="https://supercollider.github.io"
 license=('GPL3')
 groups=('pro-audio')
-depends=('boost-libs' 'fftw' 'jack' 'qt5-webkit' 'yaml-cpp')
+depends=('boost-libs' 'desktop-file-utils' 'fftw' 'jack' 'qt5-webkit' 'yaml-cpp')
 makedepends=('boost' 'cmake' 'emacs' 'qt5-tools')
 optdepends=('emacs: emacs interface'
             'gedit: gedit interface'
@@ -29,10 +29,15 @@ prepare() {
   mv -v "${_name}-Source" "${pkgname}-${pkgver}"
   cd "${pkgname}-${pkgver}"
   patch -Np1 -i ../boost-1.67.patch
+  # make sure the system boost headers are used
+  # https://github.com/supercollider/supercollider/issues/4096
+  rm -r external_libraries/boost
+  # fixing fundamental mathmatical problems:
+  # https://github.com/supercollider/supercollider/issues/4116
+  sed -e 's/-ffast-math/-fno-math-errno -fno-signaling-nans/' \
+      -i CMakeLists.txt
   # requires out-of-tree build
   mkdir -v bld
-  # make sure the system boost headers are used
-  rm -r external_libraries/boost
 }
 
 build() {