mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
aur/cifs-utils4: add dependency of samba4
This commit is contained in:
parent
fe6661315c
commit
36ef5345b0
2 changed files with 60 additions and 0 deletions
44
aur/cifs-utils4/PKGBUILD
Normal file
44
aur/cifs-utils4/PKGBUILD
Normal file
|
@ -0,0 +1,44 @@
|
|||
# $Id: PKGBUILD 176097 2013-01-27 12:26:02Z tpowa $
|
||||
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
||||
|
||||
#ALARM: moonman
|
||||
# -cifs-utils depends on libwbclient4 from samba4
|
||||
# -but smbclient4 from samba4 depends on cifs-utils
|
||||
# -hence the introduction of this pacakge.
|
||||
#
|
||||
# - changed the name to cifs-utils4
|
||||
# - introduced new variable _pkgbase
|
||||
|
||||
pkgname=cifs-utils4
|
||||
_pkgbase=cifs-utils
|
||||
pkgver=5.9
|
||||
pkgrel=1
|
||||
pkgdesc="CIFS filesystem user-space tools"
|
||||
arch=(arm)
|
||||
url="http://wiki.samba.org/index.php/LinuxCIFS_utils"
|
||||
license=('GPL')
|
||||
depends=('libcap-ng' 'keyutils' 'krb5' 'talloc' 'libwbclient4')
|
||||
source=(ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/$_pkgbase-$pkgver.tar.bz2
|
||||
fix-5.9-credentials.patch)
|
||||
conflicts=('cifs-utils')
|
||||
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$_pkgbase-$pkgver"
|
||||
# fix credentials
|
||||
patch -Np1 -i ../fix-5.9-credentials.patch
|
||||
# systemd support is broken in mount.cifs
|
||||
# https://bugs.archlinux.org/task/30958
|
||||
./configure --prefix=/usr --disable-systemd
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$_pkgbase-$pkgver"
|
||||
make DESTDIR="$pkgdir" ROOTSBINDIR=/usr/bin install
|
||||
# set mount.cifs uid, to enable none root mounting form fstab
|
||||
chmod +s $pkgdir/usr/bin/mount.cifs
|
||||
}
|
||||
md5sums=('6aa9c4347780872fefe5823ac06a8ff3')
|
||||
md5sums=('7164ad6f7963a31fcbffbe4f14a7cfc6'
|
||||
'2550d43af5bb734307cae22a09cd7710')
|
16
aur/cifs-utils4/fix-5.9-credentials.patch
Normal file
16
aur/cifs-utils4/fix-5.9-credentials.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
X-Git-Url: https://git.samba.org/?p=cifs-utils.git;a=blobdiff_plain;f=mount.cifs.c;h=40b77e92e3f734c606f522ccf279a0508ad64eab;hp=c7c3055cb890764937193b1d50d1f0fb7ae18826;hb=1a01f7c4b90695211d12291d7a24bec05b1f2922;hpb=739289ad3ce915e1ee2705ecd7ac4e907cd91405
|
||||
|
||||
diff --git a/mount.cifs.c b/mount.cifs.c
|
||||
index c7c3055..40b77e9 100644
|
||||
--- a/mount.cifs.c
|
||||
+++ b/mount.cifs.c
|
||||
@@ -581,7 +581,8 @@ static int open_cred_file(char *file_name,
|
||||
switch (parse_cred_line(line_buf + i, &temp_val)) {
|
||||
case CRED_USER:
|
||||
strlcpy(parsed_info->username, temp_val,
|
||||
- sizeof(parsed_info->domain));
|
||||
+ sizeof(parsed_info->username));
|
||||
+ parsed_info->got_user = 1;
|
||||
break;
|
||||
case CRED_PASS:
|
||||
i = set_password(parsed_info, temp_val);
|
Loading…
Reference in a new issue