diff --git a/community/linux-tools/PKGBUILD b/community/linux-tools/PKGBUILD
index a9712af16..c603964d3 100644
--- a/community/linux-tools/PKGBUILD
+++ b/community/linux-tools/PKGBUILD
@@ -11,7 +11,7 @@ pkgname=('linux-tools-meta'
          'cpupower'
          'usbip')
 pkgver=3.10
-pkgrel=1
+pkgrel=2
 license=('GPL2')
 arch=('i686' 'x86_64')
 url='http://www.kernel.org'
@@ -27,12 +27,13 @@ makedepends+=('pciutils')
 makedepends+=('glib2' 'sysfsutils')
 groups=("$pkgbase")
 source=("http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$pkgver.tar.xz"
-#        "http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.6.xz"
+        "http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.5.xz"
         'cpupower.default'
         'cpupower.systemd'
         'cpupower.service'
         'usbipd.service')
 sha256sums=('df27fa92d27a9c410bfe6c4a89f141638500d7eadcca5cce578954efc2ad3544'
+            'c96b69a10ef5ade798dcaa1867df156ccc9e173225d5aa427d00c6e89246e035'
             '4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
             'fbf6e0ce6eb0ef15703fe212958de6ca46e62188900b5e9f9272ed3cc9cfd54e'
             'a89284d0ecb556ca53a66d1c2087b5fd6d0a901ab2769cd3aebb93f4478905dc'
@@ -40,10 +41,8 @@ sha256sums=('df27fa92d27a9c410bfe6c4a89f141638500d7eadcca5cce578954efc2ad3544'
 
 prepare() {
   # apply stable patching set
-  if [[ -e "$srcdir"/patch-* ]]; then
-    msg2 'Applying stable patch set'
-    patch -N -p1 -i "$srcdir"/patch-*
-  fi
+  cd linux-$pkgver
+  patch -N -p1 -i "$srcdir/patch-$pkgver.5"
 }
  
 build() {