core/linux-armv7 to 4.18.0-1

This commit is contained in:
Kevin Mihelich 2018-08-14 13:53:47 +00:00
parent c55f3ed6be
commit 37096e2b41
16 changed files with 289 additions and 224 deletions

View file

@ -1,4 +1,4 @@
From ba0f7bad7435de617093d47ac4f0895a71dcee00 Mon Sep 17 00:00:00 2001
From 6cd78f818001a5e2caac7cadc3ffff95d752a021 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/14] ARM: atags: add support for Marvell's u-boot

View file

@ -1,4 +1,4 @@
From 89b2c1805d92a98ccc424ecad060cb08ba8e6211 Mon Sep 17 00:00:00 2001
From a383c6aaa67e862797d380a5163e633637358568 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/14] ARM: atags/fdt: retrieve MAC addresses from Marvell

View file

@ -1,4 +1,4 @@
From d441e0ca2b03d5cc7e5034efc6b15b56698b353f Mon Sep 17 00:00:00 2001
From 121aa156d4d107cf2b174c8eac89c7c473c43829 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/14] SMILE Plug device tree file
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 7e2424957809..431a7ca68751 100644
index 37a3de760d40..823a9ef2675d 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -1100,6 +1100,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@@ -1115,6 +1115,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-dlink-dns327l.dtb \
armada-370-mirabox.dtb \

View file

@ -1,4 +1,4 @@
From 23883cf4470afeb33dc9c171978df76f5470f4f0 Mon Sep 17 00:00:00 2001
From bca0f6d98bb3003178d962f83ba795d524460346 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/14] fix mvsdio eMMC timing
@ -12,7 +12,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index 210247b3d11a..1a1802dc9ef4 100644
index e22bbff89c8d..6b30c850ce07 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -93,7 +93,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
@ -24,7 +24,7 @@ index 210247b3d11a..1a1802dc9ef4 100644
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
@@ -614,6 +614,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
@@ -616,6 +616,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
if (m > MVSD_BASE_DIV_MAX)
m = MVSD_BASE_DIV_MAX;

View file

@ -1,4 +1,4 @@
From b8082b65dc78228d48e693c7bdf9dbe75a2043ff Mon Sep 17 00:00:00 2001
From 021b0a93050b75f56690bbe41fc470c77f7573c0 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/14] net/smsc95xx: Allow mac address to be set as a
@ -9,7 +9,7 @@ Subject: [PATCH 05/14] net/smsc95xx: Allow mac address to be set as a
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index 309b88acd3d0..7bc9feb891a1 100644
index 06b4d290784d..3be3b5a4a176 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -60,6 +60,7 @@

View file

@ -1,4 +1,4 @@
From 0cf9ae3f97075a40cd14e09c91de0468459c45d3 Mon Sep 17 00:00:00 2001
From 529b0cbe182106ce8b52cf465f3c54c3e0f12e1c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/14] set default cubietruck led triggers

View file

@ -1,4 +1,4 @@
From 8d59092709da9dc0f852411cb1bad579decd457c Mon Sep 17 00:00:00 2001
From adec3bf3f301ddb15994be72c92f43cc5569dd03 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/14] exynos4412-odroid: set higher minimum buck2 regulator
@ -13,10 +13,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
index d7ad07fd48f9..53c31c01713b 100644
index a09e46c9dbc0..d8117a820812 100644
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
@@ -418,7 +418,7 @@
@@ -423,7 +423,7 @@
buck2_reg: BUCK2 {
regulator-name = "vdd_arm";

View file

@ -1,4 +1,4 @@
From c26422909f777d60214288dfdb538fa8cf510c5f Mon Sep 17 00:00:00 2001
From 58b7a9138a44bef39a860611354c3dac0f558b1f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/14] ARM: dove: enable ethernet on D3Plug

View file

@ -1,4 +1,4 @@
From ce6183d0a8a9aea1a1d9acc9a85a05d73e741023 Mon Sep 17 00:00:00 2001
From 4ddcbb9ed40c97371724245d0b8d01d471bb6570 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:03 +0800
Subject: [PATCH 09/14] power: add power sequence library
@ -109,10 +109,10 @@ index 000000000000..554608e5f3b6
+.. kernel-doc:: drivers/power/pwrseq/core.c
+ :export:
diff --git a/MAINTAINERS b/MAINTAINERS
index 9c125f705f78..31042fc6c400 100644
index 96e98e206b0d..99339375209c 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11247,6 +11247,15 @@ F: drivers/firmware/psci*.c
@@ -11398,6 +11398,15 @@ F: drivers/firmware/psci*.c
F: include/linux/psci.h
F: include/uapi/linux/psci.h

View file

@ -1,4 +1,4 @@
From 5b874f0a1f92812bc797c01fa558f0ab4ed338ae Mon Sep 17 00:00:00 2001
From 1358757f34c7feff4aab541814c73f6cf3e83b69 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:05 +0800
Subject: [PATCH 10/14] usb: core: add power sequence handling for USB devices
@ -39,7 +39,7 @@ index 987fc5ba6321..bd09fc8ff763 100644
---help---
Universal Serial Bus (USB) is a specification for a serial bus
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index e3bf65e213cd..f6a739bbe754 100644
index fcae521df29b..0c708d3ef179 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -28,6 +28,7 @@
@ -126,7 +126,7 @@ index e3bf65e213cd..f6a739bbe754 100644
}
static int
@@ -3633,14 +3669,19 @@ static int hub_suspend(struct usb_interface *intf, pm_message_t msg)
@@ -3653,14 +3689,19 @@ static int hub_suspend(struct usb_interface *intf, pm_message_t msg)
/* stop hub_wq and related activity */
hub_quiesce(hub, HUB_SUSPEND);
@ -148,7 +148,7 @@ index e3bf65e213cd..f6a739bbe754 100644
return 0;
}
diff --git a/drivers/usb/core/hub.h b/drivers/usb/core/hub.h
index 4dc769ee9c74..b5d5c4818f90 100644
index 4accfb63f7dc..abe71c5e84cb 100644
--- a/drivers/usb/core/hub.h
+++ b/drivers/usb/core/hub.h
@@ -70,6 +70,7 @@ struct usb_hub {

View file

@ -1,4 +1,4 @@
From dd0ec5ddeff7c8435888e7250eb47954740e7e5d Mon Sep 17 00:00:00 2001
From 0b61e501bdfb883df4211fdc47d246df6af06e5a Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:06 +0800
Subject: [PATCH 11/14] ARM: dts: imx6qdl: Enable usb node children with <reg>
@ -14,10 +14,10 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
1 file changed, 6 insertions(+)
diff --git a/arch/arm/boot/dts/imx6qdl.dtsi b/arch/arm/boot/dts/imx6qdl.dtsi
index c003e62bf290..7ffd2f1f769e 100644
index 911141e24681..c74e9c7a83bf 100644
--- a/arch/arm/boot/dts/imx6qdl.dtsi
+++ b/arch/arm/boot/dts/imx6qdl.dtsi
@@ -983,6 +983,8 @@
@@ -965,6 +965,8 @@
usbh1: usb@2184200 {
compatible = "fsl,imx6q-usb", "fsl,imx27-usb";
@ -26,7 +26,7 @@ index c003e62bf290..7ffd2f1f769e 100644
reg = <0x02184200 0x200>;
interrupts = <0 40 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clks IMX6QDL_CLK_USBOH3>;
@@ -997,6 +999,8 @@
@@ -979,6 +981,8 @@
usbh2: usb@2184400 {
compatible = "fsl,imx6q-usb", "fsl,imx27-usb";
@ -35,7 +35,7 @@ index c003e62bf290..7ffd2f1f769e 100644
reg = <0x02184400 0x200>;
interrupts = <0 41 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clks IMX6QDL_CLK_USBOH3>;
@@ -1010,6 +1014,8 @@
@@ -992,6 +996,8 @@
usbh3: usb@2184600 {
compatible = "fsl,imx6q-usb", "fsl,imx27-usb";

View file

@ -1,4 +1,4 @@
From 01dea63eabb838525a193c32526791f6880c2b79 Mon Sep 17 00:00:00 2001
From 3e35057ab8b11c232a7c0edeea3299d53c6d600d Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:07 +0800
Subject: [PATCH 12/14] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
@ -17,11 +17,11 @@ Tested-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
1 file changed, 12 insertions(+), 14 deletions(-)
diff --git a/arch/arm/boot/dts/imx6qdl-udoo.dtsi b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
index 906387915dc5..d3cc0b666e0d 100644
index 4f27861bbb32..dead14b0d4bf 100644
--- a/arch/arm/boot/dts/imx6qdl-udoo.dtsi
+++ b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
@@ -9,6 +9,8 @@
*
@@ -5,6 +5,8 @@
* Author: Fabio Estevam <fabio.estevam@freescale.com>
*/
+#include <dt-bindings/gpio/gpio.h>
@ -29,7 +29,7 @@ index 906387915dc5..d3cc0b666e0d 100644
/ {
aliases {
backlight = &backlight;
@@ -65,17 +67,6 @@
@@ -61,17 +63,6 @@
#address-cells = <1>;
#size-cells = <0>;
@ -47,7 +47,7 @@ index 906387915dc5..d3cc0b666e0d 100644
reg_panel: regulator@1 {
compatible = "regulator-fixed";
reg = <1>;
@@ -201,7 +192,7 @@
@@ -197,7 +188,7 @@
pinctrl_usbh: usbhgrp {
fsl,pins = <
@ -56,7 +56,7 @@ index 906387915dc5..d3cc0b666e0d 100644
MX6QDL_PAD_NANDF_CS2__CCM_CLKO2 0x130b0
>;
};
@@ -272,9 +263,16 @@
@@ -268,9 +259,16 @@
&usbh1 {
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_usbh>;

View file

@ -1,4 +1,4 @@
From 29a513109fa45d1039d7f52aacb3fc4a188e60d4 Mon Sep 17 00:00:00 2001
From 9d40728e452daf4d77f8924e499814138dc5363c Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:08 +0800
Subject: [PATCH 13/14] ARM: dts: imx6q-evi: Fix onboard hub reset line

View file

@ -1,4 +1,4 @@
From ac139b06e1b309c605c65cea2d547cbba4ae5370 Mon Sep 17 00:00:00 2001
From a877c2568fc96a7a7ba89dd4cf0df20341df2a37 Mon Sep 17 00:00:00 2001
From: Ethan Tuttle <ethan@ethantuttle.com>
Date: Tue, 19 Jun 2018 21:31:08 -0700
Subject: [PATCH 14/14] ARM: mvebu: declare asm symbols as character arrays in

View file

@ -4,19 +4,19 @@
buildarch=4
pkgbase=linux-armv7
_srcname=linux-4.17
_srcname=linux-4.18
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=4.17.12
pkgver=4.18.0
pkgrel=1
rcnrel=armv7-x12
rcnrel=armv7-x2
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"http://rcn-ee.com/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
@ -38,24 +38,23 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'kernel_data_key.vbprivk'
'linux.preset'
'99-linux.hook')
md5sums=('5bb13a03274b66b56c85b26682e407d7'
'479952f5b12c20cc87bfd38d85dfcfed'
'9f720331c88c4ed0dd0a45bc3328116c'
'2ab00dfbba67e6411f7d840261079533'
'c8484367f1bd02ebf2fc1b9cdf3e2004'
'fa2402a5d90d651298d1bae0bebf785d'
'90e45476dfbbff52b921546f68ee4d78'
'32ddf11e2f4c66c474325037846e67a2'
'9423cfead77b13c537261cef1d8d068f'
'c16432d5a2cfedb5f8e924b6c23c8ed7'
'8cc861b5ee64aabd71cd4e97f79e6177'
'e83a03c82d1f9f9a3f9c796808c4160b'
'f14cbc2a326c7735d226a35039f3747d'
'e31b9705491a6bd8aad0442e248019e0'
'c414fe8e3ba3c180eaa54c9ebc5636aa'
'c6482625252e4051a144c6f7a9add062'
'480131c4aa1b4675cee89516bbd5c11f'
'd76638960cc41cb6a63ec8f07ffc852f'
md5sums=('bee5fe53ee1c3142b8f0c12c0d3348f9'
'8feb37c8b5788c2cdf1ca31f7d981661'
'fb218c1825366e722be83dd705d02822'
'bfeb8670a65fc8c14a7076ec623e9898'
'1651316b545214bb346af28f3925ccd0'
'625bc1c129c076f85a0794277438fbf3'
'95ffcc1c52475c1de2e5478c4896f0ca'
'5d8b1483f219edd892536e26663d16c7'
'8be87b6399b1cabbca28ee3592d5a9c9'
'0fcaafdce5964746e7de8c2bfd8a3421'
'd1f48c3560244b8d37084ec316b412d1'
'ec013d7dcb738d91ebe668addc96af8f'
'2d2e38af1b7db6d27babb8e072c144fc'
'eb51f5bbcf5b38956a0ba931d7898f07'
'cd9f373ec6e45e99610c9892a8e38100'
'8b896e19eac2b3bff797c48e737a166b'
'783fdfc4ed73feccdaccda071c593991'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -66,7 +65,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
git apply --whitespace=nowarn ../patch-${pkgver}
#git apply --whitespace=nowarn ../patch-${pkgver}
# RCN patch
git apply ../patch-${pkgver%.0}-${rcnrel}.diff

File diff suppressed because it is too large Load diff