Merge pull request #321 from aldrik/master

alarm/libcec-cubox: update
This commit is contained in:
Kevin Mihelich 2012-12-03 07:51:44 -08:00
commit 374f8b3ab3
3 changed files with 6 additions and 43 deletions

View file

@ -1,4 +1,4 @@
# pkgbuilds.git - README - 11/28/2012
# pkgbuilds.git - README - 2012-12-03
This repository hosts
[PKGBUILDs](https://wiki.archlinux.org/index.php/PKGBUILD) that have been
modified from the upstream [Arch Linux](http://archlinux.org) release in order
@ -37,7 +37,7 @@ you would on Arch, and we have included Yaourt to compile and install directly
from AUR (`yaourt -AS packagename`).
### alarm
Contains packages we have created or that have been submitted to us, to enable
Contains packages we have created or have been submitted to us, to enable
functionality on ARM systems in use by the community. These are our own or
have changed significantly enough from upstream or AUR to no longer qualify as
being in those respective locations here.

View file

@ -1,34 +0,0 @@
From 71fa379cb561f66d60e3507cd823ce3b438b4454 Mon Sep 17 00:00:00 2001
From: warped-rudi <r.ihle@s-t.de>
Date: Fri, 19 Oct 2012 07:56:19 +0200
Subject: [PATCH] Added adapter ID interface
---
src/lib/adapter/CuBox/NxpCECAdapterCommunication.h | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h b/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h
index 066c032..42e611a 100644
--- a/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h
+++ b/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h
@@ -39,6 +39,8 @@
#include "lib/adapter/AdapterCommunication.h"
#include <map>
+#define NXP_ADAPTER_VID 0x0471
+#define NXP_ADAPTER_PID 0x1001
namespace PLATFORM
{
@@ -84,6 +86,8 @@ namespace CEC
cec_vendor_id GetVendorId(void);
bool SupportsSourceLogicalAddress(const cec_logical_address address) { return address > CECDEVICE_TV && address <= CECDEVICE_BROADCAST; }
cec_adapter_type GetAdapterType(void) { return ADAPTERTYPE_TDA995x; }
+ uint16_t GetAdapterVendorId(void) const { return NXP_ADAPTER_VID; }
+ uint16_t GetAdapterProductId(void) const { return NXP_ADAPTER_PID; }
void HandleLogicalAddressLost(cec_logical_address oldAddress);
///}
--
1.7.12

View file

@ -3,7 +3,7 @@
buildarch=4
pkgname="libcec-cubox"
pkgver=2.0.1
pkgver=2.0.4
pkgrel=1
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter with support for cubox"
arch=('armv7h')
@ -13,11 +13,9 @@ depends=('udev' 'lockdev')
makedepends=('linux-headers-cubox')
conflicts=('libcec')
provides=('libcec')
source=("libcec-2.0.1.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/libcec-2.0.1" \
"0001-Added-adapter-ID-interface.patch")
_srcfolder=Pulse-Eight-libcec-6be84fc
sha256sums=('3dc6d7080a98dbfddcab4605a1267c24751b4334a95f845583f34d9f24c9269a' \
'4dd4a93d9cf29f383ae9ae10fd35c730160518caff9582fb4cc01cf0d316cd2c')
source=("libcec-${pkgver}.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/libcec-${pkgver}")
sha256sums=('652f8bddf8629eb4d14c93bc97efbeb7406482f69626302c8489df8e1fd8431f')
_srcfolder=Pulse-Eight-libcec-178d498
options=(!libtool)
build() {
@ -26,7 +24,6 @@ build() {
_kernel_release="$(pacman -Q linux-headers-cubox | grep -Eo "[^\ ]+$")-ARCH+"
cd "$pkgname-$pkgver"
patch -p1 -i "${srcdir}/${source[1]}"
autoreconf -vif
./configure --prefix=/usr --enable-cubox --enable-shared=lockdev \
--with-tda995x-toolkit-path="/usr/src/linux-${_kernel_release}/include/nxp_hdmi"