mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-aarch64 to 4.8.1-1
This commit is contained in:
parent
dc12ea6ff8
commit
3796bf5d44
4 changed files with 11 additions and 65 deletions
|
@ -1,7 +1,7 @@
|
||||||
From 86676a4ef2769fa5af6b3b59bfcbef96a93ed734 Mon Sep 17 00:00:00 2001
|
From db07c943b91eb4afcb52643ae867eba29dd7334c Mon Sep 17 00:00:00 2001
|
||||||
From: popcornmix <popcornmix@gmail.com>
|
From: popcornmix <popcornmix@gmail.com>
|
||||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||||
Subject: [PATCH 1/3] net/smsc95xx: Allow mac address to be set as a parameter
|
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
|
|
||||||
---
|
---
|
||||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
From 18215be4c5ba503580fd18abf1f1bd4ba7f80820 Mon Sep 17 00:00:00 2001
|
From a4338d28dfd8228fdcd8da798ca08ff66e53afe9 Mon Sep 17 00:00:00 2001
|
||||||
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
||||||
Date: Thu, 11 Aug 2016 18:50:50 +0100
|
Date: Thu, 11 Aug 2016 18:50:50 +0100
|
||||||
Subject: [PATCH 2/3] arm64: dts: qcom: Fix broken interrupt trigger settings
|
Subject: [PATCH 2/2] arm64: dts: qcom: Fix broken interrupt trigger settings
|
||||||
|
|
||||||
When a device uses the GIC as its interrupt controller and generates
|
When a device uses the GIC as its interrupt controller and generates
|
||||||
SPIs, only the values 1 (edge rising) and 4 (level high) are legal.
|
SPIs, only the values 1 (edge rising) and 4 (level high) are legal.
|
||||||
|
|
|
@ -1,52 +0,0 @@
|
||||||
From 3568393d18ecc488c8008c7d641dfeb659f2a68c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Linus Torvalds <torvalds@linux-foundation.org>
|
|
||||||
Date: Mon, 3 Oct 2016 21:03:48 -0700
|
|
||||||
Subject: [PATCH 3/3] Using BUG_ON() as an assert() is _never_ acceptable
|
|
||||||
|
|
||||||
That just generally kills the machine, and makes debugging only much
|
|
||||||
harder, since the traces may long be gone.
|
|
||||||
|
|
||||||
Debugging by assert() is a disease. Don't do it. If you can continue,
|
|
||||||
you're much better off doing so with a live machine where you have a
|
|
||||||
much higher chance that the report actually makes it to the system logs,
|
|
||||||
rather than result in a machine that is just completely dead.
|
|
||||||
|
|
||||||
The only valid situation for BUG_ON() is when continuing is not an
|
|
||||||
option, because there is massive corruption. But if you are just
|
|
||||||
verifying that something is true, you warn about your broken assumptions
|
|
||||||
(preferably just once), and limp on.
|
|
||||||
|
|
||||||
Fixes: 22f2ac51b6d6 ("mm: workingset: fix crash in shadow node shrinker caused by replace_page_cache_page()")
|
|
||||||
Cc: Johannes Weiner <hannes@cmpxchg.org>
|
|
||||||
Cc: Miklos Szeredi <miklos@szeredi.hu>
|
|
||||||
Cc: Andrew Morton <akpm@linux-foundation.org>
|
|
||||||
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
|
||||||
---
|
|
||||||
include/linux/swap.h | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/include/linux/swap.h b/include/linux/swap.h
|
|
||||||
index 4a529c9..e1d7614 100644
|
|
||||||
--- a/include/linux/swap.h
|
|
||||||
+++ b/include/linux/swap.h
|
|
||||||
@@ -257,7 +257,7 @@ static inline void workingset_node_pages_inc(struct radix_tree_node *node)
|
|
||||||
|
|
||||||
static inline void workingset_node_pages_dec(struct radix_tree_node *node)
|
|
||||||
{
|
|
||||||
- VM_BUG_ON(!workingset_node_pages(node));
|
|
||||||
+ VM_WARN_ON_ONCE(!workingset_node_pages(node));
|
|
||||||
node->count--;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -273,7 +273,7 @@ static inline void workingset_node_shadows_inc(struct radix_tree_node *node)
|
|
||||||
|
|
||||||
static inline void workingset_node_shadows_dec(struct radix_tree_node *node)
|
|
||||||
{
|
|
||||||
- VM_BUG_ON(!workingset_node_shadows(node));
|
|
||||||
+ VM_WARN_ON_ONCE(!workingset_node_shadows(node));
|
|
||||||
node->count -= 1U << RADIX_TREE_COUNT_SHIFT;
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
2.10.0
|
|
||||||
|
|
|
@ -7,24 +7,23 @@ pkgbase=linux-aarch64
|
||||||
_srcname=linux-4.8
|
_srcname=linux-4.8
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="AArch64 multi-platform"
|
_desc="AArch64 multi-platform"
|
||||||
pkgver=4.8.0
|
pkgver=4.8.1
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
arch=('aarch64')
|
arch=('aarch64')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||||
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||||
'0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch'
|
'0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch'
|
||||||
'0003-Using-BUG_ON-as-an-assert-is-_never_-acceptable.patch'
|
|
||||||
'config'
|
'config'
|
||||||
'linux.preset')
|
'linux.preset')
|
||||||
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
|
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
|
||||||
'7e48ab89ea66f92677eb1514163fc5f8'
|
'349734be5387f1605074515ad7207627'
|
||||||
'f064d74178f3155262f76224c9f3daa0'
|
'8ed2ac68adaec29a488542f613de6ad9'
|
||||||
'8f7dff8fca4221bf36019db0c905478f'
|
'e6fca8e5ddf634762d9ff7daa5e37a76'
|
||||||
'8c6b2df46bc0ca7b99d85da61fba64d6'
|
'8c6b2df46bc0ca7b99d85da61fba64d6'
|
||||||
'b5ef67d6086e20de7b82265f562f88b1')
|
'b5ef67d6086e20de7b82265f562f88b1')
|
||||||
|
|
||||||
|
@ -32,12 +31,11 @@ prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
# add upstream patch
|
# add upstream patch
|
||||||
#git apply --whitespace=nowarn ../patch-${pkgver}
|
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||||
|
|
||||||
# ALARM patches
|
# ALARM patches
|
||||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||||
git apply ../0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch
|
git apply ../0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch
|
||||||
git apply ../0003-Using-BUG_ON-as-an-assert-is-_never_-acceptable.patch
|
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue