mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/pacman: update patches
This commit is contained in:
parent
e8859eb299
commit
37a5fa3aa1
3 changed files with 10 additions and 10 deletions
|
@ -1,4 +1,4 @@
|
|||
From 638921aedf3a512ee272e7fc1a012acf615d2ace Mon Sep 17 00:00:00 2001
|
||||
From 913d684db0541a9204dd69f6a45e090839434a89 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 13 Sep 2014 18:58:16 -0600
|
||||
Subject: [PATCH 1/3] Sychronize filesystem
|
||||
|
@ -14,7 +14,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/lib/libalpm/trans.c b/lib/libalpm/trans.c
|
||||
index 5e2458e9..043b6305 100644
|
||||
index ef77e792..f716bc84 100644
|
||||
--- a/lib/libalpm/trans.c
|
||||
+++ b/lib/libalpm/trans.c
|
||||
@@ -241,6 +241,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 6e5837e7e451b3f2b87582c922abc610db9e0b40 Mon Sep 17 00:00:00 2001
|
||||
From c5d550b2c57b739f998775a6899866ee3f263e81 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 30 Jan 2016 17:19:03 -0700
|
||||
Subject: [PATCH 2/3] Revert "close stdin before running install scripts"
|
||||
|
@ -16,10 +16,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
|
||||
index 83160f00..579d5093 100644
|
||||
index 5df52657..7bb6d125 100644
|
||||
--- a/lib/libalpm/util.c
|
||||
+++ b/lib/libalpm/util.c
|
||||
@@ -640,7 +640,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
@@ -659,7 +659,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
|
||||
if(pid == 0) {
|
||||
/* this code runs for the child only (the actual chroot/exec) */
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From e237b55a291cdcc5d52e55b896fc437f8ed922c8 Mon Sep 17 00:00:00 2001
|
||||
From bf76b0751a6b6c616fd73cba6ea2196a41fe401c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 11 Mar 2016 20:11:24 -0700
|
||||
Subject: [PATCH 3/3] Revert "alpm_run_chroot: always connect parent2child
|
||||
|
@ -10,10 +10,10 @@ This reverts commit 1d6583a58da0904fb7feafd4a666391087955a7b.
|
|||
1 file changed, 7 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
|
||||
index 579d5093..02145ba7 100644
|
||||
index 7bb6d125..41d21b0b 100644
|
||||
--- a/lib/libalpm/util.c
|
||||
+++ b/lib/libalpm/util.c
|
||||
@@ -624,7 +624,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
@@ -643,7 +643,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
|
@ -22,7 +22,7 @@ index 579d5093..02145ba7 100644
|
|||
_alpm_log(handle, ALPM_LOG_ERROR, _("could not create pipe (%s)\n"), strerror(errno));
|
||||
retval = 1;
|
||||
goto cleanup;
|
||||
@@ -644,9 +644,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
@@ -663,9 +663,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
close(2);
|
||||
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
|
||||
while(dup2(child2parent_pipefd[HEAD], 2) == -1 && errno == EINTR);
|
||||
|
@ -37,7 +37,7 @@ index 579d5093..02145ba7 100644
|
|||
close(child2parent_pipefd[TAIL]);
|
||||
close(child2parent_pipefd[HEAD]);
|
||||
if(cwdfd >= 0) {
|
||||
@@ -693,16 +695,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
@@ -712,16 +714,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
|
||||
child2parent->events = POLLIN;
|
||||
fcntl(child2parent->fd, F_SETFL, O_NONBLOCK);
|
||||
close(child2parent_pipefd[HEAD]);
|
||||
|
|
Loading…
Reference in a new issue