community/blender to 2.79.b.git3.32432d91-12

This commit is contained in:
Kevin Mihelich 2018-12-05 20:53:49 +00:00
parent a34a654806
commit 37cdfc692c
3 changed files with 118 additions and 2 deletions

View file

@ -22,7 +22,7 @@ _gitcommit=32432d91bbec558cbd88e54aece61b0d641c1761
pkgname=blender
pkgver=2.79.b
[[ -n $_gitcommit ]] && pkgver=${pkgver}.git3.${_gitcommit:0:8}
pkgrel=11
pkgrel=12
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -46,7 +46,9 @@ source=("git://git.blender.org/blender-addons.git"
util_sseb.patch
openvdb3-abi.patch
stl_export_iter.patch
gcc8.patch)
gcc8.patch
opencollada1.patch
opencollada2.patch)
if [[ -n $_gittag ]]; then
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#tag=${_gittag}")
elif [[ -n $_gitcommit ]]; then
@ -64,6 +66,8 @@ sha512sums=('SKIP'
'2bd8c59ab8f163b6c7f89b6dfe8aacee3307dae6ecdc0d4878e1376ba29584c891171edd0a57f12241a98e0dd43efff0675a16708d34122bc22faebe3fd8e181'
'51f30acc407179f003d1dbec25fb47b0bf1fe8d2eb16e069a6ca83ab8b21f6032d636a42e0b140537ad1ad25ad38c52a87a2a33e51822729ab196fcef4682818'
'86f8d6c766644090bb59715b219db74f7acbe31dcd92dc1ecc32beedc1c894a98d2875e9078efa9994511b79e094277a943746dd602be6bc33ba37b7a8a41269'
'aea74c8d88e01703b46c5ee4e5a118aaeacfa0ace23e1fffd1b01d0395bafffa9012df22eca43050756f6dd8fb46c663eef1de3e061ca1911eaf1c2a0e01e58d'
'31d0f2045f88cbdb1d5720775aa49eff4672f06def1bbbd9f85da363e93143375cda84259a3e8c9000f3fe70c58ee7e1de791b5dc95d4982e559b43700bd0a2a'
'SKIP')
prepare() {
@ -84,6 +88,8 @@ prepare() {
patch -Np1 -i "$srcdir"/openvdb3-abi.patch
patch -Np1 -i "$srcdir"/stl_export_iter.patch
patch -Np1 -i "$srcdir"/gcc8.patch
patch -Np1 -i "$srcdir"/opencollada1.patch
patch -Np1 -i "$srcdir"/opencollada2.patch
}
build() {

View file

@ -0,0 +1,78 @@
commit 10c50d7dbf7578b35b3bf19a1948f556f9eb203b
Author: Gaia Clary <gaia.clary@machinimatrix.org>
Date: Tue Dec 4 19:11:33 2018 +0100
fix T58568 build errors when using collada 1.6.68 or newer
diff --git a/source/blender/collada/CMakeLists.txt b/source/blender/collada/CMakeLists.txt
index 293049a1a05..c250384b989 100644
--- a/source/blender/collada/CMakeLists.txt
+++ b/source/blender/collada/CMakeLists.txt
@@ -25,6 +25,18 @@
remove_strict_flags()
+FIND_FILE(_opencollada_with_animation_clip
+ NAMES
+ COLLADAFWAnimationClip.h
+ PATHS
+ ${OPENCOLLADA_INCLUDE_DIRS}
+ NO_DEFAULT_PATH
+ )
+
+IF(_opencollada_with_animation_clip)
+ add_compile_definitions(OPENCOLLADA_WITH_ANIMATION_CLIP)
+ENDIF()
+
set(INC
.
../blenkernel
diff --git a/source/blender/collada/DocumentImporter.cpp b/source/blender/collada/DocumentImporter.cpp
index 67fd9d648c7..24b7fc4317d 100644
--- a/source/blender/collada/DocumentImporter.cpp
+++ b/source/blender/collada/DocumentImporter.cpp
@@ -1349,6 +1349,19 @@ bool DocumentImporter::writeAnimationList(const COLLADAFW::AnimationList *animat
return anim_importer.write_animation_list(animationList);
}
+#if OPENCOLLADA_WITH_ANIMATION_CLIP
+// Since opencollada 1.6.68
+// called on post-process stage after writeVisualScenes
+bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip)
+{
+ if (mImportStage != General)
+ return true;
+
+ return true;
+ //return animation_clip_importer.write_animation_clip(animationClip); // TODO: implement import of AnimationClips
+}
+#endif
+
/** When this method is called, the writer must write the skin controller data.
* \return The writer should return true, if writing succeeded, false otherwise.*/
bool DocumentImporter::writeSkinControllerData(const COLLADAFW::SkinControllerData *skin)
diff --git a/source/blender/collada/DocumentImporter.h b/source/blender/collada/DocumentImporter.h
index 17e61326032..5e9f899d42c 100644
--- a/source/blender/collada/DocumentImporter.h
+++ b/source/blender/collada/DocumentImporter.h
@@ -49,8 +49,6 @@
#include "MeshImporter.h"
#include "ImportSettings.h"
-
-
struct bContext;
/** Importer class. */
@@ -108,6 +106,11 @@ public:
bool writeAnimationList(const COLLADAFW::AnimationList*);
+#if OPENCOLLADA_WITH_ANIMATION_CLIP
+ // Please enable this when building with Collada 1.6.65 or newer (also in DocumentImporter.cpp)
+ bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip);
+#endif
+
bool writeGeometry(const COLLADAFW::Geometry*);
bool writeMaterial(const COLLADAFW::Material*);

View file

@ -0,0 +1,32 @@
commit 22bba02bc8109f392fce50a24a4825390bca1bda
Author: Gaia Clary <gaia.clary@machinimatrix.org>
Date: Tue Dec 4 20:28:20 2018 +0100
fix T58568: used wrong case in variable name
diff --git a/source/blender/collada/DocumentImporter.cpp b/source/blender/collada/DocumentImporter.cpp
index 24b7fc4317d..7f93dd4823f 100644
--- a/source/blender/collada/DocumentImporter.cpp
+++ b/source/blender/collada/DocumentImporter.cpp
@@ -1352,7 +1352,7 @@ bool DocumentImporter::writeAnimationList(const COLLADAFW::AnimationList *animat
#if OPENCOLLADA_WITH_ANIMATION_CLIP
// Since opencollada 1.6.68
// called on post-process stage after writeVisualScenes
-bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip)
+bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *animationClip)
{
if (mImportStage != General)
return true;
diff --git a/source/blender/collada/DocumentImporter.h b/source/blender/collada/DocumentImporter.h
index 5e9f899d42c..110389030de 100644
--- a/source/blender/collada/DocumentImporter.h
+++ b/source/blender/collada/DocumentImporter.h
@@ -108,7 +108,7 @@ public:
#if OPENCOLLADA_WITH_ANIMATION_CLIP
// Please enable this when building with Collada 1.6.65 or newer (also in DocumentImporter.cpp)
- bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip);
+ bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *animationClip);
#endif
bool writeGeometry(const COLLADAFW::Geometry*);